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Introduction 

OpenCart 
OpenCart is free open source ecommerce platform for online merchants. OpenCart 
provides a professional and reliable foundation from which to build a successful online 
store. This foundation appeals to a wide variety of users; ranging from seasoned web 
developers looking for a user-friendly interface to use, to shop owners just launching 
their business online for the first time. OpenCart has an extensive amount of features 
that gives you a strong hold over the customization of your store. With OpenCart's tools, 
you can help your online shop live up to its fullest potential. 

OpenCart Documentation 
This guide serves as a resource to users needing direction in navigating the OpenCart 
interface. We detail the aspects involved with setting up your store: complete with 
keeping it up to date to the latest version, meeting the technical requirements, 
accessing the admin panel, and uninstallation. The User Guide covers the essentials 
tools used for managing your store front through the administration side. We will walk 
you through the important sections of the administration interface: Catalog, Extensions, 
Sales, Systems, and Reports. In this area we will cover which part of your store front 
each section is responsible for, and how you can modify them in the administration side 
to meet your store’s needs. Important store procedures, such as adding products to 
your store, keeping track of sales, managing customers, changing layouts, adding 
extensions, and more is explained in this guide. 

When you are finished reading this guide, you will be comfortable with using the 
OpenCart interface to set up your online shop and maintain it over time. 

System / Server requirements 

System Requirements 
OpenCart requires certain technical requirements to be met for the store to operate 
properly. First, a web server must be created to make the OpenCart store publicly 
available on the web. Domain names and hosting services can easily be purchased for 
an affordable price. 

When selecting a hosting service, you should check to see that these server 
requirements are provided and installed on their web servers: 

These extensions must be enabled for OpenCart to install properly on the web server. 



 Web Server (Apache suggested) 
 PHP 5.4+ 
 Database (MySQLi suggested) 

Required PHP libraries / modules 

 Curl 
 ZIP 
 Zlib 
 GD Library 
 Mcrypt 
 Mbstrings 
 Xml 

The above PHP extensions should be available by almost all hosting providers, during 
the install process it will check you have them all enabled. You should contact your 
hosting provider if one is missing. 

Installation 

Installing OpenCart 
This guide will walk you through how to successfully install and uninstall OpenCart. 

Downloading and unzipping OpenCart 
archive 
The latest version of OpenCart (v.3.0.2.0) can be downloaded from the OpenCart 
website (recommended for end user) or directly from Github (recommended for web 
developer). The download page also offers access to previous versions of OpenCart. 
Under the Downloads column, locate 3.0.2.0 and press the "Download Now" link directly 
across from it under the Action column. This will download the compressed archive of 
that version of OpenCart in a zip file. For OpenCart version 3.0.2.0, a file named 
"3.0.2.0-compiled.zip" will be downloaded. 



 

 If you don't have a program on your computer that can extract files from a zip 
file, WinRar can be downloaded for free. Unzipping the zip file will uncompress the 
OpenCart archive so the files can be accessed by a web server. 

When opening the zip file, the following files will be visible: 

 "upload" folder 
 "license.txt" file 
 "readme.txt" file 

The "upload" folder contains all the files needed to upload OpenCart to a web server. 
The "license.txt" file contains the license agreement regarding the use of OpenCart on 
your site. The "readme.text" file provides links to the current install and upgrade 
instructions on the OpenCart website. When you are ready, you can extract the files 
from the zip file to a location of your choice on your computer. 

Uploading OpenCart 
At this step you should have a web server established and the OpenCart archive 
extracted. We will now use File Transfer Protocol (FTP) client to upload these 
uncompressed files to a web server. 



Installing and configuring the FTP client

We recommend using Filezilla as your FTP client. Filezilla is a free F
transfer the OpenCart files to any web server specified. The FileZilla client (not the 
server) can be downloaded from
computer. 

When you open Filezilla you should see your computer's file directory on the left side. 
The next step is to locate where you saved the uncompressed OpenCart archive and 
click on the "upload" folder, and the files should appear below it. The directory needs to 
be left open as we continue. The right hand side is blank at the moment because the 
target website hasn't been connected to. When connected it will display the file directory 
of the web server. 

Before we continue, we need to make sure
about your website: 
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that you have the following information 



 the host name 
 username 
 password 

This information can be obtained by contacting your hosting provider. 

Connecting to the Site Manager 

Under the “File” menu, “Site Manager” should be opened in Filezilla. A window will pop 
up with the General tab open. You should fill in the information gathered above 
regarding hosting information, and press “Connect”. The right “Remote Site” side will 
now display the file directory of your website. 

 

Uploading OpenCart's files 

If you haven't already located the OpenCart upload folder on the left side, you need to 
do so now and keep it open. In the Remote Site directory (right side), you need to open 
the folder that the OpenCart shop will be located in. The location of shop varies based 
on whether the you want the shop to be seen on the main page, a sub-folder, a 
subdomain, etc. If you want to make OpenCart the main page, you would need to 
upload files to the root folder of their website. 



 Be aware that some hosting services require public files to be upload to a public director
as public_html, if they are to be visible on the website. You should check with your hosting 
provider to see where you can upload public files.

Once the location of the OpenCart shop has been determined, all the content within the 
“upload” folder on the computer's (left) side of Filezilla must be selected, right
and uploaded. Uploading all the files might take a few minutes on the FTP client.

 If you want the shop to be on the main page, for example www.shopnow.com, you must upload 
the contents of the “upload” folder, but not the “upload” folder itself. Including the “upload” folder 
will create a sub-folder, making the shop available only on www.shopnow.com/upload.

After Filezilla finishes uploading the files to the location specified, you s
same files on both the left side(computer) and on the right side (the website); as seen in 
the screenshot below: 

The Filezilla window should look similar
details). This means that the OpenCart files were successfully transferred the target 
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Go to the “Upload” folder and select all the files inside and zip it to a new zip file. Login 
your cPanel and click the “File Manager” to open a new tag in the browser. Upload the 
new zip file in your target path, it should be inside the public_html folder. After that you 
can right click the zip file and select “Extract" button and done. 

 

Creating a database for the shop 
The next step is to create a database on the MySQL server for OpenCart to store a 
shop's data on. You should log into the site’s control panel and locate MySQL 
Databases. Using MySQL Databases, you can create a new database by entering a 
database name and a username/password to access this database. The user that was 
just created needs to be added to the database, along with enabling all of the necessary 
permissions. We will use this database information later when we are configuring 
OpenCart using the auto-installer. 

Launch the auto-installer 
With a new database freshly created, we are now ready to install OpenCart directly onto 
a website. You should open up a web browser and enter in the web address of where 
they uploaded OpenCart. If the "install" folder in "upload" was uploaded correctly, you 
should be automatically greeted by the following page: 



 

This page is the installation page. The following steps will help you complete the 
installation process for OpenCart. 

Step 1. License 

You may read through the license, check "I agree to the license", and press “Continue”. 

Step 2. Pre-Installation 

This step checks to see if the web server has the technical requirements and correct 
permissions to setup OpenCart properly. If red marks are visible on #1 or #2, you need 
to make sure that these components are properly installed onto the web server. You 
should contact your hosting service if there are any issues with this. If there are red 
marks on #3 or #4, there might have been an issue with uploading the files using the 
FTP client. If everything is configured correctly and green marks are visible (as seen 
below), you may press "Continue". 



 

 As of version 2.3.0.2, the following files need to be renamed to continue to Step 3: 

 config-dist.php  config.php 
 admin/config-dist.php  config.php 



Step 3. Configuration 

You need to fill in the spaces below #1 by adding the database connection details 
(username/password, database name) established when you created the store's 
database using MySQL Databases. Under #2, you should create a new username and 
password for administration access to the OpenCart shop. When finished, you may 
press "Continue". 

 

Step 4. Finished 

Now that installation is complete, the "install" folder is no longer required. You should 
delete the “install” folder in the Remote Site section of Filezilla for security reasons. You 
now have the option to browse the frontend of your shop or choose to log into the 
administration side. 



 

After the install, you should make the necessary steps towards improving the security of 
your server and OpenCart store directory. These steps are detailed in Basic security 
practices. 

Installing vQmod 
vQmod for OpenCart lets you add modules to your store without modifying the core 
OpenCart code. See vQmod for more information on how to download and 
install vQmod for your store. 



Uninstalling OpenCart 
Uninstalling OpenCart is a quick and simple process. 

1. Delete the files/folders in the location you uploaded them to in Filezilla.   
2. Delete the OpenCart database from MySQL Databases or phpMyAdmin. 

 Once OpenCart is uninstalled, all product and customer information will be lost. You can save a 
backup database file in case you want to reinstall OpenCart at a later time. 
See Backup/Restore for more information. 

 
Getting Started 
There are a number of steps required after installing OpenCart to get started selling 
from your online store. This page is a helpful guide to getting started. An OpenCart 
store is comprised of a Frontend and Admin interface. This guide will primarily focus on 
Admin interface functions and settings. These settings should be tested on the frontend 
before your site is launched. Following the steps in this guide will get your store to a 
ready to use state from installation. This guide assumes that you have admin login 
credentials and are able to login to your store's Admin interface via /admin, for 
example: http://demo.opencart.com/admin/. 

System Settings 
Most General Settings are required. Under General Settings you will need to set your 
store's name, owner, address, email and phone number. These will be used for your 
store's contact page and order invoices. 



 

Store Settings 
Store Settings need to be changed from the default settings of "Your Store", etc., to 
your actual Store Name and a description of your store for search engines. 



 

Local Settings 
Local Settings allow you to choose the Country that your store is operating from. You 
can also choose the default currency for your store. If your store accepts multiple 
currencies, you will need to select whether OpenCart should automatically update 
based on current exchange rates. 



 

Image Settings 
Next, you will need to select a logo for your store and upload it via the Image 
Settings tab. The logo must be a suitable size and shape for your theme, and should 
ideally be a jpg or png file. You can also choose a favicon at this point. This is the small 
image that displays in a browser when you visit a site. Typically, favicons are 16px by 
16px, and OpenCart requires a png file for favicons. 

 



Server Settings 
There are two important settings under the Server tab of your OpenCart store's System 
Settings. 

1. SEO URLs. If you wish to have search engine optimized URLs in your store then you will 
need to set this to yes. You will also need to follow the instructions on setting up SEO 
URLs to make sure these work correctly, but it is an important step for getting the best 
possible result for your store from search engines. 

2. The Display Errors option should always be set to No for a live store. This will prevent 
your customers seeing any errors in your store's code while using your site. Your 
developer will still be able to diagnose and repair these issues using the error logs. 

Accepting Payments and Adding Taxes 
Once your settings are correct, you will need to select the payment gateway you wish to 
use. If your store needs to charge taxes on purchases, these should also be setup via 
your admin interface as described below. 

Payment Gateways 

OpenCart supports many Payment Gateways out of the box. If your payment gateway is 
not supported, you can find and install additional gateways from the OpenCart 
extension store. In order to choose the payment gateway your store will use, go to 
the Extensions menu, and the Payments submenu. This page will show you a list of all 
the available payment gateways. Your store can use more than one payment gateway. 

In order to enable payment gateways first click the Install link corresponding to the 
gateway you wish to enable, then click the Edit link to set it up for your payment 
account. The Order field on each payment gateway's settings allows you to select the 
order in which payment options are displayed on your checkout page. Lower numbered 
payment options will always be shown above higher numbered options. 



 

Taxes 

OpenCart offers a number of different Tax options by default. Taxes are location 
dependent, so you can charge different tax rates to customers in different geographical 
locations, according to local tax rules. Tax rates are set up under System > Localisation 
> Taxes > Tax Rates. If your required tax rate is not already present, you will need to 
create a new tax rate and add it. For example, the Tax Rate applicable to New Zealand 
is GST which is currently at 15%. New Zealand stores should therefore create a new 
Tax Rate called GST, set to 15%, and applicable to customers in the Geo Zone of New 
Zealand. 

If you have product specific tax rates, you need to define each of these tax rates under 
the Tax Rates page. You will later choose which tax rate applies to each product, so 
you will be able to manage your product specific taxes at the product level. 

Shipping Method 
Stores selling tangible goods will need to edit their shipping options. Shipping methods 
are selected under the Extensions > Shipping menu item. Just as with the Tax Rates 
above, you will need to Install and Edit the settings for the Shipping Methods your store 
will support. The documentation contains full instructions on setting your Shipping 
Method. 



 

Inventory Management 
OpenCart's installation includes demonstration data to help you see how to setup your 
OpenCart store's inventory. This 
includes Categories, Manufacturers, Options, Attributes and Products and some home 
page Banners. These are the Apple iPods that you see when you first visit your store's 
frontend after installation. In order to get started with your store, you will need to replace 
these demo items with the actual categories, manufacturers and products your store will 
sell. There are two recommended ways to do this: 

1. You can manually edit these under the Catalog menu in your OpenCart store's admin. 
2. You can use an import tool to simplify the upload of your products in bulk. This is more 

practical for larger inventories or dropshippers, and will allow you to remove all existing 
items and replace them at the same time. 

Extensions, Modules and Themes 
OpenCart functionality, look and feel are all controlled by modules and themes. The 
final step to get started with OpenCart is to check your Extensions > Modules page to 
ensure the functionality you want is enabled. The default banners can be modified 
under System > Banners, or removed via the Slideshow module at this point. You can 
also choose other modules that you wish to display, and the pages you wish to display 
them. The OpenCart defaults are sensible and will not necessarily need editing to get 



started, except for the default home page banners, which are for demonstration 
purposes only. 

If you do not find the functionality you need in your store, you can often add it as a 3rd 
Party Extension. 

Browsing the Store Front 

Browsing the Store Front 
This guide is intended to be used as an introduction to the OpenCart default store front. 
The store front reveals how the customer views and interacts with the store. 

The default theme 
OpenCart comes with a default theme after a fresh installation: 



 

The products seen above are included as sample data with the OpenCart installation. 
These products can easily be removed and replaced with the shop's products later. 

This guide will cover the basics of browsing the store front with the default theme. You 
can find an ever expanding list of available themes at the OpenCart Extension 
Directory. 



Navigating the shop 
The OpenCart default theme makes navigating a shop's products easily accessible to its 
customers. 

Anatomy of the home page 

The home page is arguably the most important page in the shop, in terms of 
presentation. In most cases, this will be the first page that a customer interacts with 
(especially if they are directed to the store site from a search engine). The shop's 
homepage needs to be user-friendly, while at the same time highlighting the shop's 
products. 

The first step in becoming familiar with the store front is understanding the anatomy of 
the OpenCart default homepage. 

The header 

The header will be displayed at the top of the page, on every page of the store; not just 
the home page. 

 

The header has the following navigation options: 

 Store logo: Clicking on this logo will direct the customer back to the home page of the 
store. 

 Currency block: The customer can select which currency the store's products will be in 
by clicking on any of the currency icons. 

 Shopping Cart: Displays the number of items purchased, and the total price of the order. 
Clicking on the button will containing all of products added to the cart and an option to 
"View Cart" or "Checkout". 

 Search box: The customers can type in the search box to search for a product within the 
store's product categories. 

 Links: Links the customer to the Home page, Wish List, My Account, Shopping Cart, and 
Checkout. 

 Telephone: Company telephone number. 
 My Account: Customer can register or login from here. 

The top menu 

The top menu category only displays the top parent categories of products. 
See Categories for more information on how to create and assign product categories. 



Like the header, the top menu will be displayed on every page. When the customer's 
mouse is dragged over a category, a drop down menu will display the sub-categories for 
that parent category. 

 

When a parent category is clicked, the customer will be directed to the category page, 
which displays all the products within that category. 

Slideshow 

The slideshow displays several product banners of your choice by alternating the 
images in a slideshow. After a certain amount of time, one banner will shift to the the 
next banner. Banners in this slideshow are useful for highlighting certain products to be 
easily accessible by the customer. When the banner is clicked on, the customer will be 
directed to the product on the banner's page. 

 

Unlike the top menu and header, the slideshow in the OpenCart default can only be 
viewed on the home page in this position. 

Featured products 

OpenCart gives you the option of featuring specific products of their choosing on the 
home page. 



 

The Featured section includes the product image, name, price; and an option to add the 
product directly to the Shopping Cart. 

 The carousel is only located on the Home Page in the default. 

Footer 

The footer is located at the bottom of every page, not just the Home Page. This block of 
miscellaneous links is useful in sorting relevant pages for the customer that may not 
logically sort anywhere else. 

The organizational scheme of the footer can be divided into the following sections: 

 Information: "About Us", "Delivery Information", "Privacy Policy", "Terms & Conditions" 
 Customer Service: "Contact Us", "Returns", "Site Map" 
 Extras: "Brands", "Gift Vouchers", "Affiliates", "Specials" 
 My Account: "My Account", "Order History", "Wish List", "Newsletter" 

 

Product pages 

The OpenCart default product page will follow the structural format seen below. 



 

The product page can be divided into the following sections: 

 Product image: The product image can be displayed under the title on the left-side, 
along with alternate views of the product underneath it in smaller box. Clicking on the 
main image will expand the image within the window for the customer to see it in greater 
detail. 

 Product details: The product code, availability, and price are displayed just right to the 
product image. 

 Cart: The customer can select a quanity and add the product to their cart, wishlist, or 
compare. 

 Rating/Sharing: Underneath the cart can rate the product and/or share the product on 
different social media websites. 

 Description tab: An area underneath the main product information to provide a detailed 
description of the product. 

 Review tab: An area for the customer to write a review on the product. 

Category product listings 

Category product listings enable customers to browse products similar to other products 
within the same category. This is especially helpful for customers looking to compare 
products, a feature that will be explained under Categories. The category page can be 
accessed a number of ways. It can be accessed from the top menu, when a customer 
clicks on one of the parent categories. Also, on product pages a customer can access 



the category product listing page by clicking on a category on the left side category 
block. 

 

As seen above, the category block is displayed on the left-side like it is in the product 
page. There is space under the Category title at the top to add a description to the 
category. The "Refine Search" links to sub-categories of that category for the user to 
browse. The products can be displayed according to the customer's preference: in a list 
or grid. The above image is sorted in the listing format. The products can be sorted 
according to name, price, rating, or model in the "Sort By" box. The number of products 
displayed in the product listing can be changed in "Show" from 15 up to 100. 

There is a section that gives space for each of the products within the category, 
providing a product image, description, price, and an Add to Cart option. There is an 
option to add the product to a wish list. Another option for the product is to "Add to 
Compare". 



Product compare 

The "Add to Compare" feature in the product section allows the customer to compare 
the different specifications, features, and price of a number of products s/he might be 
interested in. 

 

The customer is given the option to add one of the compared products to the cart if they 
want to. Pressing "Continue" will bring the user back to the home page. 

Shopping Cart page 

Once a customer adds a product to the cart, they can access the shopping cart in the 
header under "Shopping Cart". 



 

The shopping cart gives an overview of the product selected by including the categories 
"Image", "Product Name", "Model", "Quantity", "Unit Price", and "Total". The customer 
has an option to add a coupon code or gift voucher, or estimate shipping & taxes, 
before heading to the checkout. The "Continue Shopping" button links back to the 
homepage. 

Creating an account 

Before a customer can continue checking out a product from the shopping cart, the 
customer needs to select either guest checkout or log into their account. The guest 
checkout doesn't require log-in details. Returning customers may want to make an 
account with the store. 

There are a few ways a customer can make an account: 



1. Checkout 

Step 1 of the check out process allows the user to make an account before 
continuing with payment. Selecting "Register Account" will change Step 2 of 
checkout from Billing to Account & Billing details. Account & Billing asks for the 
same personal details as Billing, except that it asks for the user to create a 
password for their account. After Step 2 is completed, the customer may 
continue with the checkout process.

2. Header- "My Account

Clicking "My Account" in the header will show the option for customer to the 
Login or create account. This page 
already have an account, or create a new account. In the "New Customer" 
section the customer can click "Continue" under Register Account to be directed 
to the "Register an Account" page.

Checkout 

Once a product has been added to the cart, the customer can continue to the checkout 
to make their product purchase. The Checkout page can be accessed in the header 
section of every page (found under the search box). Customer checkout using 
OpenCart is a simple process

Step 1 of the check out process allows the user to make an account before 
ntinuing with payment. Selecting "Register Account" will change Step 2 of 

checkout from Billing to Account & Billing details. Account & Billing asks for the 
same personal details as Billing, except that it asks for the user to create a 

ccount. After Step 2 is completed, the customer may 
continue with the checkout process. 

"My Account" 

Clicking "My Account" in the header will show the option for customer to the 
Login or create account. This page gives the customer an option to log in if they 
already have an account, or create a new account. In the "New Customer" 
section the customer can click "Continue" under Register Account to be directed 
to the "Register an Account" page. 

t has been added to the cart, the customer can continue to the checkout 
to make their product purchase. The Checkout page can be accessed in the header 
section of every page (found under the search box). Customer checkout using 
OpenCart is a simple process that can be completed in 6 steps. 

 

Step 1 of the check out process allows the user to make an account before 
ntinuing with payment. Selecting "Register Account" will change Step 2 of 

checkout from Billing to Account & Billing details. Account & Billing asks for the 
same personal details as Billing, except that it asks for the user to create a 

ccount. After Step 2 is completed, the customer may 
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section the customer can click "Continue" under Register Account to be directed 

t has been added to the cart, the customer can continue to the checkout 
to make their product purchase. The Checkout page can be accessed in the header 
section of every page (found under the search box). Customer checkout using 



1. Step 1: Checkout options 

The customer can log into or register their account (as explained above), or 
select guest checkout. 

2. Step 2: Billing details 

Personal details including "First Name", "Last Name", "E-mail", and "Telephone" 
are filled into a form. It also requires the customer's address details. 

3. Step 3: Delivery details 

In Billing Details, the user can check a box to indicate that the delivery details 
and billing details are the same. This will cause it to skip over this step to 
Delivery Method. If the delivery etails are different from the billing details the 
customer can enter this information in a form in this section. 

4. Step 4: Delivery method 

A method of shipping is selected here. A comment box is added for the customer 
to add comments about their order. 

5. Step 5: Payment method 

The customer selects their method of payment here and may add comments in 
the comment box. 

6. Step 6: Confirm order 

In this last step, the customer will see an overview of their purchase; including 
the product description, quantity, and price (with tax & shipping). 

Store front customization using the admin 
dashboard 
All of the features listed above can be customized to some degree in the admin panel. 
The administrator can change the position of certain products, disable categories, edit 
prices and descriptions, upload banners, etc. There is much work that can be done in 
the OpenCart admin to establish the shop's brand. 

Admin Interface 

Connecting the OpenCart administration 



OpenCart's administration side of the store is where you can modify features, upload 
images, add products, keep track of customers, manage payments, and much more. 
Customization in the admin affects how the customer will interact with a store: by 
modifying the look, structure, and content of the store front. 

Accessing the admin panel 
To access the admin panel, type in location of the store into the web browser followed 
by "/admin". For example, if your store is located at "www.chocolatechip.com", your 
admin panel is located at "www.chocolatechip.com/admin". Even if the store is located 
in a sub-folder or on a sub-domain of their site, adding "/admin" to the end of the store's 
path will lead you to the administration side. 

If the name of the folder is changed by you during installation, the location of the admin 
panel is changed to that new name. For example, if the name of the admin folder is 
changed to admin1, the new location of the admin panel is at 
"www.chocolatchip.com/admin1". 

 Changing the name of the admin folder to another name is important for improving an 
online shop's security. The config.php file needs to be edited to indicate the correct file 
path and location. 

A username and password is created in Step 3 of the auto-installer during installation. 
This information can now be used to fill in the administrator login details. 

 

After filling in the correct username and password, pressing the "Login" button will direct 
you to the OpenCart dashboard. When you first login to your shop, the dashboard will 
be blank (as seen below), because there isn't any statistical data to be analyzed yet. 



 

Entering the administration through the 
Dashboard 
The dashboard is the first thing you will see when entering OpenCart's admin. The main 
function of the dashboard is to give the shop owner an overview of how the shop is 
performing. There are 3 sections of the dashboard that can help you understand the 
statistical data collected by your store: 

 Overview: 

There are four chart showing the status of your website. They are Total Orders, 
Total sales, Total Customers and People Online which help you to easier to know 
the analytics. 

 World Map: 

A world map to show where the orders from your website were coming from. 

 Sales Analytics: 

A graph is provided to track the chronological progress of the store relative to the 
amount of orders and customers over time. The x value is time; which can be 
hours, days, or months depending on the range selected. The y value displays 
the number of total orders(yellow) and total customers(blue). 

 Recent Activity: 

A section to check the recent activity from any customer from your store such as 
login, creating account or placing new orders. 



 Latest Orders: 

A list that displays the last orders and their details ("Order ID", "Customer", 
"Status", "Date Added", "Total", and "Action") 

Above the dashboard in the top menu is the administration navigation. You can navigate 
between the "Catalog", "Extensions", "Sales", "System", "Reports", and "Help". These 
sections will be explained in further detail in the following sections of the User Guide. 

Filter 

Filter 
Filter is a handy tool used regularly throughout the OpenCart administration. You may 
type into one of the information field for the item on the item list. Pressing Filter will "filter 
out" all the items in the list that do no match the criteria entered in the space, leaving 
only the items that match. With Filter, you can quickly locate any information stored in 
list form. Products, Categories, Customers, Reports, Orders, and more all use Filter as 
the main search tool to locate items in a list. 

For examples, if you would like to look up a product in the product list, you can use 
"Filter" as a shortcut to search for that product. This can be helpful when there is large 
amounts of product and you would like to edit a specific product without having to 
browse through every page for it. The search boxes are located in the first row above 
the product list. 

 

In the screenshot above, "nikon" is typed into the "Product Name" information field. 
"Filter" only displays what matches "nikon". The Nikon D300 is the only product 
displayed because it is the only product name containing the words "nikon" in this shop. 
If the "nikon" wording was present in more than one product name, the "Filter" button 
would display all of them. 

Image manager 



Image manager 
The Image Manager is a tool used in the administration to upload image files. Banners, 
product images, the store logo, and manufacturers will all need images uploaded using 
the Image Manager. 

此功能可以於產品類別、產品、橫額、適店設定等位置，只要有涉及圖片更改就可以執行

這個圖像管理器的程式。 

 

Clicking  will open up a new window called the "Image Manager". Click the  Upload 
button in the toolbar, which will open up your computer's file directory to directly add 
them. The images below were provided for the default products. Select an image by 
clicking on one, and press the  Delete& button in the toolbar to delete it. 

 



 
Adding multiple languages 

Adding multiple languages 
With shops serving a wider array of customers across multiple countries, it may become 
necessary to add multiple language options for your customers. The default language 
provided from the installation is English. Other available languages can be viewed on 
the OpenCart Language page.These language packs can be downloaded through 
the Extension Directory. 

FTP a language pack to an OpenCart store 

Any language pack that isn't English needs to be uploaded to OpenCart, post 
installation, using an FTP client like FileZilla. Before we continue, please make sure that 
you have downloaded your language pack from the Extension Directory and 
uncompressed the download contents to a location on your computer. Connect to your 
OpenCart store in the FTP client. Locate the root directory of where the OpenCart store 
was installed. From there, open the path Catalog>Language. If this is your first time 
here, you will see an "english" folder already in this location. In Catalog>Language, 
upload your new language pack to this location. 

 



Adding a language to the administration 

The OpenCart administration requires some specific information in the System area 
about the language after you FTP it. Visit Localisation to see what fields are required. 
After the language is saved there, the language name will appear in the language list 
under Localisation>Language. 

Changing a language in the store front 

Saving a language pack in Localisation will make it immediately available in the store 
front. The language area is located in the header of every page, from the left top corner. 
In achieve the example below, a French language pack was downloaded and FTP'd to 
OpenCart. By assigning French an assorting order of 2, it is displayed below of English 
in the header of every page of our store. The customer can click on the French flag in 
the header to change the language. 

 

Creating a Multi-Store 

Creating a Multi-Store 
OpenCart allows for multi-store management using only one installation. If you have 
installed OpenCart into at least one store, you can add multiple stores to your admin 
panel without having to repeat the installation process. To add a new store you must 
first create a subdomain in your cPanel, then add the store in the Settings section of the 
admin panel. 

Creating a subdomain in cPanel 

You can login to the cPanel of their default store to create a subdomain. You should 
create a new folder for the subdomain, under Subdomain. In the root directory, link the 



subdomain to the path where the default store was installed to. For example, if the 
default store had been installed under "public_html/opencart", the new subdomain 
(opencart2) should be created under "pub
subdomains here to create our multi

When we visit our new subdomain in our browser, the default store is visible. To 
customize the new store at this subdomain we need to visit the admin panel for our 
multi-store. 

 Don't worry if the default store is displayed where the new store should be, this is normal. The 
new store will not be visible at the subdomain's location until it has been added in the 
administration side of OpenCart.

Creating a new store in Settings

The admin panel of the new store can be visited through either store sites, at 
"opencart.mystore.com/admin" or "opencart2.mystore.com/admin". Just add a "/admin" 
to either of your stores' locations to access the admin panel. There is only one admin 
panel that controls all the stores in your multi

To create a new store in the administration, visit System > Settings and press Insert. 
Adding a store requires information to be filled from 
the General, Store, Local, Option
add a new template, logo, currency, language, and layout. After pressing "Save", you 
will see that the default store is replaced by the new store in that subdomain's store 
front. 

Customizing the store front

Products, product categories, customers, page layouts, and more, can be edited in the 
administration and customized for each store. Yo
products are available for each store in the
Checking the stores in this section makes the product only avai
stores. When adding or modifying a product category, you can select which stores 
display the category in the Data
sorted into their appropriate store in the administration side when they create an 
account or buy a product at that store.

subdomain to the path where the default store was installed to. For example, if the 
default store had been installed under "public_html/opencart", the new subdomain 
(opencart2) should be created under "public_html/opencart". We could add more 
subdomains here to create our multi-store by following this procedure.

When we visit our new subdomain in our browser, the default store is visible. To 
customize the new store at this subdomain we need to visit the admin panel for our 

worry if the default store is displayed where the new store should be, this is normal. The 
new store will not be visible at the subdomain's location until it has been added in the 
administration side of OpenCart. 

Creating a new store in Settings 

panel of the new store can be visited through either store sites, at 
"opencart.mystore.com/admin" or "opencart2.mystore.com/admin". Just add a "/admin" 
to either of your stores' locations to access the admin panel. There is only one admin 

ls all the stores in your multi-store. 

To create a new store in the administration, visit System > Settings and press Insert. 
Adding a store requires information to be filled from 

Option, Image, and Server tabs. In these sections you can 
add a new template, logo, currency, language, and layout. After pressing "Save", you 
will see that the default store is replaced by the new store in that subdomain's store 

Customizing the store front 

Products, product categories, customers, page layouts, and more, can be edited in the 
administration and customized for each store. You can individually select which 
products are available for each store in the Links tab when editing or creating a product. 
Checking the stores in this section makes the product only available in those specific 
stores. When adding or modifying a product category, you can select which stores 

Data tab. Customer and order info will be automatically 
sorted into their appropriate store in the administration side when they create an 
account or buy a product at that store. 

subdomain to the path where the default store was installed to. For example, if the 
default store had been installed under "public_html/opencart", the new subdomain 

lic_html/opencart". We could add more 
store by following this procedure. 

 

When we visit our new subdomain in our browser, the default store is visible. To 
customize the new store at this subdomain we need to visit the admin panel for our 

worry if the default store is displayed where the new store should be, this is normal. The 
new store will not be visible at the subdomain's location until it has been added in the 

panel of the new store can be visited through either store sites, at 
"opencart.mystore.com/admin" or "opencart2.mystore.com/admin". Just add a "/admin" 
to either of your stores' locations to access the admin panel. There is only one admin 

To create a new store in the administration, visit System > Settings and press Insert. 

tabs. In these sections you can 
add a new template, logo, currency, language, and layout. After pressing "Save", you 
will see that the default store is replaced by the new store in that subdomain's store 

Products, product categories, customers, page layouts, and more, can be edited in the 
u can individually select which 
tab when editing or creating a product. 

lable in those specific 
stores. When adding or modifying a product category, you can select which stores 

tab. Customer and order info will be automatically 
sorted into their appropriate store in the administration side when they create an 



Moving OpenCart to a new server 

Moving OpenCart to a new server 
OpenCart can be easily migrated to a new web server. The steps are listed below: 

1. Copy all the OpenCart files from your existing web server to the new web server. 
2. Export the OpenCart database and import it into the new server. 
3. Edit config.php and admin/config.php. These files contain the filesystem paths to 

OpenCart folders, URLs to OpenCart frontend and admin, and database access 
details. The paths and database details will most likely need to be updated, and 
the URLs will need to be changed only if the OpenCart store's domain has 
changed. 

SEO keywords 

SEO keywords 
OpenCart allows the use of search engine optimized URLs for product, category, 
manufacturer and information pages. SEO keywords are defined per product, category, 
manufacturer and information page, stored in a database table (url_alias), looked up at 
each page request, and translated into an internal URL. 

In order to use SEO keywords, they must be enabled in the store settings page, server 
tab in the admin interface. 



 

A correctly formatted .htaccess file must be present in the root of the OpenCart 
installation (beside the admin and catalog folders). The contents of the .htaccess file are 
shown below: 

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 
# 2. In your opencart directory rename htaccess.txt to .htaccess. 
# For any support issues please visit: http://www.opencart.com 
Options +FollowSymlinks 
# Prevent Directoy listing 
Options -Indexes 
# Prevent Direct Access to files 
<FilesMatch "\.(tpl|ini|log)"> 
 Order deny,allow 
 Deny from all 
</FilesMatch> 
# SEO URL Settings 
RewriteEngine On 
# If your opencart installation does not run on the main web folder make sure 
you folder it does run in ie. / becomes /shop/ 
RewriteBase / 
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L] 
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L] 
RewriteCond %{REQUEST_FILENAME} !-f 
RewriteCond %{REQUEST_FILENAME} !-d 
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css) 
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA] 
### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it. 



### If you get an "Internal Server Error 500" after enabling any of the 
following settings, restore the # as this means your host doesn't allow that. 
# 1. If your cart only allows you to add one item at a time, it is possible 
register_globals is on. This may work to disable it: 
# php_flag register_globals off 
# 2. If your cart has magic quotes enabled, This may work to disable it: 
# php_flag magic_quotes_gpc Off 
# 3. Set max upload file size. Most hosts will limit this and not allow it to 
be overridden but you can try 
# php_value upload_max_filesize 999M 
# 4. set max post size. uncomment this line if you have a lot of product 
options or are getting errors where forms are not saving all fields 
# php_value post_max_size 999M 
# 5. set max time script can take. uncomment this line if you have a lot of 
product options or are getting errors where forms are not saving all fields 
# php_value max_execution_time 200 
# 6. set max time for input to be recieved. Uncomment this line if you have a 
lot of product options or are getting errors where forms are not saving all 
fields 
# php_value max_input_time 200 
# 7. disable open_basedir limitations 
# php_admin_value open_basedir none 

The .htaccess.txt file should be present in your store's root folder. If not, copy and paste 
the text above into a text editor and save it as ".htaccess". If the .htaccess.txt file is 
present, please change its name to ".htaccess". With the .htaccess file changed, you 
should be able to add unique SEO keywords to individual products, manufacturers, 
categories, and information pages. 

The SEO keywords you add will be displayed in the url of the page, so they must be 
unique for each product, product category, etc. Let's see what happens when we add 
the SEO keyword, "nikon-camera", to our Nikon D300 product under the Data tab: 

 

If our store is located at "www.mystore.com", the new URL of the Nikon D300 product 
page will be located at "www.mystore.com/nikon-camera". Overall, creating SEO 
keywords will clean up your store page's URL and optimize your page for search 
engines. 

SSL Certificates and HTTPS 

SSL Certificates and HTTPS 



With sensitive customer and payment information being handled by your store, it is 
critical that you are able to secure that important information as it travels between web 
server and browser. As a result of this need, many store owners turn to HTTPS for 
additional security. A SSL certificate needs to be obtained and installed before you can 
enable HTTPS for your store. 

Once the SSL certificate has been installed, go to the Server tabs under your store's 
settings in your admin panel. The first option in the Server tab lets you decide if you 
want to use SSL. Selecting "yes" will enable the SSL so that you can access your store 
through HTTPS. 

 

 
Basic Security Practices 
OpenCart is not responsible for the securing your website, therefore it is up you to 
ensure your server's level of safety. The following suggestions aim to improve your 
OpenCart store's security. 

These additional steps can be taken immediately after OpenCart is installed to your 
server; or whenever you store becomes active. See Installation for more information on 
how to install your OpenCart store. 

Delete the install folder 
Deleting the install folder is advised by OpenCart immediately after installation. 
OpenCart will warn you in the administration if the install folder is not deleted. 



Directory protection 

Admin folder 

The admin directory is where you have access to your store's administration. People 
with access to your store administration will have access your editing your products, 
customer information, store settings, and more valuable information. Therefore, it is very 
important that the admin login be difficult to find and access. 

Rename admin 

Renaming the admin directory to something unrelated to the the admin is necessary to 
prevent unwanted eyes from discovering it's location. You can access your admin login 
through entering your store's location, then the path to the admin. For example, if the 
admin folder was changed to "cookiemonster", the admin login would be at 
"www.yourstore.com/cookiemonster". You will also need to update the admin/config.php 
file (or, in the example, the cookiemonster/config.php file), replacing instances of 
"admin" with the new name, e.g., "cookiemonster". Note that doing this may make life 
more difficult down the line, such as if you decide to install vQmod. 

.htaccess & .htpasswd 

A .htaccess and .htpasswd file in the admin folder will prevent hackers from accessing 
your store, even if they discover the admin login location. Using .htaccess, you can 
deny all IP addresses from viewing your store, except the admin's IP address. A 
.htpasswd in the admin folder will require an additional password for the allowed 
administrator to access this directory. 

Catalog 

The catalog can be protected with the traditional .htaccess file. Using file match can be 
useful for protecting important file types for your store, such as php and txt, rather than 
all of them. The following code can be used for .htaccess in your catalog folder: 

<FilesMatch "\.(php|tpl|txt)$"> 
Order Deny,Allow 
Deny from all 
Allow from "your ip address" 
</FilesMatch> 

This will deny access to all template, php, and txt files. 



System folder 

The system folder contains two files that need to be protected: logs/error.txt and 
start_up.php. The logs/error.txt can be renamed if necessary. 

.Htaccess 

The .htaccess will work to protect these files and the subfolders of System from being 
accessed by anyone except the designated administrator. To do so, insert the code 
below into your .htaccess: 

<Files *.*> 
Order Deny,Allow 
Deny from all 
Allow from "your ip address" 
</Files> 

File permissions 
The following files need to be set to 644 or 444 to prevent anyone else from writing to 
them: 

 config.php 
 index.php 
 admin/config.php 
 admin/index.php 
 system/startup.php 

vQmod 

vQmod 
While strictly modules, product feeds and OpenCart extensions should be standalone 
and modular, some require modifications to the OpenCart core. Modifying OpenCart 
core files greatly reduces your ability to upgrade your store to later versions, and can 
affect other modules and extensions. vQmod provides a mechanism by which modules 
requiring OpenCart core modifications can be installed without damaging the integrity of 
your core system for upgrades. vQmod keeps a list of filenames and changes required, 
in the form of one XML file per extension. These changes are then created as the core 
files are used, and the resulting files are stored as cached copies which are executed 
instead of the original, core PHP or TPL file. 



Installing vQmod 

If you wish to upgrade your store, or have a 3rd party extension that you have not used 
before, it is advisable that you use the vQmod system. The vQmod download and 
instructions for installation can be found here:https://github.com/vqmod/vqmod. 

Once you have downloaded the appropriate vQmod zip file provided in the link, you 
need to uncompress the zip file and FTP the vQmod folder to your site's root directory. 
From the Filezilla screenshot below, we can see the root directory of this store is 
located at public_html/opencart in the Remote site side. Uploading the vQmod folder 
here will make the vqmod folder visible in public_html/opencart. 

 

vQmod advises you to set the permissions to writable for the vqmod/vqcache folders, 
index.php, and admin/index.php. In Filezilla you can right click on a file or folder, select 
"File Permissions...", and enter 755 or 777 in the "Numeric value" to set it to writable. 



 

The next step in installing vQmod is to visit the install page in your store. Enter your 
store's location in your browser, then "vqmod/install" afterwards. If your store is located 
at "www.mystore.com", the vQmod install page would be located at 
"www.mystore.com/vqmod/install". The following text will appear on the page if it was 
installed correctly: "VQMOD HAS BEEN INSTALLED ON YOUR SYSTEM!". 

 Unlike the install folder after installing OpenCart, do not delete vQmod's install folder after the 
vQmod installation! 

vQmod advises that you load your homepage to see if it appears and works correctly 
after the install. You would also need to check your vqmod/vqcache folder to see if there 
are new vq files. 

Categories 
In the default theme of the store front, parent categories are listed in the top menu of the 
home page, and on the left side of product pages. This navigational feature is used to 
guide customers to similar products within the same category. Exposing customers to 
different products within a category lets the customer compare the similarities and 
differences between products to make the most informed purchase. When adding 
products to the store, you will be asked for a product category to sort them in. It is a 



good idea to establish these categories before adding products, to save yourself the 
trouble of adding the category name to the products later. 

 When adding a product without a product category, the product will not show up under 
any categories in the front end of the store. The product page can only be accessible if 
the customer types in the product name, one of the product tags in the search box, or 
visits the product through a manufacturer page. If you want this product to be more 
visible to your customers in the store front, we suggest that the category is created prior 
to adding the product. 

To access the Category page in the administration, hover over the Catalog button and 
click on Category in the drop-down. You will be a directed to a page that displays the 
category names of the store products (as seen below). 

 

The categories above were included with the default products provided by the install. 
You may delete them to make room for the store's product categories. To delete, check 
the box next to the row that the category is listed on. When the products selected for 
deletion are checked, "Delete" can be clicked on in the upper right corner. This should 
remove the product categories completely. 

 The ">" symbol points from a parent category to a sub-category. "Laptops & Notebooks 
> Windows" indicates that "Windows" is a sub-category sorted under the parent 
category "Laptops & Notebooks". 



The Sort Order indicates the order that the categories are displayed in the top menu 
and category box on the product page. Desktop (sort order-1) will be sorted above 
Laptops & Notebooks (sort order-2) because it has a higher priority. 

 Leaving "Sort Order" blank will organize the sections in alphabetical order. 

Clicking "Edit" under "Action" will direct the administrator to a form to change the 
category information. Clicking "Insert" will allow the shop owner to insert more products 
to the site. 

Create a category 
Before you learn how to add products, you will need to understand how to create 
product categories. Product category is an essential organizational feature in OpenCart. 
OpenCart organizes the structure of an online store around these product categories. 
Every product category gets their own space in the store to display all the available 
products for that category. 

Organizing products into categories is useful for navigating a store's inventory in both 
the store front and administration side. In the administration, creating categories for 
products will help the shop owner keep track of specific products within a category. In 
the store front, customers will be able to browse their favorite products by category. 
Category pages can be accessed in the top menu and from the category box in the 
product page. 

 Before inserting products into OpenCart, you should take some time to brainstorm and 
establish categories for your products. Think of how the products in your store can be 
organized into groups in a logical manner. Generally, you would want to start with 
creating a broad parent category, and move narrower into specification with each sub-
category below it. For example, a broad category such as Electronics is a good parent 
category. Under the Electronics, a sub-category named "Computers" can be created; 
and under that category, "Laptops". You can see how each category becomes more 
specific as we progress. Putting effort into this task will improve a store's usability, 
ultimately bringing customers to other products in the store that may interest them. 

Go to Catalog > Category in the administration. If this is your first time in the category 
section you will see a list of categories created for the default products. You should feel 
free to delete them to make room for your store's products. To create a new category for 
products you can click "Insert" in the upper right corner. You will be directed to the 
category's information page. Category information can be filled out under three tabs: 
"General", "Data", "Design". 

Category General 

General Tab 



The General tab asks for basic information regarding the product category: 

Category Name * - 

Description Text that will describe this category on the category page, 
to be viewed by the customers in the store front of the 
shop. 

Meta Tag Title * Category name to be shown on browser tag section. 

Meta Tag Description A summary of the category to describe the category page 
to search engines. 

Meta Tag Keywords Similar to meta tag description, but asks for a single 
keyword to describe the product. 

* Required ield 



 

Category Data 

Data Tab 
The Data tab asks for the following data: 

 Parent Category: Categories are arranged in a hierarchical structure; with the 
parent category always on top. You may choose to create a category under a 
parent category, turning it into a sub-category. In the category list the category 
will be displayed as "Parent Category > Sub-Category". If "None" is selected, the 
category created will be a parent category. 



 Filters: Map any pre-created filters to a category. See Filter for more information 
on how filters work. 

 Stores: If you are managing more than one store with OpenCart, you may check 
which stores you would like to add this category to. If only one store is available, 
"Default" may be checked. See Creating a multi-store for more information about 
multi-stores. 

 SEO keyword: A keyword that will be included in the category url for search 
engine optimization. 

 Image: Select the main image for the product page and the thumbnail for product 
listings. See Image manager for more information on how to upload an image 
using the image manager tool. 

 Top: Checking this section will display this category in the top menu of every 
page. If no selection is made, it will not be displayed. 

 The top menu only displays parent categories. If this category is a sub-category, 
it will not be displayed in the top menu. 

 Columns: This number controls how many sub-categories are displayed when 
selecting the parent category. 

 Shop owners with many product sub-categories may need to pay special 
attention to how many columns are allowed. If all the available sub-categories 
are allowed for a product category, the entire store page in the store front will be 
filled with sub-categories when hovered over. 

 Sort Order: This sort order determines the position of the category in the menu. 
A sorting order of 1 would be displayed before a sorting order of 2, 3, and so on. 

 Status: Selecting "enabled" makes the category publicly available in the store 
front. Selecting "disabled" will hide the category from the store front, but will still 
be available for editing purposes in the administration. 



 

Categories SEO 

SEO Tag 

 

Category Design 



Design Tab 
The design tab consists of the "Layout Override" feature. In this feature, you can choose 
to override a layout, such as the 'Account' page, to include the category on that page. 
For more information on layouts, see Modules. You can just leave it blank for the 
meantime. 

 

Pressing 'Save' in the upper right corner will save the information in the General, Data, 
and Design tabs, and add the product category to the category list. With the product 
categories created, you are now ready to add products to the shop. 

Product Overview 

Products in the administration 
Products are the bread and butter of the average OpenCart store. Therefore, it is 
essential that you learn how to manage your store's product inventory using the 
OpenCart administration side. Before adding products, you must make sure that you 
have all the necessary information about the product you are adding to the store. To get 
detailed information of your products to your customer, OpenCart requires this 
information to be gathered beforehand. The more information given to OpenCart about 
a specific product, the more informed the customer will be about that particular product 
when purchasing it from your store. 

Products overview 
The Product section, accessed under Catalog, will display all the products available in 
the store. 

Every row of product will contain the following information: 

 Image 
 Product Name 



 Model 
 Price 
 Quantity 
 Status: Selecting "Enabled" lets the product be visible in the store's store front. 

Selecting "Disabled" will remove the product from view. 

Checking an individual box in the first column will select the product information within 
the same row. Once selected, you can choose to "Copy" or "Delete" the product. "Copy" 
will duplicate the product and it's information categories. "Delete" will remove the 
product selection (including its information) completely. 

 

If you would like to look up a product in the product list, you can use "Filter" as a 
shortcut to search for it. For more information on the Filter tool, visit Filter. Pressing 
"Insert" in the top right corner will direct the administrator to a form to add new products. 

Managing and adding products in the 
catalog 
The complete list of store products can be found under Catalog > Products. If this is 
your first time in the Product section, you will notice the default products left over from 
the installation. These products can be used to experiment with and explore the 
OpenCart features before launching your store. You will eventually need to delete these 
products to make room for your store's products. 

To delete the default products: 



1. Check the box left of the "Image column" in the list. This should select all the 
products on the page. 

2. Click the "Delete" button on the top right side. 
3. Press "OK" when a window pops up asking "Delete/Install cannot be undone! Are 

you sure you want to do this?". 

There should now be a blank list to add individual products to. The "Insert" button 
directs the administrator to a page requiring product information under the following 
tabs: 

 General 
 Data 
 Links 
 Attribute 
 Option 
 Discount 
 Special 
 Image 
 Reward Points 
 Design 

Before products are added to the administration, product categories must already be 
established by the administrator. See Categories before continuing with this section. 
With the product categories created, products are now ready to be added to the catalog. 

 OpenCart currently only allows products to be added one at a time, not in mass 
quantity. Extensions can be purchased to add large amounts of product at once. See 
Product import for more information. 

Saving the product 
At this point in the guide, you will have completed all the steps and filled out all the 
appropriate information for the product. To complete the process of adding this product, 
click "Save". When you return to the Products page under Catalog, you will now see this 
product listed. You can choose to modify any of this information included above, at any 
time, by clicking "Edit" across from the product. 

Product General 

General Tab 
The format of the General tab is identical to the General tab when creating a product 
category, with the addition of the Product Tags feature: 



 Product Name 
 Meta Tag Description: A summary to describe the product page to search 

engines. 
 Meta Tag Keywords: Similar to meta tag description, but asks for a single 

keyword to describe the product. 
 Description: Text that will describe this product on the product page, to be 

viewed by the customers in the store front of the shop. 
 Product Tags: A tag to describe the product to the customers. If a customer 

types in this tag in the search box found in the header, the product will be 
displayed in the search results. 

 

Products Data 

Data Tab 
The data tab includes all the product criteria that will be included on the product page in 
the store front for customers to view: 



 

Fill in the spaces above with the following information: 

 Model: create a model number for the product using a combination of letters and 
numbers. (required) 

 SKU (stock keeping unit): a random code for the product. 
 UPC (universal product code): the product's unique barcode. 
 Location: where the product is located. 
 Price: set a price for the product. 
 Tax Class: select a tax class category on this product that was made Settings > 

Localisation > Tax Classes. This will apply the tax in the checkout for the product. 
Select "None" if taxes will not be applied to this product. 

 Quantity: The total amount available in the store for this specific product. 
 Minimum Quantity: the minimum amount of product a customer must reach to 

add that product to their Shopping Cart. 
 Subtract Stock: "Yes" will subtract stock from the quantity of the product (Ex: If 

there are 100 computers, and a customer buys 2 computers, Subtract Stock will 
change the quantity to 98). 

 Out of Stock Status: select "Out of Stock", "In Stock", "2-3 days", or "Preorder" 
as the message shown on the product page when the product's quantity reaches 
0. 

 Requires Shipping: If the product requires shipping, select "Yes". If not, select 
"No". 



 SEO keyword: create a keyword for search engine optimization of this product. It 
will be seen in the URL of the product page. Therefore, the keyword created 
must be unique for every product. 

 Image: clicking "Browse Folders" will lead the administrator to the Image 
manager to upload a new image. 

 Date Available: the date when this product will become available for purchase. 
 Dimensions: enter the length by width by height of the product if there are 

dimensions to include. 
 Length Class: determines the metric units for the dimensions above. 
 Weight: Enter a number for the weight. 
 Weight Class: Specify the units of weight for the number entered into "Weight". 
 Status: Enabling makes the product publicly available in the store. Disabling 

allows the product to be edited in the administration , but hides it from the store 
front . 

 Sort Order: When the product is sorted in a list, a number assigns it a priority. A 
product with a sorting order or 2 will be placed higher than a product with a 
sorting order of 3, but lower than a product with a sorting order of 1. 

Products Links 

Links Tab 
The Links tab specifies which pages OpenCart will show the product on: 

 Manufacturer: Selecting the product's manufacturer will place the product on the 
manufacturer's page. Select manufacturers can be viewed on the home page if 
added to the manufacturer banner. 

 Categories: Check the categories that the product will be placed into. The 
product will be listed on the category's page in the store. 

 Filters: Select the filters to be applied to this product if your Filter module is 
enabled. See Filters for more information. 

 Stores: Check which stores will sell this product. Clicking "Default" applies if 
there is only one store to be managed. 

 Downloads: If the product is a downloadable product, select the file that will be 
included with the purchase. 

 Related Products: In this space, type any related products for this product. 
These products will be displayed on that product's page for the customer to view. 
When typing in the space, a drop down box will appear with related products. 



 

Product Attributes 

Attribute Tab 
Attributes are the specifications that are compared between products in the Product 
Comparison. Attributes are originally created under Catalog > Attributes. In Catalog > 
Products, selecting an attribute will assign an attribute directly to a specific product. If 
OpenCart was just installed, it will be blank. Press "Add" and a form below should 
appear. Fill in the blanks with the attribute name and information, and click "Add 
Attribute". 



 

For example, if a customer wanted to compare monitor size of a computer monitor with 
another product with a monitor, we could create an attribute for the product. Under 
"Attribute" we would call it "Monitor size"; in the Text box area we would type the 
dimensions of the monitor of that specific product, and click "Add Attribute". 
See Attributes for a more in depth explanation of attributes. 

Product Options 

Option Tab 
Options are extra selections that a customer can make on the Product page before 
adding the product to the shopping cart. Options are first created under Catalog > 
Options, then assigned to a product that is created under Catalog > Products. 

 

One example of an option is "size". Begin by typing "size" into the search box. Size 
should appear in a drop down box. Select it, and click on the green add button. On the 
right, click "Add Option Value". 



 

The Option Values were previously created in the Options section under Catalog. In this 
section any option can be added, such as "Large". To subtract from the quantity every 
time a product is purchased with this option, you can select "Yes" under "Subtract 
Stock". An increase of price can be added to the option value, points, and weight. Click 
"Add Option Value" to assign that information to that specific option value. You can click 
"Remove" to erase the option value. See Options for a more in depth explanation of the 
options feature. 

Product Discount 

Discount Tab 
The Discount Tab needs the following information to include a discount for a product: 

 Customer Group: A group of customers (made in Sales > Customers > Groups) 
that meet a criteria to use this discount. 

 Quantity: The limit for the amount of products that can apply this discount. 
 Priority: Adding a priority number such as 1, 2, or 3, will determine when this 

discount will be used when other discounts are applied to a customer's order. 1 
will apply this discount first, while 2 will apply it second, and so on. 

 Price: The discounted price. 
 Date Start: The first date the discount will be applied. 
 Date End: The last date available for use of the discount; the date the discount 

will end. 



 

Press "Add Discount" once the information has been filled in. Click "Remove" to remove 
the discount from the product. 

Product Special 

Special Tab 
The Special tab is identical to the Discount tab, except that this offer will be considered 
a special, not a discount. Fill in the customer group, quantity, priority, price, date start, 
date end. 

Product Images 

Image Tab 
The images tags let the administrator add additional product images to the product 
page. The main image was already uploaded in the Data tab of Products, so keep in 
mind these images will be included below that main image on the product page. 

 



You may click "Add Image", then "Browse" to select an image from the Image manager. 
Assign a number for sorting order. "1" will make it the first additional image, while every 
descending sorting number will follow it. The image above is an example from a product 
page in the store front. The large main image was added in the Data tab. The images 
above were added in the "Image" tab, with the farthest top left assigned as 1, and the 
following images assigned a lower priority. 

Products Reward Points 

Reward Points Tab 
Reward points is a feature of OpenCart that assigns customers "loyalty points" for 
purchasing products from the store. Customers can use these acquired points as a 
currency to purchase products from the store. You can assign this product a certain 
number of reward points required for a customer to purchase it with. If you don't want to 
allow this product to be bought with reward points, you can simply leave this area blank. 

Product SEO 

SEO Tag 

 

Product Design 

Design Tab 
If you want a product available on other layouts besides the product page, you can 
choose to override certain layouts in order to include that product on that page. 



Profiles 

Profiles 
Profiles are a new, optional feature in OpenCart 1.5.6. They allow you to set up 
recurring payments for your customers. Profiles are useful if you plan to sell products by 
subscription, if you are promoting a discount or member's club, or if you are simply 
breaking up payments into smaller portions. This feature gives the store owner more 
control over how customers are charged for products or services. 

In order to set up a recurring payment or view your existing profiles, first open 
your Catalog > Profiles Tab.. 

 

Adding New Profiles 
If you choose to Insert a new profile, you will see the following options: 

 

 Name:This will be the name of the subscription or payment plan, such as “$35 
per month or Discount Club. 

 Sort Order:This is simply for putting your profiles into a certain order, to make 
your top picks easier to find. 

 Status:You can enable or disable the profile here. 
 Price:The actual price of the program or subscription. In this example, it is 

$39.99. 



 Duration:The number of times a user will make a payment. Set to 0 if unlimited. 
If unlimited, the payments plan will continue until cancelled by you or the user. In 
the example, the duration is set to 12 months (for a yearly subscription). 

 Cycle:The number that will be applied to your frequency option. 
 Frequency:This option allows you to choose how often a user will make a 

payment. In the example, the cycle is "1," and the frequency is "month," causing 
the user to be billed monthly. If you wanted your customer to be billed every 
three weeks, you would choose "3" as the cycle, and "week" as the frequency. 

 Trial Status:Here, you may enable or disable a free trial. If disabled, you may 
leave the following options blank. 

Adding a Trial to a Profile 
If you choose to enable a free trial or special pre-payment program, the form will ask for 
the following information: 

 

 Trial Price:The price of the subscription or payment plan during the trial period 
 Trial Duration:The number of times a user will make a payment before the trial 

expires 
 Trial Cycle:The number that will be applied to your trial frequency option 
 Trial Frequency:How often the trial will cycle. 

In this example, the trial cycle and trial duration are both set to "1," and the frequency is 
set to "month," creating a free trial of this plan that lasts one month only. If you wanted 
to make a free trial that lasted two weeks, you would set trial duration to "1," trial cycle 
to "2," and trial frequency to "weeks." 

Do not forget to Save when you are finished, and you will see your new profile listed on 
your Profile page. Now, in order to apply your new profile, you must connect it both to a 
product and to a customer group. Learn more about how to make a customer group on 
the Customer Group page. 

Applying Your Profile to a Product 
Once you have created your customer group and added your selected customers to that 
group, you are ready to apply your profile to a product. 

Open your Catalog > Products page and choose a product. Click Edit, then click 
the Profile tab. 



 

Click Add Profile, and you will see dropdown boxes appear that will allow you to 
choose which Profile and which Customer Group to apply to that particular product. 
When you are finished, click Save. 

Your new Profile has now been applied to your selected customers for your selected 
product. 

Filter 
This function can be found on Categories and Products pages when create or edit 
on Data tab. Default system does not include any data on filter, that's why no data 
popup on the field. 

 

Open the left menu in Catalog and click the Filters on row four. There is the empty list 
on the figure, click the createbutton to next page. 



 

Get into the info page, there are part of fields are requested: 

Filter Group 

Filter Group Name * Name of filter group 

Sort Order It will affect the filter groups sorting on 
store front. Can leave it blank or type 0 on 
it. 

* Field is requested, cannot blank and submit 

Filter Values 

Filter Name * Name of filter value 

Sort Order It will affect the values sorting in the group on store 
front. Can leave it blank or type 0 on it. 



* Field is requested, cannot blank and submit 

Edit Category 

 

For example, Colours filter group is created, and edit the Desktop from categories. 
Add the Red and Black into this category and save changes. 



Edit Product 

 

Now, edit the product which is under Desktop and add the filter Red on it and save 
changes. 

If the filters module is enabled, it will be displayed in Desktop on store front category 
page when it is done. For more details about layout setting please click here. 

Store front 

If the module is set on the top, the result will be same as below figure when clicking 
into Desktop. 



 

Attributes 

Attributes in the administration 
The attributes section lets you edit the attributes compared between products in 
"Product Comparison". When viewing products in the store front, customers have the 
option to add products to "Add to Compare" to analyze the similarities and differences 
between products in the store. Attributes can be used to describe the size, weight, color, 
and any other specifications of the product that have potential for comparison. You can 
create these attributes in the Catalog > Attributes area. To add attributes directly to 
products, visit the Attribute tab under Products. 

 Try to create universal attributes that are consistent across specific categories of 
products. For example, if your shop sells computer monitors, you could create a 'screen 
resolution' attribute. This attribute needs to be added consistently to all the computer 
monitor products in your store. It is more likely that a person will compare two computer 
monitors, rather than comparing a computer monitor and a random product with 
different attributes. 

Attribute Groups 



An attributes group contains related attributes that can be compared under Product 
Comparison. Attributes such as 'Clockspeed' and 'No. of Cores' can be organized under 
the larger attribute group of 'Processor'. 

 

To create an attribute group, go to Catalog> Attributes> Attributes Group and click 
"Insert". This form only requires an attribute group name in "Attribute Group Name". 
Adding the "Sort Order" is optional. Adding a sort order will affect the arrangement order 
of attributes under Product Comparison. The attribute groups created here can have 
individual attributes added to them later. 

Creating attributes 
In Catalog > Attributes, attributes can be created, edited, and deleted. 



To create a new attribute, click "Insert". This button will direct you to a page asking for 
the "Attribute Name", "Attribute Group", and "Sort Order". 

 

The "Sort Order" determines the position of the attribute if the product has multiple 
attributes assigned to it. The "Attribute Group" is the larger group of attributes that this 
particular attribute will belong to when assigned. 

Attributes in the store front 
At this point in the guide, you should be familiar with creating attributes on the 
administration side; so let's see how creating an attribute in the back-end can affect the 
store front of the shop. For the purposes of this example, we want to add a 'Display' 
attribute group to help our customers compare the differences between "aspect ratio" 
and "monitor size" attributes for our default laptop products in our store. 

Creating an attribute and attribute group 
for Product Comparison 
The first step is to create a broader attribute group to store our individual attributes, 
aspect ratio and monitor size. We will create 'Display' as our attribute group, under 
Catalog > Attributes > Attributes Groups. 

 

The next step is to create the specific attributes, Aspect Ratio and Monitor Dimensions, 
with descriptions under Catalog > Attributes > Attributes. 



 

We type the name, Aspect Ratio, then assign it to the broader attribute group "Display". 
We assign 1 to sort order because we want this attribute to be above all the other 
attributes in the Display attribute group. When we click "Save", "Aspect Ratio" will be 
added to the attributes list. We create another attribute named "Monitor Dimensions", 
but we will change the sort order to 2, so that it appears below "Aspect Ratio" under 
Product Comparison. 

Assigning the attributes to a product 
Now that we have the attributes created, we need to edit the individual products to 
contain these attributes. To be consistent, we will add "Aspect Ratio" and "Monitor 
Dimensions" to all of our laptop products. We don't want a scenario where our 
customers need to compare different laptop products, but only one or two of our laptops 
has the "Aspect Ratio" listed to compare. 

To add attributes directly to a product we go to Catalog > Products, and click edit for our 
HP laptop product. In the Attributes tab, we add the Aspect Ratio and Monitor Size 
attributes individually. The text description must be manually added, so we add 16:10 to 
"Aspect Ratio" and 19.3" x 27.2" to our monitor size. As seen below, when we start 
typing "Monitor", both the attribute group and attribute name is displayed in the drop 
down box.. 

 



We will continue on by adding these two attributes individually to all of our laptop 
products. 

Viewing the attributes in Product 
Comparison 
In the store front we added the Sony VAIO and HP LP3065 laptops to our product 
comparison from their respective product pages. Under the Product Details we can see 
our Display attributes group (highlighted by the red box). Since we gave the group a sort 
order of 1 when we inserted it into the attribute group list, it was the first attribute group 
displayed. Within the "Display" group, our "Aspect Ratio" and "Monitor Size" attributes 
are listed according to their sorting order. The specific text we included in the attribute 
section under Products is shown under each respective product column. 

 

Our customers can now make a more informed decision with their purchase by 
comparing the Display attributes in Product Comaprions. Understanding how to use 
attribute groups and attributes with products can help raise the level of customer 
satisfaction. 

 



How to DELETE the items? 
After Create the attributes and groups, how to delete the item in these pages? If user 
just check the item and delete New Attribute Item, the system will be respons with 
below screen: 

 

The reason is New Attribute Item already access into the products. OpenCart system 
is not allowed the attribute(s) delete in this status. Before take this acction, user should 
confirm all the attributes are clear into the product or delete the whole product. 

There is same case with Attribute Groups, clear all Attribute items before delete the 
groups. 

 



Options in the administration 
The Options section, under Catalog, lets you customize what details the customer sees 
when checking out a product. On the product page, the "Available Options" section is 
displayed under the price. The option for that product must be selected before the 
customer can add the product to the shopping cart. 

The image below displays the default options, but you can choose to edit or delete any 
of them. Essentially, the options can be created to fit whatever added specifications are 
needed for the customer to purchase the product. The "Insert" button will direct you 
towards creating a new option. 

 

For example, if you wanted the customer to choose a size for a particular product before 
checking out, you can create a "Size" option. 

The "Type" dropbox will show a variety of ways to display this option: 

 Choose: Select", Radio, Checkbox, Image" 
 Input: Text", Textarea 
 File: File" 
 Date: Date", Time", Date & Time" 



 

For the "size" option, three option value's were created : "Small", "Medium", and 
"Large". Images could be added for the option, but since it is referring to size the option 
value name will suffice. If the option was "Color", having images of the color would be 
appropriate. 

Adding options to products 
To apply the options to a specific product, you will need to edit the Option tab under 
Catalog > Products. Options could to be created prior to adding a product, then added 
during product creation in the Options tab. 

Options in the store front 
With the general concept behind "Options" explained above, we can now go into a 
detailed example of using the Option section to alter the checkout experience in the 
store front. For this example, we will be adding Options to the iPod Classic product 
example provided from installation. 

The image below was taken from our iPod Classic product page. We can see that 
product details such as manufacturer, product code, availability, and price are given 
product details next to the product image. The only interactive option seen below is the 
"Qty", or quantity. In the space provided next to quantity, the customer can alter the 
amount of iPod classics to be added to the shopping cart. 



 

For the purpose of this example, we want to add more options to customize the type of 
iPod Classic that will be purchased by the customer. Under Catalog > Options we will 
insert new options with varying option values. OpenCart allows for four different types of 
options for customers to select under Options: Choose, File, Date, and Input. 

Choose type 

The "Choose" Type lets the customer select specific option values. Among these 
choose types are the following sub-types: 

 Select: Provides a drop down box where the customer must select an option value. 
 Radio: Select-able icons with the option values. Only one radio selection can be made; 

clicking another selection will deselect the previously clicked option and move it to the 
current selection.  

 Checkbox: Multiple option values can be checked at once. 
 Image: Gives a radio selection next to small uploaded images. 

In our stock we have different colors of classic iPods: black, silver, and white. The 
Option Name to describe these colors will be "Color". We decided that we want to use a 
radio type option to display the color options. We want this option to be the first option in 
the list, so we gave it a sort order of 1. We added 3 option value names for our colors: 
Black, White, Silver. If we wanted to, we could have uploaded an image of the iPods in 
their different colors next to their respective value names using the Image manager. 



 

Next we will move to the Options tab to add our option to a product under Catalog > 
Products. This section is different than the Options section under Catalog because it will 
directly assign a previously created option to a product. We clicked the green '+' icon 
and typed in Color to bring up our "Color" option that we made under Catalog > Options. 
In the Option Value column, we added 3 values to enable the Black, Silver, and White 
option values to be displayed. In addition, we added the quantity of each color available, 
selected "yes" to subtract stock, and added 10 points to the Reward Points. We could 
add an increase or decrease in price for select colors, or indicate the weight, but we 
chose not to. 

 



Saving this Color option under the Options tab will automatically change how this 
product is viewed on it's product page. The product page can be seen in the screenshot 
below. Already, we discover that a new section has been added under price named 
"Available Options". We see our Color Option with the three colors in a radio selection 
format. The red asterick means that this option must be selected before adding it to the 
cart. If a selection isn't made, the customer cannot add the product to the Shopping 
Cart. 

 

File type 

The file type requires the customers to upload a file of their own before adding the 
product to their cart. In our example, we want the customer to upload an image file 
before checking out so that we can add the image to a custom iPod case. There is only 
one option under File Type called File. 

 



When we move to the Option tab under the Catalog > Product to add the option to the 
product, there is only an selection to require the file or not. There isn't any option values 
since it is up to the user to upload their own file from their computer. 

 

The result of saving this option can be seen on the iPod Classic product page. The sort 
order of 2 set the file type option below the Color option. When the customer clicks on 
the "Upload File" button, they can select a file from their computer that will be included 
in the checkout. 

 

Date type 

The Date type allows for three different types of selection: Date, Time, or Date & Time. 

For our product, we want the customer to include a specified date for delivery, so we 
title the Option Name as "Delivery Date". We select the Date type because we don't 
want the exact time to be included. We added a sort order of 4 because we want this to 
be the last option viewed before the customer adds the product to their cart. 



 

In the Option tab we can determine if it is a required option and what date we want 
included in the space. The customer can change the date using the calendar on the 
product page, so the date of the option value doesn't matter too much. 

 

The result of the date type can be seen in the product page image below. The Delivery 
Date was sort number was 4, so it falls below the Color and Ipod Case Custom Image 
options. 



 

Input type 

The Input type allows for a text or text area option. The difference between text and text 
area is that text is one line of blank text to be filled in, while text area gives more space 
for longer comments. For our iPod Classic we decided that we need an Engraved Name 
option to engrave the name of the customer on the iPod. We need the customer to type 
in their first and last name, so we chose the text type. We gave a sort order of 3 
because we want the Engraved Name option to be above the Delivery Date. 

 

In the Options Tab under Products we decided that this option doesn't need to be 
required to check out. In the Option Value we filled in "First and Last Name" so the 
customer knows to enter their first and last name in the box. 



 

When the option is saved to the product, we can see the Engrave Name section under 
Ipod Case Custom Image and above Delivery Date. The red asterick is missing 
because we chose "No" under "Required". The option value shows "First and Last 
Name" in the box, but the customer can type their own name in that area. 

 

Options displayed in the shopping cart 



When the customer makes their selection and adds the product to their cart, the 
shopping cart will display the iPod Classic product options under the Product Name 
column. Every option selected will be included under the iPod Classic. When the 
customer checks out, this product information will be included. 

 

The Option section adds another layer of flexibility in customizing product information on 
product pages. By becoming familiar with the Options tab, you will improve the 
OpenCart transaction process for your customers. 

Manufacturers 

Manufacturers in the administration 
interface 
The Manufacturer section is used to categorize products by manufacturer. This section 
can be accessed under Catalog > Manufacturers. 

The Manufacturer names below came with the install. They can be deleted, and new 
manufacturer information can be added in its place. The manufacturer information 
should be created before products are added, so the manufacturer category can be 
selected when adding the product. Saving a product without including the manufacturer 
isn't advised, because customers can search for products in the store front through their 
manufacturer page. With the manufacturer missing from the product information, the 
product will not be available on those pages. 

 

To insert a new manufacturer, the following information is required: 



 Manufacturer name 
 Stores: Default will be selected if there is only one store. If you have more than one 

store using OpenCart, you can add a manufacturer to multiple stores by checking on 
them. 

 SEO Keyword: the keyword used for search engine optimization (optional) 
 Image: an image of the manufacturer (optional). See the Image manager to learn how to 

upload images. 
 Sort Order: the position the manufacturer will be sorted among multiple manufacturers 

(optional) 

 

To edit existing manufacturers you can locate "Edit" under "Action". Clicking edit will 
direct you to the form above with the previously filled-in manufacturer information. 

 The product will need to be reassigned to the newly changed manufacturer, if the manufacturer 
name is changed. If the manufacturer name remains unchanged, but any of the other 
information is edited, the product will automatically adopt the new manufacturer information. 

Manufacturers in the store front 
Manufacturers will always need to be assigned to products in the store inventory to 
affect the store front. See the Products section for more information on how to assign 
manufacturers to products in the administration. In the store front, the manufacturer 
"categories" serve to organize products under manufacturers. To illustrate how products 
are organized under manufacturers in the store front, we will create a new manufacturer 
and assign it to a product. 



 

In the Catalog > Manufacturer section we created an 'Acer' manufacturer; added it to 
our only store ('Default'), while including an SEO keyword, manufacturer image, and 
sort order. Under Products we assigned the "Acer" manufacturer to the "Acer Aspire" 
product. 

The Manufacturers page 

To access the Acer manufacturer page, the customer can go to the footer of any page; 
and under Extras they can click on Manufacturers. 

 

The customer will then be directed to the manufacturers page, where all the 
manufacturer names are displayed alphabetically. We can see that our "Acer" 
manufacturer was automatically added to this page upon creation. 



 

When the customer clicks on the "Acer" link, they will be directed to a page listing all the 
products within this "Acer" manufacturer. On this page, we can see that the "Acer 
Aspire" product is displayed because it was assigned the manufacturer,"Acer", in the 
Products section. 



 

Clicking on the "Acer Aspire" will take the customer to its product page. 

 

The "Acer" manufacturer page can also be accessed from the product page, under 
"Manufacturer". This link is helpful for exposing customers to different products of the 
same manufacturer in the shop. The customer can click on "Acer" to be directed to the 
manufacturer page, where they can browse other Acer products in the store. 

The carousel module 

Adding a new manufacturer will not add the manufacturer icon to the carousel banner 
on the home page. The newly created manufacturer must be added to the manufacturer 
banner under System > Design > Banners for the icon to be displayed in the carousel. 
See the Layoutsection for more information on how to add the manufacturer icon to the 
banner. 



Downloads 

Adding new downloads 
This section is only applicable to you if you sell digital products, or products that have a 
downloadable component such as a PDF User Guide or similar. To insert a new 
download, you must give the downloadable product a name, upload the file, and set an 
allowance for the number of downloads per customer. The mask option allows the 
administrator to give the file a different visible filename. Press "Save" to submit the 
download information and save it. 

 

With the download created, it must be manually added to the each individual product 
that the download will be included with. See Links to learn how to add a download to the 
product. 

 

The downloadable file will not be shown on the product page. Therefore, it is a good 
idea to describe how the customer will receive their download in the product description 
on the product page. The download will be provided for the customer once their 
purchase is complete. They should be advised to visit "My Account" > "My Orders" > 
"Downloads" (as seen below) to view their downloadable products. 

 



Reviews 

Reviews 
Product reviews can be both submitted and viewed by customers on the product page. 
A customer can fill out a review form and submit it to be approved for publication on the 
site. 

In the Dashboard the administrator can view how many customer reviews are awaiting 
approval in the Overview section. To approve these reviews, the administrator may visit 
Catalog > Reviews, select the review, and click "edit". OpenCart will display the author, 
product, and text review in separate text boxes. Selecting "enabled" under status will 
make the review publicly available on the product page. 

 

 We can't recommend the editing of customer submitted reviews, even though there is a 
space to. The point of having reviews is to receive customer input on that specific 
product to help other customers make an informed decision with their purchase. If you 
would like to to disable reviews altogether, you can visit the Options tab under System > 
Settings. See Settings > Options > Products for more information.. 

The result of a customer review approval can be seen in the screenshot below. Every 
review is made publicly available on the product's main page after administrative 
approval. The average rating per product is tabulated by OpenCart and shown out of 5 
stars under 'Available Options'. 



 

Information 

Information 
The Information section displays specific company information in the footer of every 
page (as seen in the screenshot below). See Information for more information on the 
footer page. 

 

The Information page can be found under Catalog > Information. On this page the 
administrator will have the option to edit, delete, or insert a new Information page. 

 About Us, Delivery Information, Privacy Policy, and Terms & Conditions are in the default 
because they are the most important Information pages used in online stores. We recommend 
that you edit these pages rather than delete them. 



 

When editing or inserting these pages a description may be added, pages enabled or 
disabled, and SEO keywords created. There is an option to remove the page from the 
bottom of the footer. 

Information pages in the store front 

In the screenshot below, the "Delivery Information" page is being edited in the 
administration under Catalog > Information. The Information Title will display the text 
entered as the title of that information page, while the description will be placed below. 

The Data tab requires you to check the store that the Information page will be located 
in, if you have multiple stores. It also asks for a SEO keyword, a status option enabled 
(or disabled) to make the page public or not, and a sorting order. 

 



The screenshot below is the result of saving the edited Delivery Information. A customer 
can access this page from the footer of any page in the store front by clicking "Delivery 
Information". There is an option in the Data tab above to remove a link to this page from 
the footer. 

 

Build it Marketplace 

 

Extension Installer 

Extension Installer 
OpenCart 2 introduced a new "Extension Installer" feature. By means of 
the Extension Installer you can upload zip-packed extensions as well as single 
modification files by just a few clicks. In order to use the Installer you need to be aware 
of your FTP credentials. 



Setting your FTP credentials
In order to set your FTP credentials, navigate to

Then, choose the FTP tab and fill in your FTP credentials. Make sure you check 
the Yes radio button for the
upper right corner of the page as shown:

Now the Extension Installer will know how to access your FTP and you will be able to 
install extensions with ease.

Installing an extension
Usually OpenCart 2.x extensions come packed in a zip, which contains installation 
and/or update instructions, sometimes a release log and another zip, whose name ends 
in ".ocmod.zip". Extension Installer recognizes such zips and uploads their content 
directly to the FTP root of your store. That said, it will produce an error if you try to 
upload zips with a name that is not in the 

In order to upload an extension, navigate to
click the blue Upload button and provide the route to your extension' s
archive. 

Setting your FTP credentials 
In order to set your FTP credentials, navigate to System -> Settings 

tab and fill in your FTP credentials. Make sure you check 
radio button for the Enable FTP field and click the blue Save

upper right corner of the page as shown: 

Now the Extension Installer will know how to access your FTP and you will be able to 
install extensions with ease. 

Installing an extension 
penCart 2.x extensions come packed in a zip, which contains installation 

and/or update instructions, sometimes a release log and another zip, whose name ends 
". Extension Installer recognizes such zips and uploads their content 

e FTP root of your store. That said, it will produce an error if you try to 
upload zips with a name that is not in the "*.ocmod.zip" format. 

In order to upload an extension, navigate to Extensions -> Extension Installer
button and provide the route to your extension' s

> Settings -> Store Settings. 

 

tab and fill in your FTP credentials. Make sure you check 
Save button in the 

 

Now the Extension Installer will know how to access your FTP and you will be able to 

penCart 2.x extensions come packed in a zip, which contains installation 
and/or update instructions, sometimes a release log and another zip, whose name ends 

". Extension Installer recognizes such zips and uploads their content 
e FTP root of your store. That said, it will produce an error if you try to 

> Extension Installer. Then 
button and provide the route to your extension' s"*.ocmod.zip" 



If the extension that you are installing contains files with names already existent in the 
current location, you will receive an alert about this in the grey 
overwritten" box. This means the extension is about to overwrite files that you already 
have on your site. Here, you can either inspect all of the listed files and make sure no 
OpenCart core files are to be overwritten, or contact the extension's developer directly. 
Once you are sure it is safe to proceed, click the blue
you should get a green "Success: You have installed your extension!

Uploading a sing
Uploading single .xml modification files is just as easy as installing zip
extensions. The difference is only in the route you will provide the
Modification files' names should end in 

Installation errors & Clear button
At times, an error could restrain the Installer from completely uploading an extension or 
modification file and cause it to abort the installation midway through. If this happens, 
the filling color in the Progress
below it, you will get an error of some type. Example:

If the extension that you are installing contains files with names already existent in the 
will receive an alert about this in the grey "Files that will be 

" box. This means the extension is about to overwrite files that you already 
have on your site. Here, you can either inspect all of the listed files and make sure no 

files are to be overwritten, or contact the extension's developer directly. 
Once you are sure it is safe to proceed, click the blue Continue button. On success, 

Success: You have installed your extension!

Uploading a single modification file
modification files is just as easy as installing zip

extensions. The difference is only in the route you will provide the Installer
Modification files' names should end in ".ocmod.xml" when uploaded v

Installation errors & Clear button 
At times, an error could restrain the Installer from completely uploading an extension or 
modification file and cause it to abort the installation midway through. If this happens, 

Progress field will become red and will stop filling the bar. Right 
below it, you will get an error of some type. Example: 

 

If the extension that you are installing contains files with names already existent in the 
Files that will be 

" box. This means the extension is about to overwrite files that you already 
have on your site. Here, you can either inspect all of the listed files and make sure no 

files are to be overwritten, or contact the extension's developer directly. 
button. On success, 

Success: You have installed your extension!" message. 

le modification file 
modification files is just as easy as installing zip-packed 

Installer with. 
" when uploaded via the Installer. 

 
At times, an error could restrain the Installer from completely uploading an extension or 
modification file and cause it to abort the installation midway through. If this happens, 

field will become red and will stop filling the bar. Right 



When this happens, files that had alread
will need to be cleared. OpenCart has the red Clear button for that. If you had forgotten 
to do that, you will also get an alert on the top of the page about this every time you 
access your Extension Installer

Upon clicking the Clear button, the alert should be replaced by the followin
message: 

You should always make sure all temporary files are cleared before uploading an 
extension or a modification file
on your server. 

Product Feeds

Product Feeds
The Product Feed extension lets you customize how you want the products of your 
OpenCart store to be viewed and listed by search engines like Google. To ut
feature, you must compile a
feed can be compiled using XML or manually entering product information into a 
spreadsheet program. 

When this happens, files that had already been uploaded before the error has occurred, 
will need to be cleared. OpenCart has the red Clear button for that. If you had forgotten 
to do that, you will also get an alert on the top of the page about this every time you 

Extension Installer. 

button, the alert should be replaced by the followin

You should always make sure all temporary files are cleared before uploading an 
extension or a modification file because at the very least, they will be taking up space 

Product Feeds 

Product Feeds 
The Product Feed extension lets you customize how you want the products of your 
OpenCart store to be viewed and listed by search engines like Google. To ut
feature, you must compile a product feed of your store's products. The store's product 
feed can be compiled using XML or manually entering product information into a 

 

y been uploaded before the error has occurred, 
will need to be cleared. OpenCart has the red Clear button for that. If you had forgotten 
to do that, you will also get an alert on the top of the page about this every time you 

 

button, the alert should be replaced by the following "Success" 

 

You should always make sure all temporary files are cleared before uploading an 
because at the very least, they will be taking up space 

The Product Feed extension lets you customize how you want the products of your 
OpenCart store to be viewed and listed by search engines like Google. To utilize this 

of your store's products. The store's product 
feed can be compiled using XML or manually entering product information into a 



Google Base and Google Sitemap 
The OpenCart package lets you connect to two product feed tools, Google Base and 
Google Sitemap. You need to create an account at the Google Merchant Center to 
access these tools. Google Base requires the user to upload product information in 
product feeds so that they can show up in Google's search engine. The product feed 
created for Google Base needs to follow Google's specifications, which can be viewed 
in Google's support FAQ. Google Sitemap uses a data url from the store website to 
provide information to its search engine to crawl the store's website. 

In the edit section of Product Feeds, you must link to the store's Data feed urls obtained 
from the Google Merchant center. 

 

Support 

To receive support for the Product Feeds extensions, please visit the Feeds 
Extension section of the support forum. 

Anti-Fraud 

Anti-Fraud 
The Anti-Fraud modules can be accessed under Extensions > Anti-Fraud. The core 
fraud handling modules seen below are included with the OpenCart package. 



The Anti-Fraud modules need to be installed before they can be enabled for the store. 
The process of installation is similar to installing an extension under Extensions > 
Modules in OpenCart. For example, this is how to install the FraudLabs Pro module. 
First, install the module by clicking on the "Install" button under the "Action" column. A 
green stripe will notify you that the module is successfully modified.

Once the module is installed, you can edit the module settings. We will start with the 
configuration of the first module, FraudLabs Pro.

FraudLabs Pro
FraudLabs Pro module uses the
orders. In order to use the Fraudlabs Pro service, you have to obtain an API key first 
and place it in the OpenCart module settings.

Fraud modules need to be installed before they can be enabled for the store. 
The process of installation is similar to installing an extension under Extensions > 
Modules in OpenCart. For example, this is how to install the FraudLabs Pro module. 
First, install the module by clicking on the "Install" button under the "Action" column. A 
green stripe will notify you that the module is successfully modified. 

Once the module is installed, you can edit the module settings. We will start with the 
configuration of the first module, FraudLabs Pro. 

udLabs Pro 
FraudLabs Pro module uses the Fraudlabs Pro service to detect possible fraudulent 
orders. In order to use the Fraudlabs Pro service, you have to obtain an API key first 
and place it in the OpenCart module settings. 

 

Fraud modules need to be installed before they can be enabled for the store. 
The process of installation is similar to installing an extension under Extensions > 
Modules in OpenCart. For example, this is how to install the FraudLabs Pro module. 
First, install the module by clicking on the "Install" button under the "Action" column. A 

 

 

Once the module is installed, you can edit the module settings. We will start with the 

service to detect possible fraudulent 
orders. In order to use the Fraudlabs Pro service, you have to obtain an API key first 



In order to obtain the API key you need to register in the FraudLabs Pro service. There 
are several pricing plans, including a free plan. The different plans offer different amount 
of monthly queries (orders) and diffe
are customizable rules that you can configure in addition to the other checks that 
FraudLabs Pro makes when screening an order.

After configuring and enabling the module in OpenCart, each of the orders 
store will go through FraudLabs system and get screened for any potential fraud. Once 
an order is checked from the FraudLabs Pro service it is being given a certain status 
and a score. There are three possible fraud validation statuses: Approv
Pending Review. The score is a value from 0
order can be fraudulent. The bigger the number is the more risky an order is.

The OpenCart FraudLabs Pro module is configured based on the
Fraudlabs Pro status for each order.

Risk Score 

Once checked, each order is being given a certain Score. You can check what Score 
each order has in the FraudLabs Pro user panel.

In order to obtain the API key you need to register in the FraudLabs Pro service. There 
are several pricing plans, including a free plan. The different plans offer different amount 
of monthly queries (orders) and different amount of validation rules. The validation rules 
are customizable rules that you can configure in addition to the other checks that 
FraudLabs Pro makes when screening an order. 

After configuring and enabling the module in OpenCart, each of the orders 
store will go through FraudLabs system and get screened for any potential fraud. Once 
an order is checked from the FraudLabs Pro service it is being given a certain status 
and a score. There are three possible fraud validation statuses: Approv
Pending Review. The score is a value from 0-100, presenting the probability that an 
order can be fraudulent. The bigger the number is the more risky an order is.

The OpenCart FraudLabs Pro module is configured based on the Score
for each order. 

Once checked, each order is being given a certain Score. You can check what Score 
each order has in the FraudLabs Pro user panel. 

 

In order to obtain the API key you need to register in the FraudLabs Pro service. There 
are several pricing plans, including a free plan. The different plans offer different amount 

rent amount of validation rules. The validation rules 
are customizable rules that you can configure in addition to the other checks that 

After configuring and enabling the module in OpenCart, each of the orders made in your 
store will go through FraudLabs system and get screened for any potential fraud. Once 
an order is checked from the FraudLabs Pro service it is being given a certain status 
and a score. There are three possible fraud validation statuses: Approved, Rejected or 

100, presenting the probability that an 
order can be fraudulent. The bigger the number is the more risky an order is. 

Score and the 

Once checked, each order is being given a certain Score. You can check what Score 



In OpenCart FraudLabs Pro module you have to configure a
compared to the Score of the order from the FraudLabs Pro service. Also an Order 
Status should be configured in the module. This
order in your store in case the
service) is bigger than the Risk
You can choose from all the available OpenCart Order Statuses.

Status 

Based on the results status from the FraudLabs service, an order will have one of the 
following statuses: Approved, Rejected or Pending Review.

In OpenCart FraudLabs Pro module you have to configure a Risk Score
of the order from the FraudLabs Pro service. Also an Order 

Status should be configured in the module. This Order Status will be applied to the 
order in your store in case the Score (the one that comes from the FraudLabs Pro 

Risk Score (the one configured in the OpenCart module). 
You can choose from all the available OpenCart Order Statuses. 

Based on the results status from the FraudLabs service, an order will have one of the 
following statuses: Approved, Rejected or Pending Review. 

 

Risk Score, which will be 
of the order from the FraudLabs Pro service. Also an Order 

will be applied to the 
(the one that comes from the FraudLabs Pro 

(the one configured in the OpenCart module). 

 

Based on the results status from the FraudLabs service, an order will have one of the 



In OpenCart FraudLabs Pro module, you should configure what Order Status to be 
applied to each order, for each of the FraudLabs Pro service order statuses. For 
example, if the FraudLabs Pro gives a
status can be configured to change to 
applied for the three FraudLabs Pro service.

In order to test the configuration of the module, you can use the Simulate IP field. If you 
add an IP address in this field then all of the orders made in your store will be logged 
with this IP for the FraudLabs Pro service.

More features can be found in the control panel from FraudLabs Pro 
panel:https://www.fraudlabspro.com/merchant/dashboard

Risk Score 
The second anti-fraud module in OpenCart is the Anti
the possible fraudulent orders based on the customer IP addresses. The module allows 
you to create manually a list of fraud IP addresses. The fraud IP addresses list is 
configured from : Anti-Fraud IP > IP Addresses > Fraud IP Address List

In OpenCart FraudLabs Pro module, you should configure what Order Status to be 
applied to each order, for each of the FraudLabs Pro service order statuses. For 
example, if the FraudLabs Pro gives a Rejected status to an order, the OpenCart order 
status can be configured to change to "Denied". Different Order Statuses have to be 
applied for the three FraudLabs Pro service. 

 

rder to test the configuration of the module, you can use the Simulate IP field. If you 
add an IP address in this field then all of the orders made in your store will be logged 
with this IP for the FraudLabs Pro service. 

More features can be found in the control panel from FraudLabs Pro 
https://www.fraudlabspro.com/merchant/dashboard 

fraud module in OpenCart is the Anti-Fraud IP. This module handles 
the possible fraudulent orders based on the customer IP addresses. The module allows 

to create manually a list of fraud IP addresses. The fraud IP addresses list is 
Fraud IP > IP Addresses > Fraud IP Address List

 

In OpenCart FraudLabs Pro module, you should configure what Order Status to be 
applied to each order, for each of the FraudLabs Pro service order statuses. For 

status to an order, the OpenCart order 
". Different Order Statuses have to be 

rder to test the configuration of the module, you can use the Simulate IP field. If you 
add an IP address in this field then all of the orders made in your store will be logged 

 

More features can be found in the control panel from FraudLabs Pro 

Fraud IP. This module handles 
the possible fraudulent orders based on the customer IP addresses. The module allows 

to create manually a list of fraud IP addresses. The fraud IP addresses list is 
Fraud IP > IP Addresses > Fraud IP Address List . 



In OpenCart, there is an IP addresses log for each customer. In case that th
fraud IP address in the list of customer IP addresses, then an order will not 
automatically change its status to completed. Also, the module will change the order 
status to the one priorly configured in

MaxMind Anti
The second service based fraud handling module in OpenCart is MaxMind Anti
In order to use the module you have to obtain a license key from 
MaxMind minFraud service and place it in the OpenCart module settings.

In OpenCart, there is an IP addresses log for each customer. In case that th
fraud IP address in the list of customer IP addresses, then an order will not 
automatically change its status to completed. Also, the module will change the order 
status to the one priorly configured in Anti-Fraud IP > General > Order Status

MaxMind Anti-Fraud 
The second service based fraud handling module in OpenCart is MaxMind Anti

use the module you have to obtain a license key from 
service and place it in the OpenCart module settings.

 

In OpenCart, there is an IP addresses log for each customer. In case that there is a 
fraud IP address in the list of customer IP addresses, then an order will not 
automatically change its status to completed. Also, the module will change the order 

Fraud IP > General > Order Status. 

 

The second service based fraud handling module in OpenCart is MaxMind Anti-Fraud. 

service and place it in the OpenCart module settings. 



The minFraud service customers pass to minFraud system the service informati
provided by their site visitors during online transactions and account registrations. The 
minFraud service analyzes this information and returns a Risk Score. Risk Score ranges 
from 0.01-100.00 and represents the probability that a given transaction is 
Once an order is placed in your OpenCart store, the order transaction is scanned in the 
minFraud system. Once checked, each order is being given a certain Risk Score. You 
can check what Score each order has in the minFraud user panel (minFraud 
History). 

In OpenCart MaxMind Anti-
be compared to the Risk Score
Status should be set in the module. This Order Status will be applied to the order in your 
store in case the Risk Score
than the Risk Score (the one configured in the OpenCart module). Furthermore, the 
order will not be allowed to reach the complete status automatically.

The minFraud service customers pass to minFraud system the service informati
provided by their site visitors during online transactions and account registrations. The 
minFraud service analyzes this information and returns a Risk Score. Risk Score ranges 

100.00 and represents the probability that a given transaction is 
Once an order is placed in your OpenCart store, the order transaction is scanned in the 
minFraud system. Once checked, each order is being given a certain Risk Score. You 
can check what Score each order has in the minFraud user panel (minFraud 

-Fraud module you have to configure a Risk Score, which will 
Risk Score of the order from the minFraud service. Also, an Order 

Status should be set in the module. This Order Status will be applied to the order in your 
Risk Score (the one that comes from the minFraud service) is bigger 

one configured in the OpenCart module). Furthermore, the 
order will not be allowed to reach the complete status automatically.

 

The minFraud service customers pass to minFraud system the service information 
provided by their site visitors during online transactions and account registrations. The 
minFraud service analyzes this information and returns a Risk Score. Risk Score ranges 

100.00 and represents the probability that a given transaction is fraudulent. 
Once an order is placed in your OpenCart store, the order transaction is scanned in the 
minFraud system. Once checked, each order is being given a certain Risk Score. You 
can check what Score each order has in the minFraud user panel (minFraud Query 

 

Fraud module you have to configure a Risk Score, which will 
of the order from the minFraud service. Also, an Order 

Status should be set in the module. This Order Status will be applied to the order in your 
(the one that comes from the minFraud service) is bigger 

one configured in the OpenCart module). Furthermore, the 
order will not be allowed to reach the complete status automatically. 

 



More information on the minFraud service, you can find 
here: https://www.maxmind.com/MaxMind_WhitePaper.pdf 

Core Modules Overview 

Core Modules Overview 
There are 26 free core modules provided with the latest version of OpenCart: 

Account The User Account links (My Account, Edit 
Account, Order History, etc) box for the 
customer to access. 

Banner Adds an image banner with icons linking 
to different products or manufacturers in 
the store. 

Bestsellers Adds a window displaying the best sellers 
wherever position/page it is specified. 

Carousel Displays banner that can be navigated 
through as a slideshow. 

Category Displays a module containing all the 
categories and subcategories of the store. 

Divido Product Page Calculator  

Featured Displays a feature box containing selected 
products. 

Filter Displays a filter column to refine the 
products. 



Google Hangouts A chat box used with a Google account to 
interact with customers. 

HTML Content Creates a custom "Welcome" message for 
the customer to view on the home page. 

Information Adds the information tab containing the 
Information pages (About Us, Delivery 
Info, Privacy Policy, Terms&Conditions) 

Klarna Checkout  

Latest Adds the latest, or most recently added, 
products in the form of product icons to a 
product box on a page. 

Lay-Buy Layout  

Log In with PayPal  

Login with Amazon  

Pay with Amazon  

PayPal (Powered by Braintree) Button  

PayPal Express Checkout Button  

Pilibaba Checkout Button  



Sagepay Direct Card Management  

Sagepay Server Card Management  

Slideshow Displays banner that can be navigated 
through as a slideshow. 

Specials Displays all the products with Specials in a 
product box. Specials can be added to 
products in the Special tab. 

Store Creates a box for the customer to select 
another store to visit if there are multiple 
stores managed with OpenCart. 

eBay Listing  

All of these modules can be manipulated with the Layout, Position, Status, and Sort 
Order tools in Modules. 

Install / Uninstall 

Installing and uninstalling a Module 
The default version of OpenCart provides several core modules in the administration. In 
the Module section, some of these modules will be installed and uninstalled. We 
recommend that you take some time to experiment with different modules to discover 
which ones compliment your store the best. The first step in experimenting is installing 
the modules. Some modules may be uninstalled for the default, such as the Google 
Talk module. Installing a module is very simple. You can find the module, and in the 
same row click "Install" in the Module. 

Install 

 



If the module is installed, there will be an option to "Edit" or "Uninstall" where the 
"Install" used to be. 

Uninstall 

 

Uninstalling a module is as simple a process as installing one. Clicking "Uninstall" under 
the Action column is all that is necessary to remove the module information. 

 Uninstalling the module will delete the module information that was manually selected 
under "Edit". This module information cannot be recovered after it is uninstalled by re-
installing it. 

Editing a Module 

Editing a Module 
Modules can vary widely in purpose and function, so naturally, customizing a module to 
fit a particular store may vary between modules. In general, there are 4 main features of 
modules that can be tinkered with in the Module section: 

Layout Position 

Status Sort Order 

Layout 

The layout affects which pages the module will be included on. The pages available are 
listed in the screenshot below. If the module needs to be included on multiple pages, 
you must individually "Add Module" for each page. The Layout can only select one page 
at a time.. 



 

The screenshot below shows the Featured module, which displays a list of specified 
products on the left side of a random Category page. This was achieved by selecting 
"Category" under Layout. The Featured Products box will be available on every 
Category page. Selecting a layout page type will add it to every page of that type. Core 
modules can be assigned to layout pages, but not individual pages. 



 

Position 

The Position selection determines where the modules will be displayed on the page. On 
the page types selected in Layouts, the module box can be at the top, bottom, left, or 
right side of a page. 



 

Using the same module from the Layout section, we will change the Featured box on 
the category page from the left column, to the top, by selecting "Content Top" under 
Position (below). 

 



The Featured box with its specified products is listed above the category products in the 
category page, moved from its original position on the left side. 

Status 

Disabling or enabling the status of the module will affect the visibility of the module on 
the store website. Disabling a module is different from uninstalling the module. Disabling 
the module keeps all the module information available to be edited in the administration, 
while hiding it from the store front. Uninstalling the module will remove the store module 
information. Selecting "Enabled" will make this module publicly available on the pages 
selected for the store. 

 

Sort order 

The sort order affects the order of a module in relation to other modules in the same 
position. A sorting order of 1 for a module would place it above another module placed 
in "Content Bottom" with a sorting order of 2. If two modules are in the same position 
and have the same sort order number, they will be arranged alphabetically according to 
the module name. A module named "Featured" would be placed above the Specials 
module 

3rd Party Modules 

3rd Party Modules 

Extension store 

A wealth of over 15000 extensions are available for purchase and download in 
the OpenCart extension store. These modules build upon the OpenCart core foundation 
to provide added functionality and customization to your store. A complete list of the 
categories in the extension store is listed below: 

 Market Places: helpful extensions for OpenCart stores that act as online marketplaces. 
 Themes: custom themes to change the look and appearance of your store. 



 Languages: additional languages packs available for install. See Adding multiple 
languages to learn how to add language packs to your store. 

 Payment Gateways: extensions to facilitate additional payment methods for handling 
customer transactions. 

 Shipping Methods: modifications that customize and set shipping rates, to tools 
integrating other aspects of shipping not included in the core. 

 Modules: extensions that cover a wide range of features that customize the store front 
and administration. 

 Order Totals: discounts and other fees that can be applied to the order total during 
checkout in the store front. 

 Product Feeds: modules handling the importing and exporting of your store's product 
catalog. See Product Feeds for more information on modules . 

 Reports: additional reports to monitor the activity of your OpenCart store. See Reports 
for more information on the types of reports already available for the core. 

We highly suggest that you take the time to browse the extension store and explore 
these categories to see what these 3rd party modules have to offer your store. To see 
which core modules are already available through the OpenCart install, see Core 
modules overview. 

Payments 

Core payment methods 
The OpenCart package offers a variety of payment methods, from bank transfers to 
online payment gateways. The following core payment methods are available with an 
OpenCart installation: 

 2Checkout 

  

 Alipay Pay 
 Alipay Cross-border 

  

 Amazon Pay 
 Authorize.Net (AIM) 

  

 Authorize.Net (SIM) 
 Bank Transfer 



  

 BluePay Hosted Form 
 BluePay Redirect (Requires SSL) 

  

 CardConnect 
 Cardinity 

  

 Cheque / Money Order 
 Cash On Delivery 

  

 Divido 
 eWAY Payment 

  

 First Data EMEA Connect (3DSecure enabled)) 
 First Data EMEA Web Service API) 

  

 Free Checkout 
 G2A Pay 

  

 Globalpay Redirect 
 Globalpay Remote 

  

 Klarna Account 
 Klarna Checkout 

  

 Klarna Invoice 
 Lay-Buy 



  

 LIQPAY 
 NOCHEX 

  

 Paymate 
 PayPal (Powered By Braintree) 

  

 PayPal Express Checkout 
 PayPal Payflow Pro 

  

 PayPal Payflow Pro iFrame 
 PayPal Payments Standard 

  

 PayPal Pro 
 PayPal Pro iFrame 

  

 PayPoint 
 Payza 

  

 Perpetual Payments 
 Pilibaba for Chinese Checkout 

  

 Perpetual Payments 
 Realex Redirect 

  

 Realex Remote 
 SagePay Direct 



  

 SagePay Server 
 Sage Payment Solutions (US) 

  

 Secure Trading Payment Pages 
 Secure Trading Web Service 

  

 Skrill 
 Square 

  

 Web Payment Software 
 WorldPay Online Payments 

Additional payment methods can be downloaded from the OpenCart Extension 
Directory. 

Editing a payment method 
Editing payment methods in the administration for different transaction processors, like 
Paypal, will require a previously created account. The account and payment information 
should be obtained from these companies prior to editing the payment method in the 
administration. You will need to create an account with these companies to use their 
transaction processing for OpenCart. The information required for each payment 
method will be displayed in the Edit section. Across payment methods, there are a few 
details that are consistently asked for: 

Total Set the minimun price to reach the payment method. 

Order Status A default status of an order once the payment module has 
completed. Pending is considered one of the best default 
statuses because it gives the administrator some leeway to 
process the order. 



Status Disables or enables the payment method. 

Sort Order The position of the payment method in the store front when 
listed among all the available payment methods. 

Payment method in the checkout 

Enabling a payment method in the administration will make it available in the Checkout. 
In Step 5 of the checkout, the customer will be given a radio type selection to select 
their preferred payment method. 

 

Payment method in order history 

After the customer has confirmed the order, they can visit their Order History in their 
Account page to view its status. Immediately after checkout, the status will display the 
default order status you selected when editing the payment method details. In the 
screenshot below, you may chose "Pending" as the order status. 



 

The screenshot above shows "Pending" as the order status in the customer's Order 
History page under "My Account" in the store front. 

 

After the order is finished, user can go to the administrator to change the order status. 
For details, please read the page orders. 

Support 

To receive support for payment extensions, please visit the Payment Extension 
section of the support forum. 

Shipping 

Shipping 
The shipping methods extensions can accessed under Extensions > Shipping. The core 
shipping methods seen below are included with the OpenCart package. 



 

The shipping methods need to be installed before they can be enabled or disabled for 
the store. To Install a shipping method, click "Install" under "Action". Once the shipping 
method is installed, you can edit the specifications of that shipping method, or uninstall 
it to remove the shipping method information. 

Editing the shipping method 
Each shipping method needs to be individually edited to meet your shop's shipping 
requirements and to specify the prices for that service. There are a few details that are 
present across all shipping methods: 

Total Set the minimum price for seleting this shipping method. 



Geo Zone the geographical zone that this shipping method is available to. The 
GeoZone can be created or configured at System > Localisation > 
GeoZone in the administration. For more information visit Localisation. 

Status The status determines whether the shipping method will be available in 
the store front. 

Sort Order The sort order affects the placement of the shipping method among other 
available shipping methods. A shipping method with a sort order of 1 will 
be positioned above another shipping method with a sorting order of 2 in 
the store front. 

Shipping methods in the store front 
Editing shipping methods in the administration will affect the shipping methods available 
to customers in both the store front Shopping Cart and Checkout pages. 



Shopping cart 

 

The shopping cart has a special feature called "Estimate Shipping & Taxes" that will 
calculate a shipping payment for a customer's order. See Order totals to enable or 
disable this feature. When a customer enters their regional information, a popup window 
will ask the customer to select a shipping method. In this window, every shipping 
method that is enabled under Shipping Methods will be listed according to their sorting 
order. The store below enabled Free Shipping and Flat Shipping Rates as their two 
available shipping methods. 

 

After the customer applies the shipping, the shipping method and it's cost will be 
displayed under the Totals. 



Checkout 

In Step 4 of the Checkout, the customer will need to select a shipping method before 
finalizing their purchase. The Delivery Method will display every shipping method that 
was enabled in the administration. The store in the screenshot below enabled the Free 
Shipping and Flat rate shipping methods. The shipping methods were positioned 
according to their sorting order, with their prices included on the right side. 

 

Support 

To receive support for the Shipping extensions, visit the Shipping Extension section of 
the support forum. 

Store Themes 

Theme can be installed 
Theme was grouped into extensions list starting from OpenCart 2 (version 2.3). Each 
theme can be edited product dimension, product display limited and description lenght. 
User can go to OpenCart Official Marketplace to buy more themes to stylize the store. 



Install & Enable the themes 
Install method is same as extension, while download the xxxx_theme.ocmod.zip, go 

to installer and upload the zip file. 

After upload the file successfully, go to Extension select Themes on the dropdown list. 

 

Location Module / Item 

Extensions  Extensions  Themes Select Themes on the dropdown list 

Location Module / Item 

Extensions  Installer Upload the xxxx_theme.ocmod.zip in installer page 



 

New theme will be displayed on the list. Click the install button and can be start to edit 
the theme, select the directory and edit the setting of the details. 

Order Totals 

Order Totals Extensions 
You can manage the order total extensions used for orders under Extensions > Order 
Totals. These totals are extra fees that are added to the total sum of an order in the 



store's shopping cart. For more information on order totals, visit Orders. The order total 
extensions below are included with the OpenCart package. 

 

In the image above we can see that Coupon, Store Credit, Reward Points, Shipping, 
Sub-Total, Taxes, Total, and Gift Voucher extensions are enabled. These enabled order 
totals will be included in the checkout section. To disable any of these order total 
extensions, click "Edit". If you want to remove an extension, click "Uninstall". 

Coupon 

Coupons can be added to the order totals page by selecting "Enabled" under "Status". 
The sorting order affects the order that the extension is put in. 

 



Store credit 

Store credit can be added to an order with this extension. The status and sorting order 
can be selected for checkout. 

 

Handling fee 

To include a handling fee with orders, fill in the following information: 

Order Total The total price of the products 

Fee Extra fee when the amount over order total 

Tax Class Set the tax item for the handling fee 

Status "Enabled" or "Disabled" this option 

Sort Order Set the sorting number for the store front in cart page 

 

 



Klarna fee 

To add a Klarna fee include the following information: 

Order Total The total price of the products 

Invoice Fee - 

Tax Class Set the tax item for the handling fee 

Status "Enabled" or "Disabled" this option 

Sort Order Set the sorting number for the store front in cart page 

 

Low order fee 

To include a fee if the order amount is too low, include the following information: 

Order Total The total price of the products 

Fee Extra fee when the amount less than order total 

Tax Class Set the tax item for the handling fee 

Status "Enabled" or "Disabled" this option 

Sort Order Set the sorting number for the store front in cart page 



 

Reward points 

If you want an option to add reward points to order totals, enable under status and 
select a sorting orde. 

 

Shipping 

The shipping estimator will automatically estimate how much shipping will cost and add 
the fee to the order total. 

 

 

Sub-total 

Select the status and sort order of the sub-totals in checkout. 

 

Taxes 

Select the status and sort order of the taxes in checkout. 

 

Total 

Select the status and sort order of the total amount of the order in checkout. 



 

Gift-voucher 

Select the status and the sort order of the gift-voucher option in checkout. 

Order totals in the shopping cart 
The screenshot below displays a basic shopping cart with some specific extensions 
enabled. Coupon, Reward points, Gift Voucher, Shipping, Sub-total, and Total are 
enabled (as seen below). 

 

Support 

To receive support for Order Totals extensions, please visit the Order Totals section of 
the support forum. 

Modifications 



Modifications 
OpenCart modification system allows store owners to extend and edit the system 
functionality without directly editing core files. The modification system works with XML 
modification files formatted in a specific way. An XML modification files gives 
information to the system which file should be changed, which code should be changed 
and what changes to be done to this code. 

To see a list of all the modifications applied to your system go to Extension > 
Modifications 

You can apply modifications either by uploading a single modification file or a 
compressed file containing XML, PHP and SQL scripts. Both of these approaches use 
the Extension Installer as a way to be imported into an OpenCart system. 

Uploading a single modification file 
To install a modification first you need to upload it. Go to Extension > Extension Installer 
and click the upload button. 

 

OpenCart modification files follow a strict naming rules. In order for your modification to 
be accepted by the installer and uploaded to the system it should have a file extension 
of .ocmod.xml. Here is an example yourmodifcation.ocmod.xml 

After clicking upload a popup will open. Locate the modification file on your local drive 
and click Open 



 

If the upload is successful, you will receive a green success message. 

 

To apply the changes characterised by the uploaded modification file navigate to 
Extension > Modifications and click the refresh button at the upper right corner. 

 

Once the modifications are applied you will receive a confirmation in the toolbar as 
shown below: 

 

Uploading a compressed file containing 
modification files 



OpenCart allows users to install third party extension which add new feature or extend 
the default functionality. These extensions are also uploaded through the Extension 
Installer. They should also follow the naming rules for opencart modifications with the 
exception that the file extension is your_modification.ocmod.zip 

Compressed ocmod files, unlike single ocmod.xml files are not always modifying the 
core system files. In those cases the zip contains only dedicated extension files. If the 
extension which is about to be installed requires a modification of some of the core 
system files, besides the dedicated extension files, install.xml file containing those 
changes is added to the zip. 

Here is a sample file and its content of compressed file containing an install.xml and 
install.php files: 

 

 

Here is what those files and folders represent: 

 "upload" 

- The upload folder contains all of the core files of the extension you are about to 
install. 

 "install.php - optional" 

- This is an optional file containing custom php scripts implementing any post-
installation logic if needed. 



 "install.xml - optional" 

- This is the file which describes the changes which your extension will make to 
the core system files. It also creates a virtual copy of each one of them and 
performs the described modifications. 

Installing an extension containing a 
modification file 
Go to Extension->Extension installer and click upload. 

 

Select the correct modification file from your local drive and click "Open" 

 



 

After you verify that the upload is successful you need to navigate to Extension > 
Modifications and click the refresh button. 

 

As mentioned above after successfully applying the modification the system will notify 
you with green success message. 

 

Cron 



What is a cron? 
A cron is a service that allows a user to automatically execute a script at a specific time. 

For example, you can set a particular PHP script to be automatically executed everyday 
at midnight. 

Setup in cPenal 

Set up cron jobs through cPanel using this procedure: 

1. Log on to your cPanel Interface. 
2. Go to 'Advanced' section. 
3. Click on "Cron Jobs". 
4. Select the specific time from the lists provided. 
5. You should enter the command to run in the "Command" field. 

You should make sure to enter the proper command and the full path to the file. 

For example: /user/bin/php/home/user/public_html/cron.php 
If you are not sure the command path, you could ask your hosting angency. 

 

 

Setup in Plesk Panel 

If you are going to create subscription-level task, than you can create cron/windows 
scheduler task in: 

1. Log on to your Plesk Panel Interface. 
2. Go to "Subscriptions" section click "Your Subscription". 
3. Select "Websites & domains" 
4. Click on "Show advanced operations" 
5. Select "Scheduled Tasks" 
6. There will be only one name of FTP user of your subscription 

Pay attention to interface changes for Plesk 11.5 and Plesk 12+ - there is no need to 
open "Show advanced operations". 

The latest Plesk 12.5 provide a lot of options to cover most of the task cases: 



The latest Plesk 12.5 provide a lot of options to cover most of the task cases 

 

Other Plesk versions support only "Run a command" option: 

Plesk 12.0  

 



 
Plesk 11.5

 

If you need just answer, in "Server" -> "Scheduled Tasks" you can choose: 

 FTP user of your subscription mysite.com 
 Your can choose root, but it's not recommended for security reasons. 

For Plesk version below 12.5 to schedule execution of PHP script on Windows there is 
two ways: 

1. Direct call of php binary with your script as argument. 
Path to executable file: C:\Program Files (x86)\Parallels\Parallels 
Panel\Additional\PleskPHP55\php.exe 
Arguments: path to you script like C:\inetpub\vhosts\domain.tld\httpdocs\script.php 
Note: Pay attention to interpretation path, ...Additional\PleskPHP55\php.exe it path for 
PHP 5.5, you can change PleskPHP55 to PleskPHP5, PleskPHP53 or PleskPHP54 to 
use another PHP version. 

2. Call script via request to your site: 
Path to executable file: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe 
Arguments: -c "(new-object 
system.net.webclient).downloadstring('http://domain.test/script.aspx')" 

Orders 

Managing orders 
When a customer goes through checkout, the information on their order is automatically 
transferred to the Orders section for you to keep track of. In the administration, you can 
view all of the orders made on their site, manually add orders, or edit the details of 
existing orders. 

Viewing order details 



The Orders section is located under Sales > Orders. On this page, every order ever 
made from the store is listed in detail.

The following details are displayed for each order on the list:

 Order ID: a number assigned to an order by OpenCart during the checkout confirmation
 Customer: the name of the customer that made the order.
 Status: update of the status of the order. After the order is initially created the status will 

be "Pending". The default options are M
Chargeback, Complete, Denied, Expired, Failed, Pending, Processed, Processing, 
Refunded, Reversed, Shipped, and Voided.

 Total: the total price of the order.
 Date Added 
 Date Modified 

With the orders included in the list, there is an option to edit, insert, delete, search, or 
print an invoice of an order.

Searching for an order

The "Filter" button under Action helps you find orders based on the information specified 
in the blanks. It can help you locate orders by date added or customer. The "Filter" 
cannot search for orders by product purchased yet. For mor
the Filter tool, see Filter. 

Manually adding/modifying an order
Customer Orders will be automatically updated to the Order section after a customer 
confirms checkout. Though it
orders manually to add new information such as a gift
manually add a new order, click the "Insert" button. To modify a pre
"Edit" under Action. 

The Orders section is located under Sales > Orders. On this page, every order ever 
made from the store is listed in detail. 

The following details are displayed for each order on the list: 

ssigned to an order by OpenCart during the checkout confirmation
: the name of the customer that made the order. 

: update of the status of the order. After the order is initially created the status will 
be "Pending". The default options are Missing Orders, Canceled, Canceled Reversal, 
Chargeback, Complete, Denied, Expired, Failed, Pending, Processed, Processing, 
Refunded, Reversed, Shipped, and Voided. 

: the total price of the order. 

With the orders included in the list, there is an option to edit, insert, delete, search, or 
print an invoice of an order. 

Searching for an order 

The "Filter" button under Action helps you find orders based on the information specified 
in the blanks. It can help you locate orders by date added or customer. The "Filter" 
cannot search for orders by product purchased yet. For more information on 

Manually adding/modifying an order
Customer Orders will be automatically updated to the Order section after a customer 
confirms checkout. Though it is automatically updated, you may want to edit or add 
orders manually to add new information such as a gift-voucher, or add reward points. To 
manually add a new order, click the "Insert" button. To modify a pre-

The Orders section is located under Sales > Orders. On this page, every order ever 

ssigned to an order by OpenCart during the checkout confirmation 

: update of the status of the order. After the order is initially created the status will 
issing Orders, Canceled, Canceled Reversal, 

Chargeback, Complete, Denied, Expired, Failed, Pending, Processed, Processing, 

 

With the orders included in the list, there is an option to edit, insert, delete, search, or 

The "Filter" button under Action helps you find orders based on the information specified 
in the blanks. It can help you locate orders by date added or customer. The "Filter" 

e information on 

Manually adding/modifying an order 
Customer Orders will be automatically updated to the Order section after a customer 

is automatically updated, you may want to edit or add 
voucher, or add reward points. To 

-existing order, click 



Customer details

The first section for modifying an order is called Customer Details. Typing in a customer 
name that has already made an account with the store will auto
bringing up their information to fill in the blanks.

Payment details 

If an address has been added to the customer, select their address option under 
"Choose Address". Otherwise the customer address will need to be manually filled into 
the form. 

ustomer details 

The first section for modifying an order is called Customer Details. Typing in a customer 
name that has already made an account with the store will auto-complete the form by 
bringing up their information to fill in the blanks. 

 

If an address has been added to the customer, select their address option under 
"Choose Address". Otherwise the customer address will need to be manually filled into 

The first section for modifying an order is called Customer Details. Typing in a customer 
complete the form by 

 

If an address has been added to the customer, select their address option under 
"Choose Address". Otherwise the customer address will need to be manually filled into 

 



Shipping details 

This section tracks the shipping address for this particular order. If the shipping and 
payment address are the same, copy and paste the information above when adding it 
manually. 

Products 

In "Choose Product", begin typing the product name. A drop down list will appear with 
products containing that name. Selecting a product from this list will bring up specific 
product options for this order.

Vouchers 

If a customer wants to add a gift voucher order, it will ask them for the following 
information. 

 

This section tracks the shipping address for this particular order. If the shipping and 
payment address are the same, copy and paste the information above when adding it 

duct", begin typing the product name. A drop down list will appear with 
products containing that name. Selecting a product from this list will bring up specific 
product options for this order. 

If a customer wants to add a gift voucher order, it will ask them for the following 

This section tracks the shipping address for this particular order. If the shipping and 
payment address are the same, copy and paste the information above when adding it 

duct", begin typing the product name. A drop down list will appear with 
products containing that name. Selecting a product from this list will bring up specific 

 

If a customer wants to add a gift voucher order, it will ask them for the following 

 



Totals 

Under Totals, other contributing payment factors, such as coupons and vouchers, are 
added/subtracted to the order total.

 Shipping and payment methods must already be set up to select a method in the order form. 
Otherwise, there will be nothing to select under Shipping Method and Payment Method.

The sections seen above (such as Coupon, Voucher, Rewards) are extensions that 
were enabled specifically for this form. There is an option to customize the order details 
included in the totals by editing, uninstalling, or enabling specific order total exte

Printing invoices
To print an invoice, go back to the Orders page under Sales > Orders. Above the order 
list on the top right corner is the "Print Invoice" button. Select the order to be printed, 
and click "Print Invoice". This action will direct y
The invoice can be printed out and included in with the shipping.

Recurring Orders

Recurring Orders
Recurring orders are the payments that you as an administrator set for customers that 
have to be billed on a recurring basis. They are setup from
Profiles > Add Recurring Profile

Under Totals, other contributing payment factors, such as coupons and vouchers, are 
added/subtracted to the order total. 

Shipping and payment methods must already be set up to select a method in the order form. 
Otherwise, there will be nothing to select under Shipping Method and Payment Method.

The sections seen above (such as Coupon, Voucher, Rewards) are extensions that 
were enabled specifically for this form. There is an option to customize the order details 
included in the totals by editing, uninstalling, or enabling specific order total exte

Printing invoices 
To print an invoice, go back to the Orders page under Sales > Orders. Above the order 
list on the top right corner is the "Print Invoice" button. Select the order to be printed, 
and click "Print Invoice". This action will direct you to a printable page of the invoice. 
The invoice can be printed out and included in with the shipping. 

Recurring Orders 

Recurring Orders 
Recurring orders are the payments that you as an administrator set for customers that 
have to be billed on a recurring basis. They are setup from Catalog > Recurring 
Profiles > Add Recurring Profile. 

Under Totals, other contributing payment factors, such as coupons and vouchers, are 

Shipping and payment methods must already be set up to select a method in the order form. 
Otherwise, there will be nothing to select under Shipping Method and Payment Method. 

 

The sections seen above (such as Coupon, Voucher, Rewards) are extensions that 
were enabled specifically for this form. There is an option to customize the order details 
included in the totals by editing, uninstalling, or enabling specific order total extensions. 

To print an invoice, go back to the Orders page under Sales > Orders. Above the order 
list on the top right corner is the "Print Invoice" button. Select the order to be printed, 

ou to a printable page of the invoice. 

Recurring orders are the payments that you as an administrator set for customers that 
Catalog > Recurring 



 

To access the Recurring Orders section, click on Sales as shown in the image below: 

 

This section allows you to filter through the recurring payments that you have set to 
recurring profiles. For more information about the profiles - click here. 



 

Order ID: the ID of the order that is associated with the recurring payment. 

Payment Reference: the ID of the recurring profile in PayPal Express (by default). 

Customer: your customer’s name in OpenCart. 

Status: the status of the payment in PayPal. 

Returns 

Adding a new return 
The Return section under Sales > Returns lets you manage merchandise returns. You 
must manually enter the product and return information to create a new return. To insert 
a new return, click the "Insert" button in the right corner above the returns list. 

Return details 

Filling in the Returns Details tab is the first step in creating a new return. The following 
details are required to fill out a return: 

 Order ID: the ID of the order that was returned. 
 Order Date: the date that order was made. 
 Customer 
 First Name 
 Last Name 



 E-mail 
 Telephone 

 

Products 

The Products section fills out more information about the product that was returned, and 
why it was returned. You will need to manually type in the product that the customer 
returned. Typing in "Apple" will bring up all the apple products in the store. We selected 
the Apple Cinema 30" from the drop down, and the "Model" space was auto-completed 
for us. You may also include the quantity, the return reason, whether or not the product 
was opened, the customer's comments, the return action (credit issued, refunded, 
replacement sent), and return status (awaiting products, complete, pending). The return 
status names can be added in the return statuses section. 

 

Editing a return 



Merchandise returns are automatically added to the Returns section when submitted by 
the customer. The Returns form is located in the store front on the Returns page, under 
Customer Service in the footer. 



 

The information filled out in this form will be saved in Sales > Returns. The fields that 
the customer entered above will be included in the same fields when viewing the return 



in the administration. You can edit the status of the return to Awaiting Products, 
Pending, or Completed. When the status is updated in the administration, the customer 
will be able to view the status of their order under My Account > "View your return 
requests" in the store front. 

Customers 

Managing customers 
Shop owners should know who their customers are and how to manage their 
information. In the administration, customer information will need to be stored efficiently 
to remember any transactions made with their account. To access customer 
information, you can log into the administration panel of the OpenCart store. The 
Customer management sections are located under Sales > Customers. There are three 
sections used to manage customer information: Customers, Customer Groups, and IP 
Blacklist. 



 

Customers 
When a customer creates an account or completes the checkout process, OpenCart will 
store their information automatically in the administration to be accessed under 
Sales>Customers>Customers. A complete list of customers will be displayed on this 
page, along with the following information: 

 Customer Name 
 E-mail: Saves the email address for confirmation emails, notifications, newsletters, etc. 
 Customer Group: A designated group of customers used to apply discounts/specials 

and send group emails. 
 Status: Denies or approves customer account login. 
 Approval: Approves the customer account after creation. 



 IP: An address that reveals the location of the customer. 
 Date Added: The date the customer account was created. 

Searching for a customer 

In the case of locating a specific customer, type in the necessary customer information 
in the spaces below. Clicking "Filter" will locate specific customers matching the 
information typed in. This saves you the time of sorting through pages of customers to 
find a specific person. See Filter for more information on the filter tool. 

 

Manually adding a new customer 

Customer accounts usually don't need to be created in the administration panel, since 
account information is stored automatically upon user creation in the store front. You 
might find yourself needing to manually input customer information into Customers. 
Clicking the "Insert" button on the Customer page will lead you to a form where 
customer information can be filled in. 

General tab 

The general tab asks for the customer's basic information: "First Name", "Last Name", 
"E-Mail", and "Telephone". A password must be submitted for the customer to access 
the site privately. Under "Confirm", retype the password. Enabling "Newsletter" will put 
this customer on the e-mail newsletter list. Later on, you can categorize this customer 
into a specific customer group. The customer will be categorized into "Default" if there 



isn't a defined customer group available. The status determines whether or not this 
customer will be allowed to access the store's login. 

 

Adding an address 

Obtaining the customer's address is important for shipping products to the customer. 
Clicking the Green '+' button will add the "Address 1" address form. You may add as 
many addresses as needed with the green button, or remove them with the red '-' 
button. The "First Name", "Last Name", "Address 1", "City", "Country", and 
"Region/State" are required fields in the address form. 



 

When the above fields have been filled in, click "Save" to save the form to the 
administration. You don't need to worry about the customer's IP address for keeping 
track of transactions, unless you need to know your customer's regional location. 

Modifying existing customer information 

The Customer section will mostly be used to modify existing customer information, for 
operations like changing the Customer Group, rather than adding a whole new 
customer. When editing customer information, you can modify general information, 
include new addresses, manage transactions, and add reward points. Under Action, 
clicking "Edit" for a customer listed on the Customer page will direct you to the customer 
information page. You can change customer information in the General tab. 

Managing transactions 

The Transaction tab is where you may manually add a transaction to the customer. To 
do so, enter in the description of the transaction, the amount paid, and click "Add 
Transaction". Every transaction added will be listed in the Transactions tab. 



 

Adding reward points 

If you choose to enable reward points for the store, points may be manually added to 
specific customers in the admin side of your store. Reward points can be added to 
products, which will be assigned to customers once they purchase that product. If you 
choose to add reward points directly to customers, you can include a reason in the 
description and the amount of points under the Reward Points tab. If you need to 
subtract points from a customer, you can enter in a negative number into the points 
field. 

 

A list will be displayed of every addition and subtraction event in the customer's profile. 
The balance will display the total reward points accumulated by the customer. OpenCart 
calculates the balance of negative and positive numbers to subtract from or add to the 
total. 



IP Addresses 

An IP Address will reveal the location of customer's computer network. There are many 
website services available to shop owners, that will give the location for an IP address. 

 The IP address cannot be added or modified for a customer in OpenCart. The IP address will 
be collected from the customer automatically by OpenCart and added to their customer 
information. 

Approving new customers 
Customer accounts need to be approved before they can access their account in the 
store. In the Dashboard page, the amount of customers needing approval is tabulated in 
the Overview section. Go to Sales > Customers > Customers, and find any customers 
that list "No" under the Approved column. Check those customers, and click the 
"Approve" button in the right corner. 

Customer Groups 

Customer Groups 
Customer Groups provide a greater organizational scheme for the customer list. This is 
helpful in selecting customer groups for discounted products and specials in the store; 
and for sending out emails to select customers. 

Adding a new customer group 

The default customer group for OpenCart is called "Default". To create a new customer 
group name, go to the Sales > Customers > Customer Groups page. Above the list, 
click the "Insert" button. You will be directed to a page where you can fill in information 
about the customer group. You can provide a "Customer Group Name" and a 
"Description" for the group. Within this group, you can approve or disapprove customers 
logins into their store account. There is also an option to allow the customer to select 
their company no. or Tax ID. The sorting number determines the position of this group 
among other customer groups. 



 

Adding a customer group to a customer 

In order to apply a customer group to a group of customers, each customer must be 
individually added to the group under Sales > Customers. To add a customer group, 
select the customer and click "Edit" under "Action". In the General tab there is a drop 
down selection for "Customer Group". Select the customer group and click "Save" at the 
top right corner. 

Applying discounts for customer groups to products 

In order to add a discounted price of a product to a particular customer group, the 
product information needs to be edited beforehand. Under Catalog > Products, find the 
product in the list and click "Edit" under "Action". A customer group can be selected 
under "Discount" or "Special" tabs. A discounted price needs to be specified, as well as 
the date start/end to this discount/special. See Products for more information. 

 

IP Blacklist 

IP Blacklist 
OpenCart provides a feature called "IP Blacklist" that will ban an IP address from 
logging into the store. This step may become necessary if the shop is being harassed 
by a fraudulent "customer". If you are experiencing harassment from a particular 
person, their IP address can be copied from the customer list under Sales > Customers 
> Customers. Copy that IP address and go to Sales > Customers > IP Blacklist. Click 



the "Insert" button and paste in the IP address to ban a customer from the store. This 
will stop users of this IP address from logging into the store again. 

Gift Vouchers 

Gift Vouchers 
Gift vouchers can be individually sent to customers through their email by other 
customers in the store front. The customer receiving the gift certificate can use the code 
provided in the email at the shopping cart to deduct the gift voucher amount from the 
order total. To manage the Gift Vouchers of the store, go to Sales > Gift Vouchers > Gift 
Vouchers. 

 Gift Vouchers only have one use per customer. If the customer uses the same code for 
another order, OpenCart will display the warning "Warning: Gift Voucher is either invalid 
or the balance has been used up!" 

General tab 
To create a new gift voucher, click "Insert". The following information will be needed: 

 Code: The code the customer must enter in the Shopping Cart to use the gift 
voucher. 

 From Name: The name of the person sending the gift certificate. 
 From E-Mail: The email of the person sending the gift certificate. 
 To Name: The name of the person receiving the gift certificate. 
 To E-Mail: The email of the person receiving the gift certificate. 
 Theme: The theme of the gift voucher email. 
 Message: A message added in the gift voucher email. 
 Amount: The amount of the gift certificate to be used in the store. 
 Status: Enables or disables the gift voucher. 



 

Voucher history tab 
The voucher history tab displays the use of the gift voucher code in the checkout. The 
Order ID, Customer Name, Amount, and Date Added will be displayed. 

Voucher themes 
The Voucher Themes section alters the image displayed in the email according to the 
theme. In the store front, customers purchasing the voucher for a person can choose a 
theme for voucher. 

 

Emailing a gift voucher to a customer 
Once a gift voucher has been created, you are responsible for sending out the email to 
the customer receiving the gift voucher. After you make sure the customer's email 



information has been filled out in the General Tab, you can send the email by clicking 
"Send" under "Action". If the email was sent, OpenCart will display the message: 
"Success: Gift Voucher e-mail has been sent!". 

 

The screenshot below is how the customer will view the Gift Voucher email in their 
email: 

 

The Code, From Name, Message, Amount fields from the General Tab are included in 
the content of the email. The Birthday Theme selected above is shown in the email by 
the image on the right side. 

Purchasing a gift voucher in the store front 
Customers have the option to buy a gift voucher for their friends and family. They can 
purchase a gift certificate by accessing My Account > Gift Voucher from their account 
page, or through Extras > Gift Voucher in the footer section of any page. 



The information added in the fields above will be automatically stored in the 
administration, once a customer confirms the purchase of the gift voucher. The 
minimum and maximum amounts
the store's settings. See Settings

PayPal 

PayPal 
The PayPal Search section in the OpenCart admin panel allows yo
transactions made to your PayPal account. The section can be accessed under Sales > 
PayPal > Search. 

The information added in the fields above will be automatically stored in the 
administration, once a customer confirms the purchase of the gift voucher. The 
minimum and maximum amounts a voucher can be purchased for is controlled under 

Settings for more information. 

The PayPal Search section in the OpenCart admin panel allows you to search for all the 
transactions made to your PayPal account. The section can be accessed under Sales > 

 

The information added in the fields above will be automatically stored in the 
administration, once a customer confirms the purchase of the gift voucher. The 

a voucher can be purchased for is controlled under 

u to search for all the 
transactions made to your PayPal account. The section can be accessed under Sales > 

 



Note. For the PayPal Search section to work, you need to setup your PayPal Express 
Checkout account. 

Searching transactions
After you click on the Search button under PayPal, you will see the Search section 
where you will have three main sub

The Search by date section allows you to find the transactions you need according to 
the time period they have been completed.

The Transaction section gives you multiple fields to use for finding the transactions you 
need. 

The field named Type contains all the transactions that can be made, as well as their 
status (e.g. Sent, Received, etc). The rest of the fields require specific information about 
a transaction, such as the Email addresses of the buyer and receiver, Receipt and 
Transaction ID, Invoice and Auction item number, Amount and type of currency as well 
as the Recurring Profile ID.

The Buyer Information section requires the personal details of th
Salutation (Mr., Ms.), first, middle, last name and suffix (B.A., Ph.D.).

For the PayPal Search section to work, you need to setup your PayPal Express 
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When you are done filling out the required fields, click on the blue icon in the top right 
corner of the screen, named

It will show you the transaction(s) affiliated with the information that you have input in 
the fields below. 

Marketing 

Marketing 
The Marketing section in your
marketing campaigns you create. To access the section from the dashboard, go to 
the Marketing field, click it, and you will see submenus named Marketing, Affiliates, 
Coupons, Mail. Click on Marketing

The first section you will see is named
track and search the marketing campaigns you have added. We have added an 
example for a marketing camp

You can add your campaigns from the
screen (Option 1). Once you start creating your new marketing campaigns, you will be 
able to search them by Campaign Name, Date Added and 
make additional editing to each campaign using the Edit button at the bottom right 
corner of the screen (Option 2)

When you are done filling out the required fields, click on the blue icon in the top right 
corner of the screen, named Search. 

It will show you the transaction(s) affiliated with the information that you have input in 

section in your OpenCart dashboard allows you to add and track the 
marketing campaigns you create. To access the section from the dashboard, go to 

field, click it, and you will see submenus named Marketing, Affiliates, 
Marketing. 

The first section you will see is named Marketing Tracking. On this page, you can 
track and search the marketing campaigns you have added. We have added an 
example for a marketing campaign named "The Future of Content". 

You can add your campaigns from the Add New button in the top right corner of the 
. Once you start creating your new marketing campaigns, you will be 

able to search them by Campaign Name, Date Added and Tracking Code. You can 
make additional editing to each campaign using the Edit button at the bottom right 

(Option 2). 

 

When you are done filling out the required fields, click on the blue icon in the top right 
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make additional editing to each campaign using the Edit button at the bottom right 



In the section where you add a new marketing campaign, you have several open fields.

1. Campaign Name - choose the name of your new marketing campaign (for our 
example, we used “The Future of Content”).

2. Campaign Description 
example, what is the main subject, what are the goals and methods you will be using).

3. Tracking Code - this code will be generated automatically, but you can edit the field 
and choose a custom number for easier tracking. The URLs below will be automatically 
updated with the number you input.

Tracking Codes
To track your campaigns, the tracking code is added to the end of the URL leading to 
each marketing campaign. You can embed the code into each
your website. 

When you are creating a banner for an advertising campaign in your website or another 
online media platform, you have to create a new marketing campaign. The new 
campaign will be used to track how many clicks you ge
embedding the tracking code in the link to the campaign.

Example. You start advertising in three different media platforms. You will need to add 
a new marketing campaign for each of them, with the name of each media platform you 
are advertising on. That way, you will track how many clicks you get from each of their 
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online media platform, you have to create a new marketing campaign. The new 
campaign will be used to track how many clicks you get and where they came from by 
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a new marketing campaign for each of them, with the name of each media platform you 
are advertising on. That way, you will track how many clicks you get from each of their 
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You start advertising in three different media platforms. You will need to add 
a new marketing campaign for each of them, with the name of each media platform you 
are advertising on. That way, you will track how many clicks you get from each of their 



websites. You simply give them the link with the embedded tracking code of each 
marketing campaign. 

Affiliates 

Affiliate program 
OpenCart gives you the opportunity to set up an affiliate program to promote additional 
traffic to your shop. Affiliates will receive a commission for each time they direct traffic or 
sales to your site. The commission % can be adjusted in the administration under Sales 
> Affiliate. 

Creating a new affiliate 

To create a new affiliate, you may click the Insert button on the Affiliate page. 

General tab 

The first form asks for general information regarding the affiliate. This information can 
be obtained directly from the affiliate through email, or will be added automatically if 
they filled out a form on the Affiliate page: 



 

Payment details tab 

The Payment Details tab configures the commission and payment methods to be paid 
to the affiliate: 

 

Editing an affiliate 

The Affiliate page can be accessed from Extras > Affiliates in the footer section of every 
page. The affiliate will need to create an affiliate account using this page. A form on the 
page includes the same fields seen in the General and Payment Details tabs in the 
admin side. When the affiliate completes the form, the affiliate information will be filled 



into the General and Payment tabs for you to edit. Clicking "Edit" under Sales > 
Affiliates will allow you to edit specific payment or general affiliate information. 

Approving an affiliate 

After the affiliate creates their account in the store front, the affiliate will need to be 
approved by the administrator in the Affiliates section of the administration. 

Coupons 

Coupons 
You may create and designate coupons to specific products or product categories under 
Sales > Coupons. The Coupons page will display a list of all the coupons created in the 
administration. 

 

General tab 

Editing or inserting a coupon will lead the administrator to a form containing the 
following fields: 

 Coupon Name: A descriptive name for the coupon. 
 Code: A code that the customer needs to enter in the shopping cart to use the coupon in 

the store front. 
 Type: The discount can be a fixed amount off, or a percentage off from the total amount. 
 Discount: The number taken off from the purchase total. 
 Total Amount: The amount a customer must reach before using the coupon. 
 Customer Login: Selecting 'yes' requires the customer to be logged into their store 

account to use the coupon. Selecting 'no' will let a customer use the coupon as a guest. 
 Free Shipping: Selecting 'yes' gives the customer free shipping for using the discount 

code. 
 Category: Selecting a product category will apply the discount to all products within that 

category. See Categoriesfor more information on how to create a new product category. 



 Products: Individual products can be selected by entering in the product name in the 
space provided. To remove a product from the discount, click the red minus button in the 
product list below it. 

 Date Start: The first day that the discount can be used. 
 Date End: The last day the discount can be used. 
 Uses per Coupon: Limits how many times the coupon can be used by customers. 
 Uses per Customer: Limits how many times a specific customer can use the coupon. 
 Status: Enables or disables the coupon for use in the store front. 

 

From the information in the General Tab above, we can see that this coupon gives the 
customer a $10 discount to the Acer Aspire product. 

Coupon history 

The Coupon History tab list all the uses of this coupon in the store. The following 
information about each use will be displayed: 

 OrderID 
 Customer 
 DateAdded 
 Amount 



Coupons in the store front 
Adding and editing coupons in the administration affect the use of coupons in the 
Shopping Cart and Checkout in the store front. 

Shopping cart 
To enable the use of Coupons in the store front, the coupon extension must be enabled 
by you under the Order Totalsextension. For the customer to use the "-10.00 Discount" 
coupon, they must first add the product to their cart from the product page, then enter 
the code in the Shopping Cart. They can select "Use Coupon Code", enter the coupon 
code in the space provided, then add "Apply Coupon". 

 

Applying the coupon will subtract the coupon discount from the original total. A newly 
discounted total will be shown under the Coupon(code) total in the order totals section. 

 

Checkout 
The customer will see the coupon discount once more in the Confirm Order step in 
Checkout: 



 

Mail 

Emailing a customer group 
The Mail system in OpenCart lets you send emails to specific customer groups. You can 
use this feature to send newsletters, information on specials, or to communicate any 
type of store information to select groups of customers. Customer groups are especially 
useful in emailing specific groups of people instead of every customer stored in the 
administration. For more information on how to create a customer group, see Customer 
Groups. The Mail page can be accessed from Sales > Mail. 

 

Select the customer group in the "To:" field, create a subject for the email and a 
message, and click "Send". This email will be sent to all the customers with this specific 
customer group selection. 

Settings General 

General Tab 
The general tab under Settings displays the following fields: 

 Store URL: The url of the store. Remember to include the 'http:' in the beginning 
and a '/' at the end. 



 Store Name: The name of the store. This information will be displayed in the 
Contact Us page under the Customer Service section of the footer. 

 Store Owner: The name used in the "From:" section of any email sent from the 
store. 

 Address: The address of the store. This information will be displayed in the 
Contact Us page under the Customer Service section of the footer. 

 E-mail: The store owner's email, or general email for the store, to be used for 
email notifications sent by OpenCart. 

 Telephone: A telephone number for the store. This information will be displayed 
in the Contact Us page under the Customer Service section of the footer. 

 Fax (optional): A fax number for the store. This information will be displayed in 
the Contact Us page under the Customer Service section of the footer. 

  
  

  

Settings Store 

Store Tab 



The store tab under Settings displays the following fields: 

 Title: The name for the store to be displayed in the browser title toolbar. 
 Meta Tag Description: A tag providing a metadata description for the store. 

Meta tags are seen by search engines. 
 Template: Selects the template/theme of the store. OpenCart only has one, 

"default". Themeforest is a great resource for discovering 3rd party templates for 
OpenCart. 

 Default Layout: The default layout type for the store. 
 This is how the Store tab in the System Settings looks like. 

  

Settings Local 

Local tab 
The local tab under Settings displays the following fields: 

 Country: The country the store is located in. 
 Region/State: The region or state the store is located in. 
 Language: The language that the store front will be displayed in. 
 Administration Language: The language that the administration of the store will 

be displayed in. 
 Currency: The default currency prices will be displayed in. 
 Auto Update Currency: Updates the conversion rate between different 

currencies daily. 
 Length Class: The units that product lengths will be displayed in. 
 Weight Class: The units that product weights will be displayed in. 
  



  

  

Settings Option 

Option Tab 
The local tab under Settings displays the following fields: Items, Products, Vouchers, 
Taxes, Account, Checkout, Stock, Affiliates, Returns: 

Items 

 

 Default Items Per Page (Catalog): The number of Catalog items that can be displayed 
in the store front. For example, a '5' will set a default view of 5 products to be displayed 
at a time per Product Category page or Manufacturer page. The customer can 
customize how many products can be viewed at a time in "Show" above the product list 
or grid. In the store front, this number of items per page will alter how many products are 
viewed in the Product Category page, the Manufacturer Page, and the Search page. 



 Default Items Per Page (Admin): The number of Admin items that can be displayed in 
the administration. For example, a '10' will limit the number of customers listed under 
Sales > Customers to 10 displayed per page. This setting will affect the number items 
per page under Catalog > Products, Attributes, Options, Manufacturers, Downloads, 
Reviews, Information; Sales > Orders, Returns, Customers, Affiliates, Coupons, Gift 
Vouchers; System > Layouts, Banners, Users, Localisation; and Reports > Sales, 
Products, Customers, Affiliates. The only way to change how many items viewed per 
page is under this tab. 

Products 

 Category Product Count: Selecting 'Yes' will display how many products are available 
within each subcategory of the parent categories located in the Top Menu. 

 If you have lots of categories, you can gain a significant performance improvement by not 
displaying the Category Product Count. 

 

 Allow Reviews: Selecting 'Yes' allows customers to add reviews for products on their 
product pages. Selecting 'No' will remove this option from the product page. 

 Allow Downloads: Selecting 'Yes' lets customers download a downloadable product 
from the store after confirming the purchase. 

 Allowed Upload File Extensions: This option lets the customer upload specific file 
types to their order. This may be used when the store owner needs the user to upload a 
file to personalize a product. If you need a picture file for the order, you could type in 
"jpg", "gif", or "png" to let the customer upload a image in that format. Leaving this option 
blank will not let the customer upload any file type. If they try to upload a file from the 
upload button on the product page, they will receive the "Invalid file type!" message. 



Vouchers 

 

 Voucher Min:The minimum amount that a customer can enter to purchase a gift 
voucher. The number added will be counted in the default currency. 

 Voucher Max:The maximum amount that a customer can enter to purchase a gift 
voucher. The number added will be counted in the default currency. 

Taxes 

 

 Display Prices With Tax: Selecting 'Yes' will display the estimated tax on the product's 
page under Price. Selecting 'No' will not show the customer the price of taxes until the 
checkout. 

 VAT Number Validate: Validate the VAT identification number if the store is based in 
the EU. 

 Use Store Tax Address: The tax estimate will use either the store's shipping or 
payment address if the user isn't logged into their account with their address information. 

 Use Customer Tax Address: The tax estimate will use the customer's shipping or 
payment address if they are logged into their store account. 



Account 

 

 Customer Group: Select the default customer group that a customer will be sorted into 
when they create an account. To edit a customer's customer group, see Customers. 

 Customer Groups: Lets the customer select what customer group to be assigned to 
when first creating their account. 

 Login Display Prices: Selecting 'Yes' will require the user to create a customer account 
to see the prices of products in the store. Selecting 'No' will let anyone with access to the 
store see the product prices. 

 Account Terms: If "About Us", "Delivery Information", "Privacy Policy", or "Terms and 
Conditions" is selected, the user will have to read and agree to the terms of those pages 
before creating an account with the store. Selecting "None" will let the user create an 
account without agreeing to any terms. 



Checkout 

 

 Display Weight on Cart Page: Selecting 'Yes' will display the weight of a product at the 
top of the Checkout page. For the weight to be displayed, there needs to be a weight 
number added to the product under its Data tab. See Products for more information. 

 Guest Checkout: Selecting 'Yes' enables users to go through the checkout process 
without creating a store account. Selecting 'No' requires the user to create a store 
account before checking out. 

 Checkout Terms: Selecting an Information page listed in the drop down box forces the 
user to agree to the terms of that page in "Step 6: Confirm Order" of checkout. Selecting 
'None' lets the customer confirm their order without agreeing to any terms. 

 Order Editing: the amount of days that the admin is allowed to edit the order in the 
administration. See Orders for information on how to edit an order. 

 Invoice Prefix: Adds a prefix to each invoice order. OpenCart will add an incremental 
number to the end of the prefix for every invoice. For more information on how to print an 
invoice, see Orders. 

 Order Status: the default status of every order after the customer confirms in checkout. 
The customer can view the status of their order in the store front under My Account > My 
Orders. The status can be edited in the Order section. See Orders for more information. 



 Complete Order Status: the default status for a complete order. 

Stock 

 

 Display Stock: the amount of product left in the store inventory. 
 Show Out Of Stock Warning: displays the an Out of Stock warning on the product 

page in the store front, if the store is out of that particular order. A product will be out of 
stock if its quantity in the Data tab reaches 0. It will reach 0 if the subtract stock option is 
selected. This option subtracts a stock with every purchase of the product. See Products 
for more information. 

 Stock Checkout: lets the customer checkout a product if it is out of stock. 
 Out of Stock Status: lets you choose "2-3 Days", "In Stock", "Out of Stock", "Preorder". 

Affiliates 

 

 Affiliate Terms: makes an affiliate agree to the terms on one of the Information pages in 
order to make an affiliate account. 

 Affiliate Commission (%): the default percentage an affiliate will make from a customer 
purchase. 



Returns 

 

 Return Status: the default status a customer will see in their account after submitting a 
return form under Customer Service > Returns; displays either "Awaiting Products", 
"Completed", or "Pending". 

Settings Image 

Image Tab 
The Image tab under Settings customizes the default images for the store: 

 Store Logo: Upload a store logo from the store or the admin's computer 
using Image manager. 

 Icon: Upload a favicon for the store using Image manager. 
 Image Sizes: Lets you customize the pixel width by length for specific images in 

the store front. Image sizes are now managed at the theme level. For the default 
Opencart theme, these settings can be found in the Opencart admin under 
Extensions->Themes(Extension Type Dropdown) then Edit the Default store 
theme. 

Settings Mail 

Mail Tab 
The mail tab under Settings displays the following fields: 

 Mail Protocol: Lets you choose between sending mail to the host's email, or 
through an SMTP. You should contact your shop's hosting provider to see if 
configure PHP mail. If not, you need to use a SMTP, such as gmail. 

 Mail Paramaters: Asks for the e-mail address for the store if "Mail" was selected 
under Mail Protocol. 

 SMTP Host: The address of the smtp host. 
 SMTP Username: The full email address for the SMTP host 
 SMTP Password 
 SMTP Port: The port number provided by the SMTP host. 



 SMTP Timeout: A timeout number provided by the SMTP host. 
 New Order Alter Mail: Selecting 'Yes' will send a notification email for every 

order submitted in the store front. 
 New Account Alert Mail: Selecting 'Yes' will send a notification email for every 

account created in the store front. 
 Additional Alert E-mails: List any additional e-mails that should also receive the 

notification emails above. 

Settings Fraud 

Fraud Tab 
The Fraud tab under Settings allows you to sign up to use the MaxMind Fraud Detection 
System for OpenCart. Visit MaxMind for more information. 

Settings Server 

Server Tab 
The server tab under Settings displays the following fields: 

 Use SSL: Enable HTTPS on your store. This requires a valid SSL certificate 
installed on your webserver. 

 Used Shared Sessions: Enables session information stored from the shopping 
cart to be shared between multiple domains/stores. 



 Robots: Add or remove bot user agents from accessing shared sessions. 
 Use SEO URL's: Enable OpenCart's SEO keyword functionality for information, 

category, manufacturer and product pages. This requires a correct .htaccess file. 
 Allowed File Extensions: Add or remove the file formats that can be uploaded 

to your store's server. 
 Allowed Mime Types: Add or remove allowed mime types. 
 Allow Forgotten Password: Allows admin to request a new password if it is 

forgotten. 
 Maintenance Mode: Restrict viewing your store front to logged in admin users 

while you make changes to your store. 
 Encryption Key: Enter a combination of numbers and letters to encrypt private 

information. 
 Outpout Compression Level: The level of HTTP compresion to be used in your 

HTTP headers. 
 Display Errors: Whether to display the PHP errors, warnings and notices 

produced by your store. This should be set to "No" for a live store. 
 Log Errors: Whether to log PHP errors, warnings and notices produced by your 

store. 
 Error Log Filename: If Log Errors is set to "Yes", the file where errors will be 

logged. 
 Google Analytics: Enter the code provided for the store site from the store's 

Google Analytics account here. 



 
Layouts 

Layouts 
The OpenCart default store provides the following page layouts: 

 Account 
 Affiliate 
 Category 
 Checkout 
 Contact 
 Default 
 Home 
 Information 
 Manufacturer 
 Product 
 Sitemap 



If you haven't done so already, you should take some time to
become familiar with layouts available in OpenCart, you should visit the different page 
types of your store front. The Manufacturer page layout has a different type of layout 
than the Checkout page, whi
and so on. It's good to see how these layouts arrange themselves, to discover how 
positioning a module from the Extensions section will affect the overall look of the page.

Creating a layout page from scratch takes some knowledge of web design and 
development. Once a layout page has been created, you should upload the files with an 
FTP client. 

The location of the layout pages in the default theme is visible under 
/catalog/view/theme/default/template/ in the OpenCart directory. You can see that all the 
page layouts from the default are included as folders above. To add a new layout page, 
you would need to upload the files under a new layout folder.

After the new layout page is uploaded to the location above, it can added to the store by 
clicking the "Insert" button under System > Design > Layout. The new layout will require 
a layout name, the store the layout will be added to, and a route. The route is the folder 
name that the layout files are included in. OpenCart knows to search for the folder 
under /catalog/view/theme/default/template/ in the store directory, so only the folder 
name is required. 

If you haven't done so already, you should take some time to browse the store front
become familiar with layouts available in OpenCart, you should visit the different page 
types of your store front. The Manufacturer page layout has a different type of layout 
than the Checkout page, which has a different page layout than the Information page, 
and so on. It's good to see how these layouts arrange themselves, to discover how 
positioning a module from the Extensions section will affect the overall look of the page.

om scratch takes some knowledge of web design and 
development. Once a layout page has been created, you should upload the files with an 

The location of the layout pages in the default theme is visible under 
/catalog/view/theme/default/template/ in the OpenCart directory. You can see that all the 
page layouts from the default are included as folders above. To add a new layout page, 

d need to upload the files under a new layout folder. 

After the new layout page is uploaded to the location above, it can added to the store by 
clicking the "Insert" button under System > Design > Layout. The new layout will require 

e the layout will be added to, and a route. The route is the folder 
name that the layout files are included in. OpenCart knows to search for the folder 
under /catalog/view/theme/default/template/ in the store directory, so only the folder 

browse the store front. To 
become familiar with layouts available in OpenCart, you should visit the different page 
types of your store front. The Manufacturer page layout has a different type of layout 

ch has a different page layout than the Information page, 
and so on. It's good to see how these layouts arrange themselves, to discover how 
positioning a module from the Extensions section will affect the overall look of the page. 

om scratch takes some knowledge of web design and 
development. Once a layout page has been created, you should upload the files with an 

 

The location of the layout pages in the default theme is visible under 
/catalog/view/theme/default/template/ in the OpenCart directory. You can see that all the 
page layouts from the default are included as folders above. To add a new layout page, 

After the new layout page is uploaded to the location above, it can added to the store by 
clicking the "Insert" button under System > Design > Layout. The new layout will require 

e the layout will be added to, and a route. The route is the folder 
name that the layout files are included in. OpenCart knows to search for the folder 
under /catalog/view/theme/default/template/ in the store directory, so only the folder 



 

Clicking "Add Route", then "Save" will make the new layout available in the store. 
See Modules for more information on how to add a module to a specific layout page. 

Banners 

Banners 
Banners are pictures containing linkable images displayed in the store's store front. 
Banners can be utilized to catch the customer's eye and direct them to special products 
in the store. The Banners page under System>Design>Banners lets you customize the 
images and links displayed on the banners. 

Using banners in modules 

The Modules section uses banners for two modules: Carousel and Banners. The 
Banners section lets you customize what page layout the banner will be included, and 
its position. The Carousel module acts like a slideshow, or carousel. The customer can 
click an arrow to look through a range of product images. 

If you want to create a new carousel banner displaying all the manufacturer logos, you 
need to go to System>Design>Banners, and click "Insert". After coming up with a 
banner name for later reference, you would to click "Add Banner" to add a new icon to 
the banner. The following fields are needed to add a new icon to the banner: 

 Title: when the customer hovers their mouse over the icon, the title will be displayed. 
 Link: the address of the page that the customer will be directed to when clicking on the 

icon in the banner. In this case, you would want to link the image to a banner page. The 
link doesn't need the "www.store.com" portion of the link. 

 Image: add an image using the Image manager. 

 

You may add as many banners to the banner as necessary. Under Modules, you can 
edit the Carousel to display the "Manufacturers Banner". The image below is the 
screenshot of the home page after the Carousel was assigned the Manufacturers 



banner. All the manufacturer logos that were added to the Manufacturers banner in the 
administration can be scrolled through in the store front. 

 

It its a advised that you test the links by clicking on the images on the banner. If the 
clicks do not direct the user to the manufacturer location, double check to see if the 
page address was typed in correctly in the administration. 

Users 

Users 
Managing the in's and out's of the admin side of an online store can be quite the task for 
just one person to handle. You may find it necessary to assign administration side 
permissions to specific people on your team. The User section lets you customize which 
users can access the admin side of the store, and what sections can be accessed or 
modified by them. 

User groups 



Before you begin creating user profiles, you should visit System > Users > User Groups 
to set specific access and modification permissions. 

OpenCart lets you customize which admin side pages can be accessed by the specific 
user groups. You must check which pages can be accessed under Access Permission, 
and which page content can be modified under Modify Permission. The pages in the 
box office are displayed according to the top menu sections. For example, 
catalog/attribute is the Attribute section under Catalog in the top menu of the 
dashboard. 

 Be aware that checking sections in Access Permission lets the user see the information on 
those pages. If a page in Access Permission is selected, but the page in Modify Permission is 
unselected; the user will be able to view the information on the page, but will be unable to 
modify this information. 

For the Co-worker group, we chose to allow access and permit modification to the 
Catalog Section only, but not the rest of the admin panel. 

 

OpenCart provides two user groups installed into the admin side, Top Administrator and 
Demonstration. The Top Administrator has every box checked under Access 
Permission and Modify Permission. It is an intuitive step that users assigned to the Top 
Administrator position would need access to all of the admin pages and permission to 
modify these sections. You can choose to leave the group unchanged, or unselect 
categories for this group. The Demonstration user group doesn't have any admin pages 



checked in Access Permission or Modify Permission, meaning users added in this 
group will not be able to access the admin side or modify any features of the shop. 

Users 
With the user groups set up, the individual users can be saved to the administration side 
of your store under System>Users>Users. Clicking "Insert" will bring you to the user 
form below. Aside from the basic user information, a password must be created for the 
user to login to the dashboard. The User Group selected from the drop down box will 
assign specific permissions to the user. The status lets you choose to enable the user to 
be able to login, or disable the user from logging in to the dashboard. 

 

Permission denied 

The user can access the dashboard the same way the administrator would, with the 
exception of entering their specific username and password. See Admin interface for 
more information. 

Our user, John Doe, was assigned to the Co-worker group; meaning he will be able to 
access and modify all the Catalog pages. He will not be able to access Extensions, 
Sales, System, or Reports. The following screenshot displays what John Doe will view 
when he tries to access the Extensions page. 



 

If John Doe was permitted access to this page, but not modify it, the following warning 
message would appear if he tried to save an edit: 

"Warning: You do not have permission to modify categories!" 

User Groups 

User Groups 
As an Administrator, OpenCart allows you to use the User Groups section to set the 
permissions and access of the user profiles. You can access it from your Dashboard by 
clicking on System > Users > User Groups: 

 

In the User Groups section, you can create groups and determine which admin pages 
can be viewed and modified by each group. Note that you must know which pages can 
be accessed or modified with the Access and Modify permissions. 



 

You have two pre-defined user groups in your default OpenCart installation - 
Administrator and Demonstration. While the Administrator group has all the 
permissions, the Demonstration group has none. You can delete both of these groups 
and create new ones. Click on the Action button for one of the user groups to see the 
permission fields. 

 

The Edit User Group section gives you two main fields - Access Permission and Modify 
Permission. Respectively, the Administrator user group has all the access and 
modifying permissions. However, users assigned to the Demonstration group will have 
no permissions to access or modify any of the Admin panel pages. 

 

If you decide that a certain user group should not have modifying permissions, simply 
remove the ticks from the categories you wish to prevent from being modified. 



For example, analytics/google_analytics refers to the Analytics section in the Category 
menu of your OpenCart Dashboard. The same goes for all the rest - they are the Admin 
panel pages of your online store and you can decide which group has the rights to view 
or modify each of the pages. 

Scroll down in each field to see all of the Admin panel pages that you can give and take 
away permissions for. 

To create a new user group, go back to the main User Groups section and click on the 
Add New button on the top right side. 

 

After you assign a User Group Name, you will see that you can setup the permissions 
right away, while you are opening a new user group. 

 

To learn how to assign users to user groups, see the Users documentation page for 
more information. 

API 

API 
For using OpenCart API you should enable it previously, via admin part of you're site. 
Go to System->Users->API and you'll see a predefined user named "Default". 



Edit it - and the are no API-key so generate it, by pressing the button and set "Status" to 
enable. 
Next, add you'r IP to list of permitted for API access on another tab. 

API is avaliable via URL like 

http://myopencart.example.com/index.php?route=api/cart/add 

where route is using choose appropriate controller. 

NOTES: 

 API users always have customer_id as '0'. And have the own api_id. 
 I'll us python-requests library for this examples, but the main idea is describing 

parameters so console curl will be fine enough. 
 And in descriptions I'll assume what we have "oc_" prefix on DB tables. 

Firstly, you can and definitly should get token for you session - you'll get cookie file and 
OpenCart server will identify activity by this way. 

import requests 

 

s = requests.Session() 

 

username = 'Default' 

key='L3MYyzlYMRL8gBcpCm6CdrVarFUXtPORZkJKP7vgaY8M8EIZWOr3EJxq' 

# Actually, key is 256 character-long 

 

s.post( 

    'http://myopencart.example.com/index.php?route=api/login', 

    data={'username':username, 'key':key} 

).text 

If everything was done right, you'll get json-response with api_token for you'r session. 
Check site admin API page, edit API user and open "Sessions" tab - you can see 
established session. 

Now, what you can do with OpenCart API? 



Login 

api/login 

Establishing session for API user by key PARAMS: 
DATA: 
username:username from oc_api 
key:key from oc_api 
EXAMPLE: 

 

session.post( 

    'http://myopencart.example.com/index.php?route=api/shipping/address', 

    params={'api_token':'768ef1810185cd6562478f61d2'}, 

    data={ 

        'username':username, 

        'key':key 

    } 

) 

Currency 

api/currency 

DESCRIPTION:change session currency 
PARAMS: 
api_token 
DATA: 
currency:code from table oc_currency 
EXAMPLE: 

 

session.post( 

    'http://myopencart.example.com/index.php?route=api/currency', 

    params={'api_token':'768ef1810185cd6562478f61d2'}, 

    data={'currency':'USD'} 



) 

Cart 

api/cart/add 

DESCRIPTION:adding product to cart 
PARAMS: 
api_token 
DATA: 
product_id:product_id from table oc_cart 
quantity:quantity from table oc_cart 
option:option array from table oc_cart 
EXAMPLE: 

 

session.post( 

    'http://myopencart.example.com/index.php?route=api/cart/add', 

    params={'api_token':'768ef1810185cd6562478f61d2'}, 

    data={ 

        'product_id':'100' 

        'quantuty':'1' 

    } 

) 

api/cart/edit 

DESCRIPTION:edit product quantity in cart 
PARAMS: 
api_token 
DATA: 
key:cart_id from table oc_cart  
quantity:quantity from table oc_cart 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/cart/edit', 



  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

        'key':'10' 

        'quantuty':'2' 

    } 

) 

api/cart/remove 

DESCRIPTION:removing product from cart 
PARAMS: 
api_token 
DATA: 
key:cart_id from table oc_cart 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/cart/remove', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

        'key':'10' 

    } 

) 

api/cart/products 

DESCRIPTION:cart content 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/cart/products', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={} 



) 

Coupon 

api/coupon 

DESCRIPTION:apply existing coupon 
PARAMS: 
api_token 
DATA: 
coupon:code from oc_coupon; 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/coupon', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

        'coupon':'2222' 

    } 

) 

Customer 

api/customer 

DESCRIPTION:set customer for current session 
PARAMS: 
api_token 
DATA: 
firstname: 
lastname: 
email: 
telephone: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/customer', 



  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    'firstname':'Dear', 

    'lastname':'Customer', 

    'email':'customer@example.com', 

    'telephone':'+1 879 2548022'} 

    } 

) 

Voucher 

api/voucher 

DESCRIPTION:apply existing voucher 
PARAMS: 
api_token 
DATA: 
voucher:code from oc_voucher; 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/voucher', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

        'voucher':'VOU-7271' 

    } 

) 

api/voucher/add 

DESCRIPTION:add new voucher for current session 
PARAMS: 
api_token 
DATA: 
from_name:from_name from oc_voucher  
from_email:from_email from oc_voucher  
to_name:to_name from oc_voucher  



to_email:to_email from oc_voucher  
amount :amount from oc_voucher in selected currency  
code :code from oc_voucher 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/voucher/add', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

        'from_name':'MyOpenCart Admin' 

        'from_email':'admin@example.com' 

        'to_name':'Dear Customer' 

        'to_email':'customer@example.com' 

        'amount':'100' 

        'code':'VOU-7177' 

    } 

) 

Shipping 

api/shipping/address - 

DESCRIPTIONIPTION:set shipping address for current session 
PARAMS: 
api_token 
DATA: 
firstname  
lastname  
address_1  
city  
country_id  
zone_id 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/shipping/address', 



  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    'firstname':'Customer', 

    'lastname':'Dear', 

    'address_1':'Somewhere', 

    'city':'KLD', 

    'country_id':'RUS', 

    'zone_id':'KGD' 

    } 

) 

api/shipping/methods 

DESCRIPTION:returning avaliable shipping methods 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/shipping/methods', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

) 

api/shipping/method 

DESCRIPTION:set shipping method for current session 
PARAMS: 
api_token 
DATA: 
shipping_method 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/shipping/method', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 



  data={ 

    'shipping_method':'pickup.pickup' 

    } 

) 

Reward 

api/reward 

DESCRIPTION: 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/reward', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    } 

) 

api/reward/maximum 

DESCRIPTION: 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/reward/maximum', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    } 



) 

api/reward/available 

DESCRIPTION: 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/reward/avaliable', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    } 

) 

Order 

api/order/add 

DESCRIPTION:new order by cart content and payment/delivery information has beeen 
set by current session 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/order/add', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

) 

api/order/edit 

DESCRIPTION: 
PARAMS: 
api_token 



DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/order/edit', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    } 

) 

api/order/delete 

DESCRIPTION: 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/order/delete', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    } 

) 

api/order/info 

DESCRIPTION: 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/order/info', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 



  data={ 

    } 

) 

api/order/history 

DESCRIPTION: 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/order/history', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 

    } 

) 

Payment 

api/payment/address 

DESCRIPTION:set payment address for this session 
PARAMS: 
api_token 
DATA: 
firstname  
lastname  
address_1  
city  
country_id  
zone_id 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/payment/address', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 



  data={ 

    'firstname':'Customer', 

    'lastname':'Dear', 

    'address_1':'Somewhere', 

    'city':'KLD', 

    'country_id':'RUS', 

    'zone_id':'KGD' 

    } 

) 

api/payment/methods 

DESCRIPTION:returning avaliable payment methods 
PARAMS: 
api_token 
DATA: 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/payment/methods', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

) 

api/payment/method 

DESCRIPTION:setting payment method of avaliable in api/payment/methods 
PARAMS: 
api_token 
DATA: 
payment_method 
EXAMPLE: 

session.post( 

    'http://myopencart.example.com/index.php?route=api/payment/method', 

  params={'api_token':'768ef1810185cd6562478f61d2'}, 

  data={ 



    'payment_method':'bank_transfer'

    } 

) 

Store Location

Store Location
If your eCommerce website is accompanied by one or more physical stores, you can 
input their location details into your O
users to learn where to find your store.

Starting from the dashboard, click on

You will open the Store Locations
about your physical stores. There are two main fields 
When you are done inputting the details about your store, it will appear in this section. 
You will have an option to Edit

Store Locations
Begin by clicking the Add New button:

'payment_method':'bank_transfer' 

Store Location 

Store Location 
If your eCommerce website is accompanied by one or more physical stores, you can 
input their location details into your OpenCart system. This way, it will be easy for web 
users to learn where to find your store. 

Starting from the dashboard, click on System > Localisation > Store Location:

Store Locations section where you will find all of the inf
about your physical stores. There are two main fields - Store Name and Address
When you are done inputting the details about your store, it will appear in this section. 

Edit the information about a particular store.

re Locations 
Begin by clicking the Add New button: 

If your eCommerce website is accompanied by one or more physical stores, you can 
penCart system. This way, it will be easy for web 

System > Localisation > Store Location: 

 

section where you will find all of the information 
Store Name and Address. 

When you are done inputting the details about your store, it will appear in this section. 
the information about a particular store. 



Store location details
The next section will reveal all the empty fields you have to fill with the details about 
your physical store. The mandatory fields are Store Name, Address and Telephone.

Geocode - this code uses the geographic coordinates of your address. For exa
address like 103 Integer Rd. Corona New Mexico 08219 will be turned into Latitude 
34.249772 and Longitude -
map. 

Fax - input your fax number if you have one.

Store location details 
will reveal all the empty fields you have to fill with the details about 

your physical store. The mandatory fields are Store Name, Address and Telephone.

this code uses the geographic coordinates of your address. For exa
address like 103 Integer Rd. Corona New Mexico 08219 will be turned into Latitude 

-105.603535. Geocoding used to place your marker on the 

input your fax number if you have one. 

 

will reveal all the empty fields you have to fill with the details about 
your physical store. The mandatory fields are Store Name, Address and Telephone. 

 

this code uses the geographic coordinates of your address. For example, an 
address like 103 Integer Rd. Corona New Mexico 08219 will be turned into Latitude 

105.603535. Geocoding used to place your marker on the 



Image - place the image or logo of 

Opening Times - list the opening and closing hours of your store.

Comment - leave any comment you want your customers to know. For example 
"Checks not accepted." 

Showing the store location in the Contact 
Us page 
After you have completed inputting the details of your physical store, go to System > 
Settings > Store: 

Scroll down to the bottom and you will see the field named Store Location. If you want 
the location to be visible in your Contact Us page, enable your location by clicking on 
the tick. 

The location is now active and will be visible in the Contact Us page of your OpenCart 
website. 

place the image or logo of your store for easier recognition. 

list the opening and closing hours of your store. 

leave any comment you want your customers to know. For example 

Showing the store location in the Contact 

have completed inputting the details of your physical store, go to System > 

Scroll down to the bottom and you will see the field named Store Location. If you want 
e in your Contact Us page, enable your location by clicking on 

The location is now active and will be visible in the Contact Us page of your OpenCart 

 

leave any comment you want your customers to know. For example 

Showing the store location in the Contact 

have completed inputting the details of your physical store, go to System > 

 

Scroll down to the bottom and you will see the field named Store Location. If you want 
e in your Contact Us page, enable your location by clicking on 

 

The location is now active and will be visible in the Contact Us page of your OpenCart 



If you want to remove the details of a store, you can select it from the tick on the left 
hand side and click the Delete button in the top right corner.

Localisation Language

Language 
The language section lets you manage the languages available for the store front. 
OpenCart provides English as the default language after installation. To add multiple 
languages to the site you need to install a language pack. Language packs can be 
acquired from the Extension Directory
add a language pack to OpenCart.

The new language can be added to the site under System>Localisation>Language. The 
following information will be needed to save the language:

 Language Name 
 Code: The ISO language code.
 Locale: The code used by browsers to auto

Locale codes can be viewed
 Image: The image used to represent the language, that will be displayed in the 

header area of the store.
 Directory: The location of the language pack (do not include the 

catalog/language path).
 Filename: The name of

If you want to remove the details of a store, you can select it from the tick on the left 
hand side and click the Delete button in the top right corner. 

Localisation Language 

The language section lets you manage the languages available for the store front. 
OpenCart provides English as the default language after installation. To add multiple 
languages to the site you need to install a language pack. Language packs can be 

Extension Directory. See Adding multiple languages
OpenCart. 

The new language can be added to the site under System>Localisation>Language. The 
following information will be needed to save the language: 

The ISO language code. W3Schools has a complete list of ISO codes.
The code used by browsers to auto-detect the language of the site. 

Locale codes can be viewed here. 
The image used to represent the language, that will be displayed in the 

header area of the store. 
The location of the language pack (do not include the 

catalog/language path). 
The name of the language file. 

 

If you want to remove the details of a store, you can select it from the tick on the left 

 

The language section lets you manage the languages available for the store front. 
OpenCart provides English as the default language after installation. To add multiple 
languages to the site you need to install a language pack. Language packs can be 

Adding multiple languages to learn how to 

The new language can be added to the site under System>Localisation>Language. The 

has a complete list of ISO codes. 
detect the language of the site. 

The image used to represent the language, that will be displayed in the 

The location of the language pack (do not include the 



 Status: Enables or disables the language in the store front. 
 Sort Order: Determines the position of the language among multiple languages 

in the header. 

 

Localisation Currency 

Currency 
The currency sections lets you select which currencies are available for use in store 
front. The default currency will display all the product prices in that currency. The 
currency preference can be changed by the customer in the header section of any page 
in the front office. 

In the store below, we have enabled the Euro, Pound, and US Dollar. 

 

The following information is needed about a currency to add it to your store: 

 Currency Title 
 Code: The ISO code for the currency. Currency codes can be looked up at 

this currency converter. 
 Symbol Left: Adds a currency symbol to the left of the code. 
 Symbol Right: Adds a currency symbol to the right of the code. 
 Decimal Places: The amount of decimal places displayed in the price of the 

store front. 
 Value: The Default currency will be set to a value of 1. Every value of currency 

will be relative to this value. Since the US Dollar is 1.0 (the default), the Euro is 



tabulated to .81 for the value based on its worth. When OpenCart transitions 
between currencies in the store front, it will use the value number to calculate the 
prices of products in that new currency. OpenCart will update the currency values 
in the Local Tab under store settings if Auto Update Currency is enabled. 
Visit Settings for more information. 

 Status: Enables or disables the currency in the store front. 

 

Localisation Stock Status 

Stock status 
In this section you may create Out of Stock statuses to be displayed on the product 
page when a product is out of stock. The stock status name is arbitrary. 

The default stock status for Out of Stock products can be edited under the option tab 
in Settings. The specific Out of Stock Status for a product can be edited in the Data tab 
in Products. 

Localisation Order status 

Order status 
Similar to the stock status, when an order is confirmed by the customer they will need to 
see an order status. The order status can be accessed from their account page in the 
store front. After the order status names are created, they can be selected 
under Orders. 

Localisation Returns 



Returns 
The Returns section allows you to create the return statuses, return actions, and return 
reason names that may be selected in return requests. See Returns for more 
information on how these return names are used. 

Localisation Countries 

Countries 
239 countries are stored in the Country section with the OpenCart installation. These 
countries can be used to estimate shipping and taxes when a customer enters in their 
location. Each country can be individually disabled, removing them from the store front, 
by editing them. The countries can be deleted as well. The only issue with deletion of a 
country is that the country information will be deleted with it. If you wanted to make that 
country available for shipping, you would have to re-enter the country's information; 
whereas enabling a disabled country is easier. 

Localisation Zone 

Zone 
3948 zones are included with install. Zones are specific regions of countries, such as a 
state or province. Creating zones helps estimate taxes and shipping in the store front. 

 

Localisation Geo zone 

Geo zone 
Geo zones are customized zones used in calculating shipping and taxes. Multiple 
countries and zones can be added to one geo zone to customize shipping methods. 

The geo zone below is used to combine the west cost states of the United States into 
one zone. The west coast of the US consists of California, Oregon, and Washington 



states. Each individual state is added by selecting the Country, Zone, then clicking "Add 
Geo Zone". 

 

See Shipping for more information on how geo zones are used. 

Localisation Taxes 

Taxes 
The Taxes section in Localisation allows the administrator to create the taxes that will 
be applied to specific products in the store. 

Tax rates 

The tax rate will be used to calculate the taxes from an order. The following information 
is needed to save a tax rate to the administration: 

 Tax Name: A name for the tax that will be displayed in the store front when taxes are 
added to order total. 

 Tax Rate: A number value for the tax. 
 Type: Determines whether the number value in Tax Rate is a fixed amount or a 

percentage of the total amount of an order. 
 Customer Group: Selecting a customer group will add this tax to all the customers 

within this group. Multiple customer groups can be selected at once. 
 Geo Zone: Selecting a Geo Zone will apply the tax to the regions and countries within a 

Geo Zone. 

 



Tax class 

Tax classes can store multiple tax rates into one category. The taxes can be 
customized to calculate the taxes based on the payment address (customer) or the 
store's address. Tax classes require the following information: 

 Tax Class Title 
 Description 
 Tax Rate: selecting "Add Rule" will add a tax rate that was created in Tax Rates. Base 

On requires either the payment address or the store address to be selected. This will 
determine the amount of tax added to the shopping cart total in the store front. Priority 
determines the position of the tax rate if other tax rates are listed with it. 

 

The tax class must be added to each product individually in order to apply tax rates for a 
purchase. The tax class field is located under the Data tab in Products. See Products 
for more information. 

Localisation Length class 

Length class 
Length classes are used to assign length specifications to products in the Data tab. The 
values added to products will be displayed in the product page in the store front. The 
following information is required to create a new length class: 

 Length title: The name of the length measurement, (i.e. Centimeter) 
 Length unit: The units of measurement (i.e. cm) 
 Value: Set 1 for the default value. Every value added to other lengths, such as 

km, will need to be relative to that. There are 10 mm in one 1cm, so the value of 
mm would be set to 10. 

Store Location 

Store Location 



If your eCommerce website is accompanied by one or more physical stores, you can 
input their location details into your OpenCart system. This way, it will be easy for web 
users to learn where to find your store.

Starting from the dashboard, click on

You will open the Store Locations
about your physical stores. There are two main fields 
When you are done inputting the details about your stor
You will have an option to Edit

Store Locations
Begin by clicking the Add New button:

Store location details
The next section will reveal all the empty fields you have to fill with the details about 
your physical store. The mandatory fields are Store Name, Address and T

e is accompanied by one or more physical stores, you can 
input their location details into your OpenCart system. This way, it will be easy for web 
users to learn where to find your store. 

Starting from the dashboard, click on System > Localisation > Store 

Store Locations section where you will find all of the information 
about your physical stores. There are two main fields - Store Name and Address
When you are done inputting the details about your store, it will appear in this section. 

Edit the information about a particular store.

Store Locations 
Begin by clicking the Add New button: 

Store location details 
The next section will reveal all the empty fields you have to fill with the details about 
your physical store. The mandatory fields are Store Name, Address and T

e is accompanied by one or more physical stores, you can 
input their location details into your OpenCart system. This way, it will be easy for web 

System > Localisation > Store Location: 

 

section where you will find all of the information 
Store Name and Address. 
e, it will appear in this section. 

the information about a particular store. 

 

The next section will reveal all the empty fields you have to fill with the details about 
your physical store. The mandatory fields are Store Name, Address and Telephone. 



Geocode - this code uses the geographic coordinates of your address. For example, an 
address like 103 Integer Rd. Corona New Mexico 08219 will be turned into Latitude 
34.249772 and Longitude -
map. 

Fax - input your fax number if you have one.

Image - place the image or logo of your store for easier recognition.

Opening Times - list the opening and closing hours of your store.

Comment - leave any comment you want your customers to know. For example 
"Checks not accepted." 

Showing the store location in the Contact 
Us page 
After you have completed inputting the details of your physical store, go to System > 
Settings > Store: 

this code uses the geographic coordinates of your address. For example, an 
address like 103 Integer Rd. Corona New Mexico 08219 will be turned into Latitude 

-105.603535. Geocoding used to place your marker on the 

input your fax number if you have one. 

place the image or logo of your store for easier recognition. 

list the opening and closing hours of your store. 

leave any comment you want your customers to know. For example 

Showing the store location in the Contact 

After you have completed inputting the details of your physical store, go to System > 

 

this code uses the geographic coordinates of your address. For example, an 
address like 103 Integer Rd. Corona New Mexico 08219 will be turned into Latitude 

105.603535. Geocoding used to place your marker on the 

 

leave any comment you want your customers to know. For example 

Showing the store location in the Contact 

After you have completed inputting the details of your physical store, go to System > 



Scroll down to the bottom and you will see the field named Store Location. If you want 
the location to be visible in your Contact Us page, enable your location by clicking on 
the tick. 

The location is now active and will be visible in the Contact Us page of your OpenCart 
website. 

Scroll down to the bottom and you will see the field named Store Location. If you want 
the location to be visible in your Contact Us page, enable your location by clicking on 

The location is now active and will be visible in the Contact Us page of your OpenCart 

 

Scroll down to the bottom and you will see the field named Store Location. If you want 
the location to be visible in your Contact Us page, enable your location by clicking on 

 

The location is now active and will be visible in the Contact Us page of your OpenCart 

 



If you want to remove the details of a store, you can select it from the tick on the left 
hand side and click the Delete button in the top right corner.

Localisation Language

Language 
The language section lets you manage the lang
OpenCart provides English as the default language after installation. To add multiple 
languages to the site you need to install a language pack. Language packs can be 
acquired from the Extension Directory
add a language pack to OpenCart.

The new language can be added to the site under System>Localisation>Language. The 
following information will be needed to save the language:

 Language Name 
 Code: The ISO language code.
 Locale: The code used by browsers to auto

Locale codes can be viewed
 Image: The image used to rep

header area of the store.
 Directory: The location of the language pack (do not include the 

catalog/language path).
 Filename: The name of the language file.
 Status: Enables or disables the language in the s
 Sort Order: Determines the position of the language among multiple languages 

in the header. 

If you want to remove the details of a store, you can select it from the tick on the left 
hand side and click the Delete button in the top right corner. 

Localisation Language 

The language section lets you manage the languages available for the store front. 
OpenCart provides English as the default language after installation. To add multiple 
languages to the site you need to install a language pack. Language packs can be 

Extension Directory. See Adding multiple languages
add a language pack to OpenCart. 

The new language can be added to the site under System>Localisation>Language. The 
following information will be needed to save the language: 

The ISO language code. W3Schools has a complete list of ISO codes.
The code used by browsers to auto-detect the language of the site. 

Locale codes can be viewed here. 
The image used to represent the language, that will be displayed in the 

header area of the store. 
The location of the language pack (do not include the 

catalog/language path). 
The name of the language file. 

Enables or disables the language in the store front. 
Determines the position of the language among multiple languages 

If you want to remove the details of a store, you can select it from the tick on the left 

 

uages available for the store front. 
OpenCart provides English as the default language after installation. To add multiple 
languages to the site you need to install a language pack. Language packs can be 

Adding multiple languages to learn how to 

The new language can be added to the site under System>Localisation>Language. The 

has a complete list of ISO codes. 
detect the language of the site. 

resent the language, that will be displayed in the 

The location of the language pack (do not include the 

Determines the position of the language among multiple languages 

 



Localisation Currency 

Currency 
The currency sections lets you select which currencies are available for use in store 
front. The default currency will display all the product prices in that currency. The 
currency preference can be changed by the customer in the header section of any page 
in the front office. 

In the store below, we have enabled the Euro, Pound, and US Dollar. 

 

The following information is needed about a currency to add it to your store: 

 Currency Title 
 Code: The ISO code for the currency. Currency codes can be looked up at 

this currency converter. 
 Symbol Left: Adds a currency symbol to the left of the code. 
 Symbol Right: Adds a currency symbol to the right of the code. 
 Decimal Places: The amount of decimal places displayed in the price of the 

store front. 
 Value: The Default currency will be set to a value of 1. Every value of currency 

will be relative to this value. Since the US Dollar is 1.0 (the default), the Euro is 
tabulated to .81 for the value based on its worth. When OpenCart transitions 
between currencies in the store front, it will use the value number to calculate the 
prices of products in that new currency. OpenCart will update the currency values 
in the Local Tab under store settings if Auto Update Currency is enabled. 
Visit Settings for more information. 

 Status: Enables or disables the currency in the store front. 



 

Localisation Stock Status 

Stock status 
In this section you may create Out of Stock statuses to be displayed on the product 
page when a product is out of stock. The stock status name is arbitrary. 

The default stock status for Out of Stock products can be edited under the option tab 
in Settings. The specific Out of Stock Status for a product can be edited in the Data tab 
in Products. 

Localisation Order status 

Order status 
Similar to the stock status, when an order is confirmed by the customer they will need to 
see an order status. The order status can be accessed from their account page in the 
store front. After the order status names are created, they can be selected 
under Orders. 

Localisation Returns 

Returns 



The Returns section allows you to create the return statuses, return actions, and return 
reason names that may be selected in return requests. See Returns for more 
information on how these return names are used. 

Localisation Countries 

Countries 
239 countries are stored in the Country section with the OpenCart installation. These 
countries can be used to estimate shipping and taxes when a customer enters in their 
location. Each country can be individually disabled, removing them from the store front, 
by editing them. The countries can be deleted as well. The only issue with deletion of a 
country is that the country information will be deleted with it. If you wanted to make that 
country available for shipping, you would have to re-enter the country's information; 
whereas enabling a disabled country is easier. 

Localisation Zone 

Zone 
3948 zones are included with install. Zones are specific regions of countries, such as a 
state or province. Creating zones helps estimate taxes and shipping in the store front. 

 

Localisation Geo zone 

Geo zone 
Geo zones are customized zones used in calculating shipping and taxes. Multiple 
countries and zones can be added to one geo zone to customize shipping methods. 

The geo zone below is used to combine the west cost states of the United States into 
one zone. The west coast of the US consists of California, Oregon, and Washington 
states. Each individual state is added by selecting the Country, Zone, then clicking "Add 
Geo Zone". 



 

See Shipping for more information on how geo zones are used. 

Localisation Taxes 

Taxes 
The Taxes section in Localisation allows the administrator to create the taxes that will 
be applied to specific products in the store. 

Tax rates 

The tax rate will be used to calculate the taxes from an order. The following information 
is needed to save a tax rate to the administration: 

 Tax Name: A name for the tax that will be displayed in the store front when taxes are 
added to order total. 

 Tax Rate: A number value for the tax. 
 Type: Determines whether the number value in Tax Rate is a fixed amount or a 

percentage of the total amount of an order. 
 Customer Group: Selecting a customer group will add this tax to all the customers 

within this group. Multiple customer groups can be selected at once. 
 Geo Zone: Selecting a Geo Zone will apply the tax to the regions and countries within a 

Geo Zone. 



 

Tax class 

Tax classes can store multiple tax rates into one category. The taxes can be 
customized to calculate the taxes based on the payment address (customer) or the 
store's address. Tax classes require the following information: 

 Tax Class Title 
 Description 
 Tax Rate: selecting "Add Rule" will add a tax rate that was created in Tax Rates. Base 

On requires either the payment address or the store address to be selected. This will 
determine the amount of tax added to the shopping cart total in the store front. Priority 
determines the position of the tax rate if other tax rates are listed with it. 

 

The tax class must be added to each product individually in order to apply tax rates for a 
purchase. The tax class field is located under the Data tab in Products. See Products 
for more information. 

Localisation Length class 

Length class 



Length classes are used to assign length specifications to products in the Data tab. The 
values added to products will be displayed in the product page in the store front. The 
following information is required to create a new length class: 

 Length title: The name of the length measurement, (i.e. Centimeter) 
 Length unit: The units of measurement (i.e. cm) 
 Value: Set 1 for the default value. Every value added to other lengths, such as 

km, will need to be relative to that. There are 10 mm in one 1cm, so the value of 
mm would be set to 10. 

Localisation Weight class 

Weight class 
Similar to length classes, weight classes are used to assign weight specifications to 
products in the Data tab. The following information is required to create a new weight 
class: 

 Weight title: The name of the weight measurement (i.e. Kilogram) 
 Weight unit: The unites of measurement (i.e. kg) 
 Value: Set 1 for the default value.Every value added to other weights, such as g, 

will need to be relative to that value. There are 1000 g in 1 kg, so the value of g 
would be set to 1000. 

Uploads 

Uploads 
To access the Uploads section in your OpenCart admin panel, click on System > Tools 
> Uploads: 



 

The field shows you all of the uploaded files you have in your OpenCart store. They can 
be images, PDF files, etc. 

You have a filter button that sorts the uploaded files according to Upload Name and the 
date on which it has been added. 

 

The Action button on the right side allows you to download the uploaded file from your 
OpenCart store. Respectively, the Delete button allows you to remove the selected file. 

Backup/Restore 



Backup and restore 
One of the most devastating events that can happen to an online store is the loss of a 
database. The store database contains important customer and product information. It 
is difficult for a store to recover after losing a database, and certainly takes up too much 
time to re-enter this necessary information. You need to be vigilant with downloading 
updated backups of the store's database to their computer, just in case something 
happens. 

OpenCart lets you download a backup of the store's current database or restore the 
database to the administration in System>Backup/Restore. The Backup section seen 
below contains all the data tables in the MySQL database available for download. You 
can choose what files you want to download by checking on them. Clicking the 
"Backup" button will download the selected tables to your computer. 

If you need to restore a backup file that you previously saved to your computer, all you 
need to do is click "Choose File" from Restore Backup, select the sql file from their 
computer, and the database will be restored. 

Error Logs 

Error Logs 
If a user experiences an error in the store, the error will be displayed in an error log 
under System > Error Logs. This section can be used by web developers to track errors 
in coding for the store. The error log can get very full over time, so it is a good idea to 
clear the log from time to time. Pressing "Clear Log" will clear the list of errors. 

Orders Report 

Orders Report 
The Orders Report can be accessed through Reports>Sales>Oders. Order information 
is displayed in either daily, weekly, monthly, or yearly increments depending on which 
option you select in the "Group By" drop box. The Orders report displays the following 
information: 

 Date Start:The date of the first day of the week tracked (if set to week in Group 
By). 

 Date End: The date of the last day of the week tracked (if set to week in Group 
By). 

 No. of Orders: The number of orders made through the store between the date 
start and end. 



 No. of Products: The number of products purchased through the store between 
the date start and end. 

 Tax: The amount of taxes paid by customers between the date start and end. 
 Total: The total amount of money made from transcations between the date start 

and end. 

The Filter option can display the order information within a certain space of time using 
Date Start or End, or by order status. 

Tax Report 

Tax Report 
The Tax Report can be accessed through Reports > Sales > Tax. The Tax report 
displays which type of tax is being paid the most by customers in the store front. Tax 
information is displayed in either daily, weekly, monthly, or yearly increments depending 
on which option you select in the "Group By" drop box. 

The Tax Report displays the following information: 

 Date Start: The date of the first day of the week tracked (if set to week in Group 
By). 

 Date End: The date of the last day of the week tracked (if set to week in Group 
By). 

 Tax Title: The title of the tax type used. 
 No. of Orders: The number of orders made through the store between the date 

start and end. 
 Total: The total amount of money paid for taxes by customers between the date 

start and end. 

The Filter option can display the order information within a certain space of time using 
Date Start or End, or by order status. 

Shipping Report 

Shipping Report 
The Shipping Report can be accessed through Reports > Sales > Shipping. The 
Shipping report displays which shipping method is being used the most by customers in 
the store front. Shipping information is displayed in either daily, weekly, monthly, or 
yearly increments depending on which option you select in the "Group By" drop box. 

The Shipping Report displays the following information: 



 Date Start:The date of the first day of the week tracked (if set to week in Group 
By). 

 Date End: The date of the last day of the week tracked (if set to week in Group 
By). 

 Shipping Title: The shipping method used. The shipping title with the highest 
total will be displayed at the top. The lowest total will be at the bottom. 

 No. of Orders: The number of orders made through the store between the date 
start and end. 

 Total: The total amount of money paid for shipping between the date start and 
end. 

The Filter option can display the order information within a certain space of time using 
Date Start or End, or by order status. 

Returns Report 

Returns Report 
The Returns Report can be accessed through Reports>Sales>Returns. The returns 
report shows how many returns were requested within a given time frame. The returns 
information is displayed in either daily, weekly, monthly, or yearly increments depending 
on which option you select in the "Group By" drop box. 

The Returns Report displays the following information: 

 Date Start: The date of the first day of the week tracked (if set to week in Group 
By) 

 Date End: The date of the last day of the week tracked (if set to week in Group 
By) 

 No. Returns: The number of return requests submitted or created between the 
date start and date end. 

Sale Coupon Report 

Sale Coupon Report 
The Coupon Report can be accessed through Reports > Sales > Coupon. The coupon 
report tracks the use of coupons in the store front. 

The Coupon Report displays the following information: 

 Coupon name: The name given to the coupon in the administration. 
 Code: The code that was used to activate the coupon in the store front. 



 Orders: How many orders used this specific coupon. 
 Total: The total amount of all the coupons used. The number is a negative 

number because the customer is using the coupon to receive a reduced price on 
a product or order. 

Clicking "Edit" under "Action" for a coupon will direct you to the coupon information form 
under Sales>Coupons. The coupons can be filtered through a date start and date end. 

Products Viewed Report 

Products Viewed Report 
The Products Viewed Report gives you an idea of what products are being viewed the 
most, or the least, in the store front. You can access this section under Reports > 
Products > Viewed in the administration side. The report will position the top viewed 
product first. Along with the product name and model, the report will display the number 
of customers who viewed that product in the store front, and the percentage of views for 
this specific product out of all the views for products on the site. Clicking "Reset" will 
clear the information below and reset the report to only collect information from that 
moment on. 



 

Report analysis to increase views 

From the report above, you can see that the HP LP 3065 is the most viewed product in 
this store. To increase the views for products in the bottom of the list, you would need to 
have a good grasp of what type of factors were involved to place that specific product 
on top. Was this product advertised on other websites? Was the product image included 
on the product banners on the home page? Were the products added to the related 
products of a product page? Were they given a special discount price to a customer 
group through a newsletter? Most likely, the product with the most views will answer 
'yes' to some of these questions. Typically, the products with the least amount of views 
will have the least exposure on the site out of all the other products. Of course there 
may be other factors involved, but the more a product has exposure on the store's site 
through links and images, the more views a product will probably get. Take advantage 
of the back end features of OpenCart to improve the views for the products of a store. 

Products purchased report 



The Products Purchased Report can be found under Reports > Products > Purchased. 
The report will display the all the products purchased from the store. The products are 
positioned according to the total amount of money acquired for that product: the highest 
at the top and lowest at the bottom. 

 

The Filter button lets you customize which products are shown on the list. Selecting a 
date start and date end will only show the products purchased between those two 
dates. Selecting an order status will display the all the products purchased within a 
status, such as Pending or Completed. 

Customers Online 

Customers Online 
The section Customers Online Report is used to track the activities of the users you 
currently have online in your OpenCart store. 

Important Note! If you do not see any people online, you need to go to System > 
Settings > Edit Store > Option, scroll down to Account and select Yes next 
to Customers Online. 

To access the Customers Online Report section, click on Reports > Customers > 
Customers Online: 



 

Once you access the section you will see a filter allowing you to input an IP address and 
the customer's name you want to track. 

 

The displayed results will contain the following: 

IP: The IP address from which your customer is currently browsing your store. 

Customer: The name of your OpenCart customer. 

Last Page Visited: The page that your customer last visited before leaving. 

Referer: The page your customer previously browsed. 

Last Click: The time and date of the last click of the customer. 



Action: The button under Action will allow you to access your customer’s account. 

Customer Activity 

Customer Activity 
The Customers system in your OpenCart installation allows you to track and manage 
your customers' accounts from the admin panel. The section is accessed 
from Customers > Customers. For more information - click here. 

To view the Customer Activity Report head to Reports > Customers > Customer 
Activity: 

 

This section will show you a list of recent activities. You also have a filter for all of your 
customers and their activity from date to date. You are able to see the account name of 
each customer, their IP address and their type of activity on each date. 



 

Customer: The name of your customer. 

IP: The IP address used by your customer. 

Comment: The type of activity of your customers. For example: John Doe registered for 
an account. 

Customer Order Reports 

Customer Order Reports 
The Order Report section can be accessed under Reports>Customers>Orders. 

The following information will be displayed about customer orders: 

 Customer Name 
 E-Mail 
 Customer Group: The customer group the customer is categorized in. 
 Status: Shows if the customer is currently allowed to login to their store account. 
 No. Orders: The total number of orders made by this customer. 
 No. Products: The total number of products purchased by this customer. 
 Total: The total amount purchased from this customer. Customers are arranged 

on the list from the highest amount to the lowest. 



Clicking "Edit" under "Action" will direct you to that specific customer's edit form under 
Sales > Customer. Customers can be filtered by selecting a start and end date. 

Customer Reward Points Report 

Customer Reward Points Report 
The Order Report section can be accessed under Reports>Customers>Reward Points. 

The following information will be displayed about customer reward point usage: 

 Customer Name 
 E-Mail 
 Customer Group:The customer group the customer is categorized in. 
 Status: Shows if the customer is currently allowed to login to their store account. 
 Reward Points:The amount of reward points obtained by this customer. Reward 

points can be acquired by a customer by purchasing a product with reward points 
designated to it under its Data tab under Catalog>Products. See Reward 
Points for more information. 

 No. Orders: The total number of orders made by this customer. 
 Total: The total amount purchased from this customer. 

Clicking "Edit" under "Action" will direct you to that specific customer's edit form under 
Sales > Customer. Customers can be filtered by selecting a start and end date. 

Customer Credit Report 

Customer Credit Report 
The Order Report section can be accessed under Reports>Customers>Credit. 

The following information will be displayed about customer store credit: 

 Customer Name 
 E-Mail 
 Customer Group:The customer group the customer is categorized in. 
 Status: Shows if the customer is currently allowed to login to their store account. 
 Total: The total amount purchased from this customer. 

Clicking "Edit" under "Action" will direct you to that specific customer's edit form under 
Sales > Customer. Customers can be filtered by selecting a start and end date. 



Marketing 

Marketing 
The Marketing Report can be accessed from Reports > Marketing > Marketing in the 
Admin panel. This report lets you keep track of the marketing campaigns that you have 
created. 

 

The Marketing Report displays the following information: 



 

Date Start: The date that you have selected upon starting your marketing campaign. 

Date End: The date that marks the end of the marketing campaign. 

Order Status: The status of the orders that your marketing campaign has generated. 

 

Campaign Name: The name of your marketing campaign. 

Code: The tracking code that is displayed at the end of the URL of your marketing 
campaign. 

Clicks: The number of clicks that each marketing campaign has generated. 



No. Orders: The number of orders that your marketing campaign has generated. 

Total: The amount of revenue generated from the number of orders. 

Affiliate Commission Report 

Affiliate Commission Report 
The Affiliate Commission Report can be accessed from Reports>Affiliates>Commission 
in the administration. This report lets you keep track of the affiliates who are making a 
commission for referring customers to the store. 

The Affiliate Commission Report displays the following information: 

 Affiliate Name: The name of the individual/company acting as an affiliate for the 
store. 

 E-mail: The e-mail for contacting the affiliate. 
 Status: Shows if the affiliate is enabled or disabled. 
 Commission: The commission amount made from a customer purchase. 
 No. Orders: The number of orders obtained through this affiliate. 
 Total: The total amount that this affiliate has earned through the affiliate 

program. 

Clicking "Edit" under "Action" will direct you to the affiliate information form under 
Sales>Affiliates. Affiliates can be filtered through a date end and date start. 

Affiliate Activity 

Affiliate Activity 
Your affiliate program is designed to bring additional traffic, customers and sales to your 
store. The affiliates are created and managed from Marketing > Affiliates. For the 
exact details - click here. 

To view the Affiliate Activity Report head to Reports > Marketing > Affiliate Activity: 



 

This section will show you a filter for all of your affiliates and their activity from date to 
date. You are able to see the name of each affiliate, their IP address and their type of 
activity on each date. 

To track their activity, your affiliate will need to create an account in your website. 

The Affiliate Activity Report will indicate their transactions, when they logged in, etc. 

 



Affiliate: The name of your affiliate. 

IP: The IP address used by your affiliate. 

Comment: The type of activity of your affiliate. For example: John Doe logged in. 

Developing Modules 
Writing OpenCart modules can be a very good way to learn how the fundamentals of 
OpenCart actually work. Just as the rest of OpenCart, modules follow the MVCL design 
pattern. This documentation guide will describe how you use each of the MVC-L 
components to create the admin and frontend parts of your module. The easiest way to 
create a module is to download the DIY Module Builder skeleton from HostJars. This 
module contains the directory structure, files, and instructions on how to understand and 
build your own modules. This page is a more theoretical guide. 

Basic directory structure 
The basic file structure for your module will be divided into two sections, the admin and 
the catalog folders. The contents of each folder will follow the MVC-L framework 
respectively, with the difference that the admin will deal solely with backend 
functionality, and the catalog with frontend functionality. Users of your module will 
interact and configure its settings in the administration side of the store. Therefore, the 
files in the admin folder will handle any changes to its settings, the way the module is 
displayed in the administration, install/uninstalling the module, etc. Likewise, the way 
the module is displayed and how it works in the front end of the store will be handled by 
the files in the catalog folder. 



 

The image above displays a skeleton of the directory structure that your module should 
follow. A good way to get started with your module is to duplicate the folder structure 
and create the files above. What will go in those files is determined by what your 
module is trying to accomplish, but the basic functionality is detailed in the sections 
below. 

Admin module functionality 
When a store owner uses your module, they will want to edit the module's configuration 
options in the admin in order to decide which layouts to display the module on, whether 
it is enabled or disabled, and any module specific options. As the module developer, 
you will need to create the admin page where the module may be edited and the 
configuration options added or adjusted. 

All admin files are located in the admin/ folder. You will find four folders within the 
admin/ folder: 

1. controller 
2. view 
3. language 
4. model 



All modules will require at least a single file in each of the view and controller folders. 
Most will require a file in each of the model and language folders. Usually the files have 
the same name, except the view file has a different suffix (.tpl). We will go through these 
files one by one. 

 

Controller 

The first file you make will be the controller for your module's admin interface page. 
OpenCart identifies existing modules automatically, simply by reading the 
admin/controller/module folder of your store. Any modules existing in this folder will 
automatically be shown on the Modules page, and on the User Permissions, page. You 
may call your controller file my_module.php. 



The controller file is the place where you can load the language files to convert text into 
variables to be utilized in the template file. In the diagram above, you can see the 
$_['text'] variable being handled by the controller, then sent as $text to the view. You will 
also utilize multiple model files and their class functions here, including your module's 
model file if it has one. For more information on loading files see Loading files in the 
controller. 

You may also have a function defined as public function install(). This function will be 
triggered when the install link is clicked on the Extensions > Modules page. Similarly, a 
function defined as public function uninstall() will be triggered when the uninstall link is 
clicked. You can use these functions to create and remove any structures (such as 
database tables or config settings) required by your module. It is good practice to create 
an uninstall function to clean up any changes your module has made. To see the 
specific code for an install(), uninstall(), visit Install/Uninstall a module. 

Accessed via URL 

The controller is the only file in the MVC-L framework to be accessed by URL in 
OpenCart. In the administration, the URL will look like 
/admin/index.php?route=module/my_module&token. The admin adds a token to the 
URL, whereas the link in the catalog will not have it. As a result, the controller file will 
have a function defined as public function index(). This is a publicly accessible 'page' 
that is loaded by the URL, which will be shown when the Edit button is clicked, and 
where the view form will submit to. The submitted data will be processed in this function 
and saved to the `settings` database table through the controller's config object. 

View 

The second required file for your module's admin interface is the view file. This will be 
created in the admin/view/template/module folder, and will have the suffix .tpl. This is 
standard for OpenCart view files. In this file you will create a form for the user to fill out 
and submit. It will be submitted to the module controller's index function. The easiest 
way to create your view file is to copy and paste an existing, similar view file, and edit 
the form to contain the correct fields for your module's configuration options. You may 
call your view file my_module.tpl. 

In the view, you will be able to access the text from the language that the controller file 
stored as a PHP variable. See Loading Files in the Controller for the code on how to do 
so. 

Model 

It is uncommon for modules to require a model file on the admin side. However, if your 
module relies on its own database table, or a custom query to create data of a particular 
format, then you may find yourself writing a model file. An example of this may be if you 
are writing a visitor counter module, where each visitor is stored in a database table with 



their IP address and number of visits. You may then create a model file, with a function 
to define and create this extra table in the OpenCart database. The model file will live in 
the admin/model/module folder. You may call your model file my_module.php, the same 
as your controller and language files. 

Frontend module functionality 
The frontend of your module follows the same pattern as the admin interface just 
described. What you will include in each of your frontend files will largely depend on 
what your module is supposed to do. A module can access any model files that already 
exist in OpenCart, you do not need to write your own database queries if the same 
query already exists. For example, the catalog/product model contains many useful 
queries for fetching products. Using these model functions should be preferred over 
reinventing the wheel. 

A key difference in the frontend of your module, is that your view file will be in the 
catalog/view/theme/(themename)/template/module folder. This is a significantly deeper 
folder structure to the admin view file because of themes. An OpenCart store may have 
many different frontend themes available, but only one admin template. (themename) 

On the frontend part of your module you will have access to the configuration options 
saved by your module, through both the controller's config object, and the $settings 
variable passed to the module controller's index function. You can control aspects of the 
frontend display on the basis of these settings. 

Developing new product feeds 
OpenCart includes several useful Product Feeds in the core, but you may find you 
require a custom format and decide to create your own. Writing OpenCart product feeds 
is very similar to writing OpenCart modules, and can be a very good way to learn how 
the fundamentals of OpenCart actually work. Just as the rest of OpenCart, feeds follow 
the MVCL design pattern. This documentation guide will describe how you use each of 
the MVCL components to create the admin and frontend parts of your product feed. 

Admin feed functionality 
When a store owner uses your product feed, they will want to edit the product feed's 
configuration options in the admin in order to select whether it is enabled or disabled 
and any specific options you make available. As the developer, you will need to create 
the admin page where the product feed may be edited. 

All admin files are located in the admin/ folder. You will find four folders within the 
admin/ folder: 

1. controller 



2. view 
3. language 
4. model 

All product feeds will require at least a single file in each of the view and controller 
folders. Some will require a file in each of the model and language folders. Usually the 
files have the same name, except the view file has a different suffix (.tpl). We will go 
through these files one by one. 

Controller 

The first file you make will be the controller for your product feed's admin interface page. 
OpenCart identifies existing product feeds automatically, simply by reading the 
admin/controller/feeds folder of your store. Any product feed files existing in this folder 
will automatically be shown on the Product Feeds page, and on the User Permissions, 
page. You may call your controller file my_feed.php. 

The controller file will have a function defined as public function index(). This is a 
publicly accessible 'page', which will be shown when the Edit button is clicked, and 
where the view form will submit to. The submitted data will be processed in this function 
and saved to the `settings` database table through the controller's config object. 

You may also have a function defined as public function install(). This function will be 
triggered when the install link is clicked on the Extensions > feeds page. Similarly, a 
function defined as public function uninstall() will be triggered when the uninstall link is 
clicked. You can use these functions to create and remove any structures (such as 
database tables or config settings) required by your feed. It is good practice to create an 
uninstall function to clean up any changes your feed has made. 

View 

The second required file for your feed's admin interface is the view file. This will be 
created in the admin/view/template/feed folder, and will have the suffix .tpl. This is 
standard for OpenCart view files. In this file you will create a form for the user to fill out 
and submit. It will be submitted to the feed controller's index function. The easiest way 
to create your view file is to copy and paste an existing, similar view file, and edit the 
form to contain the correct fields for your feed's configuration options. You may call your 
view file my_feed.tpl. 

Language 

The third file you will usually create for any feed is the language file(s). You will need 
one language file per language that your feed is compatible with. The language file will 
live in the admin/language/<language name>/feed folder. It simply contains a 
PHP associative array called $_, which contains the internal name as the key and the 



translation as the value. You may call your language file my_feed.php, the same as 
your controller and model files. 

Model 

It is uncommon for feeds to require a model file on the admin side. However, if your 
feed relies on its own database table, or a custom query to create data of a particular 
format, then you may find yourself writing a model file. An example of this may be if you 
are writing a visitor counter feed, where each visitor is stored in a database table with 
their IP address and number of visits. You may then create a model file, with a function 
to define and create this extra table in the OpenCart database. The model file will live in 
the admin/model/feed folder. You may call your model file my_feed.php, the same as 
your controller and language files. 

Frontend feed functionality 
The frontend of your feed follows the same pattern as the admin interface just 
described. What you will include in each of your frontend files will largely depend on 
what your feed is supposed to do. A feed can access any model files that already exist 
in OpenCart, you do not need to write your own database queries if the same query 
already exists. For example, the catalog/product model contains many useful queries for 
fetching products. Using these model functions should be preferred over reinventing the 
wheel. 

A key difference in the frontend of your feed, is that your view file will be in the 
catalog/view/theme/(themename)/template/feed folder. This is a significantly deeper 
folder structure to the admin view file because of themes. An OpenCart store may have 
many different frontend themes available, but only one admin template. (themename) 

On the frontend part of your feed you will have access to the configuration options 
saved by your feed, through both the controller's config object, and the $settings 
variable passed to the feed controller's index function. You can control aspects of the 
frontend display on the basis of these settings. 

Loading files in the controller 
In OpenCart's MVC-L framework, your module's controller is the glue connecting your 
language, model, and template files to each other. The controller is responsible for 
grabbing the text contained in the language file and making them accessible as PHP 
variables in the view's template file. In addition to inheriting the functions available in the 
controller's parent class, Controller, you can also load any of OpenCart's default model 
files and their functions in the controller. In this documentation, we will show the PHP 
code needed to load language and model files and their functions. 



Loading the language file 
The controller brings the text stored in the language file, and turns them into variables 
that can be echoed in the template file to displayed text. This is especially useful for 
managing translations of your module. Instead of modifying your .tpl file every time you 
have a new translation to change each piece of text inside, you just need to modify the 
text in your language file, and the variables will remain the same in the controller and 
the template. 

The piece of code below will load the language file inside in your module's controller. 
Inside the parentheses you will need to include the path to the language file from inside 
the language folder. 

$this->load->language('module/my_module'); 

It is important to remember that the admin controller will only load the admin language 
file, but not the catalog language file; and likewise the catalog controller will only load 
the catalog language file. Once the language file is loaded into the controller, you can 
store its text into a php variable with the use of the $data array. The $this->language-
>get('text') will grab the text from the $_['text'] variable inside of the language file. 

$this->data['text'] = $this->language->get('text'); 

The $this->language->get('text') will grab the text from the $_['text'] variable inside of the 
language file we just loaded above. Every element of the data array will be converted 
into its own variable. The $data['text'] will become $text for the template file inside view. 
The $text variable can be echoed in the view's .tpl file wherever needed: 

<p><?php echo $text; ?></p> 

Setting the heading title 

The following code will set text from the language file as the heading title of the page: 

$this->document->setTitle($this->language->get('heading_title')); 

This will grab the text for the variable $_['heading_title'] stored in the module's language 
file. 

 If you need the text to be stored as a php session variable, use $this->session->data['text'] 
instead of $this->data['text']. 

Loading model files 
Loading model files into your controller file will allow your module to utilize OpenCart's 
built-in functions. The functions inside the model files interact with the store's database 
and to add/pull important information for your module. We recommended that you to 



take advantage of these functions, rather than making your own DB queries. Take some 
time to explore the model folders in both the admin and catalog files, to see which files 
may benefit your module's purpose. For example, if your module needs to pull product 
information from the store's database, it will be useful to load the 
admin/model/catalog/products.php file, since it already has a multitude of helpful, built-in 
functions that interact with the store's products in the database. 

Your module can load any model file its controller file using the following code, granted 
that they are in the same admin or catalog folder as the controller. 

$this->load->model('setting/setting'); 

You will need to specify the path to the file you want to load from the admin folder within 
the parentheses. The code above will load the settings class so we have access to the 
functions within the ModelSettingSetting class in our model's controller file. Use the 
following format in your code to call a function from a loaded model file: 

$this->model_setting_setting->editSetting('my_module', $this->request->post); 

The underscores refer to the file designations for model/setting/setting.php. If you have 
a model file included for your module your code would follow the format mentioned 
above, since the model file is uploaded to model folder. 

$this->load->model(module/my_module.php); 
$this->model_module_my_module->myFunction(); 

The code above will load the my_module.php stored in 
admin/model/module/my_module.php. 

 Instead of using spaces in file names for your module, use underscores. 

Loading template files 
In the controller you will need to load your module's template file in view. To do so, set 
$this->template as so: 

$this->template = 'module/my_module.tpl'; 

Loading library files 
The OpenCart directory contains a collection of library files that can be accessed by 
both the admin and catalog controller files. These files are located under system/library 
in the root folder of the OpenCart store. In the code examples seen inloading the 
language file, both $this->load->language and $this->document give access to functions 
within the language.php and document.php files in the library folder. If you want to 
access a function in a library file you need to call it using $this->[insert library file name]-
>function() in the controller class. 



Additional information 

For more information on the concept of 
how the controller behaves within the 
MVC framework or in the context of 
developing a module for OpenCart, see 
the Introduction and Developing 
Modules. To see how loaded files can be 
utilized in a basic module, see the DIY 
Module from HostJars 
 
Updating OpenCart 
OpenCart is periodically updated with new versions of itself. It is a good idea to update 
your store with each new version released to take advantage of bug fixes and new 
features. It may seem like a hassle to update the shop every time a new version comes 
out, but it is worth the effort in the long run. There are ways to avoid the pain of 
upgrades, such as using quality themes and modules that do not modify your OpenCart 
core, or using vQmod. 

This guide will explain how to upgrade from the v2.x.x up to the latest version of 
OpenCart 3. Versions earlier than 1.5.4 will not be included since they are no longer 
available. 

Checking the requirements for the new 
version 
To see if the a store with an older version can upgrade to the newest version, your web 
server needs to meet the basic technical requirements. To see the latest technical 
requirements for the latest version of OpenCart, 3.0.x, see System requirements. 

 BACKUP YOUR EXISTING STORE FILES AND DATABASE!! 

1. Backup your database via your store Admin->System->Backup, press  Download the 
database. 



2. Backup your files using FTP file copy or use cPanel filemanager to create a zip of all the 
existing opencart files and folders. 

Updating from 2.x.x to 3.0.x 

1. Download the latest version of OpenCart and upload ALL new files on top of your current 
install EXCEPT your config.php and admin/config.php.  
- #1 Backup and Remove all of 2.x.x views files. Because OpenCart 3 is start to use 
TWIG to replace the TPL format. 
- #2 Before upgrade the latest version, you should double check the existing extensions 
(in your store) are compatibility with latest version or not. Please contact the developer 
for enquiry before you upgrade. 
- #3 Not only the extensions, all the themes in OpenCart 2 cannot use in OpenCart 3. 
You should set your store theme to default theme and disabled all of the extensions first. 

2. Browse to http://yourstore.com/install Replacing yourstore.com with your actual site 
(and subdirectory if applicable). 

3. You should see the OpenCart Upgrade script. 
- If you see the OpenCart Install page, then that means you overwrote your config.php 
files. Restore them from your backup first. Then try again. 

4. Click UPGRADE, after a few seconds you should see the upgrade success page  
- If you see any errors, report them immediately in the forum before continuing. 

5. Clear any cookies in your browser 
6. Goto the admin side of your store and press Ctrl+F5 or Ctrl+Shift+R for several times to 

refresh your browser cache. That will prevent oddly shifted elements due to stylesheet 
changes. Login to your admin as the main administrator. 

7. Goto Admin->Users->User Groups and Edit the Top Adminstrator group. Check All 
boxes.  
- This will ensure you have permissions for all the new files. 

8. Goto Admin->Extensions->Extensions->Theme enabled and save the default theme 
again. 

9. Goto Admin->System Settings  
- Update any blank fields and click save. 
Even if you do not see any new fields, click save anyway to update the database with 
any new field names. 

10. Other Adjustments that may need to be made, depending on which version you are 
upgrading from and to. These are broken down by which version they were added in. So 
if you are not currently at that version, you may need to make changes. 

11. Load the store front and again press CTRL+F5 3x times to refresh your browser cache. 
That will prevent oddly shifted elements due to stylesheet. (If you skip step 8, you will get 
the error message.) 

 

 


